Razer DeathAdder 3500, on OSX Lion, Scroll Wheel Problems!

Discussion in 'Mac and PC Games' started by Killery96, Aug 8, 2011.

  1. Killery96 macrumors 6502

    Joined:
    Mar 20, 2011
    #1
    Hi, I recently got a new 15" macbook pro. I'm loving it! I also purchased a Razer Deathadder from the Apple store online, and until recently, I was loving it. Unfortunately, it's Scroll Wheel started tweaking out, so that all the time I scrolled, it would simply take the signal as a left click. I changed that in the DeathAdder program, and made sure that the scrolling was scrolling, up and down, like it should have been. However, now, it doesn't even respond to the scroll wheel. This is really a nuisance, and I wish Razer would come up with a fix for it, unless of course I'm just blathering and have overlooked something. Anyone else own the Razer DeathAdder + Lion, and have a fix or a similar experience?

    E.

    p.s - sorry it's a bit off topic, but I've always gotten prompt responses from M.R Gamers, and the DeathAdder is likely to be found on Gamers :p
     
  2. Killery96 thread starter macrumors 6502

    Joined:
    Mar 20, 2011
    #2
    Hi guys, I realized it was something stupid I was overlooking. Nvm! Heh...
     
  3. Hayden. macrumors newbie

    Joined:
    Aug 28, 2011
    #3
    Hi, Killery96, I'm having the same problem. I just installed Lion (10.7.1) on my MacBook Pro 15" and the latest DeathAdder 3500 driver (3.0.0). Would you please explain what you did to solve the problem?
     
  4. Killery96 thread starter macrumors 6502

    Joined:
    Mar 20, 2011
    #4
    My fix was that the button assignments were all screwed up. You need to install the driver 3.0.0 like you have from Razer's website. Then you need to ensure that the following buttons in the main menu function like this:

    1 = Primary Button
    2 = Secondary Button
    3 = (in my case, full screenshot, but you can do an advanced function or turn it off)
    4 & 5 = I recommend using them for letter keys that are relevant to your in game control layouts. I use 'V' for 4 (knife in CoD and Borderlands) and 'G' for 5, (grenade in CoD and Borderlands)

    It's also imperative to make sure that the scrolling (below the button management) is set correctly, that is scrolling up is the "up" function and scrolling "down" is the down function. Also, make sure your sensitivity is correct and calibrated so there's nothing funky there. Restarts generally help, and plugging the mouse in directly through the computer's physical USB port (no expansions) ensures that the settings stay the same. Re-downloading the driver is also a possibility, never know what could be wrong. Hope that solves something...
     
  5. Hayden. macrumors newbie

    Joined:
    Aug 28, 2011
    #5
    I had tried reinstalling the driver and resetting all the settings. I managed to simply not see the "Advance Mouse-wheel Options". It works now. Thanks.
     

Share This Page