Razer Deathstalker not recognized on MBA 2013

Discussion in 'Mac Accessories' started by deltaray, Jul 21, 2014.

  1. deltaray macrumors newbie

    Joined:
    Jan 7, 2010
    #1
    Hey guys, I just bought a Razer Deathstalker Essential yesterday and out of the box, it feels and works great when playing Guild Wars 2!

    However, when I installed Razer Synapse 2.0 on my Macbook Air 2013 13', it keeps telling me to "Please connect a Razer Synapse 2.0 enabled device". I've tried plugging the keyboard on both USB slots but it still won't work. I've also re-installed Synapse a dozen times and nothing seems to work. I've tried to google it, but all the working suggestions are for windows.

    Since Razer products aren't cheap, I just want to get my money's worth and have all features working on my laptop. For now, this Deathstalker is just an overpriced and oversized ordinary keyboard.

    If anyone has any idea how to make this work, please tell me. I would be forever grateful to you!

    Thanks in advance! :)
     
  2. Fietsbel macrumors member

    Joined:
    Aug 8, 2012
    #2
    i'm sorry to say but i would return the product if it is still possible.
    I had a Razor mamba mouse that needed drivers other than the Synapse 2.0 and it was horrible. After i returned it for the third time (defect mouse button) i decided to go for a deathadder 2013 mouse. Since day 1 i had problems with the software, every time there is something broken. Profiles that wont load, devices that doesnt get detected. Shortcuts to mousebuttons disappear etc. etc. Their customer support is horrible and have never ever been any good to me and never came up with a solution.
    Just today i spent 4 hours to get the software back to working, with no good result, tried all different software versions, other solutions, but nothing helps.
    "no devices detected" , but when i right mouse click on the razer logo it does see the mouse and sometimes my keyboard. But when opening the app: no devices detected"

    I like the design of their products but the Razer Synapse software is the worst piece of fck crap software i have ever seen. I'll "use" it till the hardware breaks down (AGAIN) and than i will go for a different brand.
    Sorry that i dont have a solution to get it working, but imho is the only solution to return the product and hope razer will improve their software. Which will never happen... as history has been proven.

    Screenshot:
    http://tweakers.net/ext/f/GhcrPfopWJAHNfDTTmBRpMu9/full.png
     
  3. deltaray thread starter macrumors newbie

    Joined:
    Jan 7, 2010
    #3
    A lot of people have been saying that. I was kind of excited getting my first Razer product, hoping that it would be a good buy, but it seems that I'm completely wrong.

    I did try to use it on a MBP 2008 that is on Windows 7 Bootcamp. I was able to install Synapse 2.0 and it worked flawlessly. I did have troubles updating the firmware/software at first. It kept saying that I did not have internet connection when in fact I do. I decided to use my iPhone's data in hopes that it might do the trick. I can't return the keyboard since it's not technically broken, I'm sure the people where I bought it from will only say that it's not fully Mac-compatible. :(
     
  4. Fietsbel macrumors member

    Joined:
    Aug 8, 2012
    #4
    They cant use that excuse, since Razor admit it is Mac compatible.
    Anyway, try to find Synapse 2.0 (version 1.23.22) its the only version that will work for me, all other versions are showing problems. And dont update it, stick with 1.23.22 and store the installation file!

    Hope it will help you.
     
  5. deltaray thread starter macrumors newbie

    Joined:
    Jan 7, 2010
    #5
    Finding an older version of Synapse 2.0 may be a harder challenge than finding a fix for the 1.25.8 version. Haha

    Anyway, thanks for the advice! I'll try to look for it once I get home. If you still have the installer of the older version, I'd appreciate if you can link/send it to me :)
     
  6. Fietsbel macrumors member

    Joined:
    Aug 8, 2012
    #6

Share This Page