Razer Naga 2014 & Synapse 2.0 problems

Discussion in 'Mac Accessories' started by MidKnight44, Jan 14, 2014.

  1. MidKnight44 macrumors newbie

    Joined:
    Mar 27, 2013
    #1
    I just got a Naga Razer 2014 - when I installed the Synapse 2.0 software it says it needs to update and then it starts to download and install components....and then doesn't stop - it just says its downloading and then installing, then downloading, then installing...repeat!

    If I try to go into offline mode then nothing appears in the Synapse window so I cannot modify the mouse keys in any way.

    Very disappointed this is not working - anyone got any ideas? I have tried uninstalling and re installing but same thing keeps happening :(
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    Razer Synapse software is rather lackluster and so is Razer support. (And that's being polite.) My suggestion is return the mouse and buy a Logitech G600 mouse. You can download the Mac version of the Logitech software directly from Logitech. Logitech doesn't require a network connection to change mouse settings.
     
  3. MidKnight44 thread starter macrumors newbie

    Joined:
    Mar 27, 2013
    #3
    Thanks - that is exactly what I have done. I want the mouse for editing not gaming and the total failure of the Naga software was a big no for me so going to give the Logitech a spin.
     
  4. CaptainAsa, Jan 18, 2014
    Last edited: Jan 18, 2014

    CaptainAsa macrumors newbie

    Joined:
    Jan 18, 2014
    #4
    Synapse

    On mavericks 10.9.1 Ok I tried to install this 2.0 and it did not show up in my applications folder. but the uninstall script did show up in my utilities folder. But when i try to run it it won't let me enter my admen. pass word.
    Also it made little snitch go crazy. razor tried to connect to google, then FaceTime, then it dialed Yahoo after that it tried to connect to razerdriversupport.com. and i mean it does this all the time now.
    i suggest if you install this use little snitch first and watch it go nuts trying to connect to all of your social media to get your info. And it doesn't even install the app for me to use so The mouse is as good as dead.
    How I removed Razer 2.0
    mavericks 10.9.1 Went to finder hit command F. selected search for system files. Found all the files and deleted them but one. the application file that won't show up for me to run was in their hidden away and said it was running so i couldn't delete it. i then deleted the folders in that files content. After that i restarted and then deleted the remaining file. Wow Thanks razer for all that work to make your mouse work and it won't work what a waist of time and money.
    How I make razer Deathaddler work on my mac
    I have bootcamp installed. boot up in windows install Razer Synapse 2.0. register with Razer configure your mouse then restart in Mavericks. Wow It now works only you can't change the settings. HAH Dum hu?
    once you configure the mouse in windows it remembers the settings you give it so you can unplug it and move it to other computers.
    Also you can change the mouse speed in preferences, mouse settings.
    Razer needs to get a fix soon. but remember the razor Synapse is also spyware so beware.
    Installed better touch tool and it wants to control my computer i just do not want programs controlling my computer. I appzaped it.
     
  5. MidKnight44 thread starter macrumors newbie

    Joined:
    Mar 27, 2013
    #5
    So I sent back the Naga - I like the physical mouse but the software was horrendous. Bought the Logitech as suggested here and its awesome - software works flawlessly on my Mac Pro and the mouse is fully programmable to use with my Avid (editing suite) so thank you for the recommendation.
     
  6. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #6
    I have a couple of bug reports on Synapse in to Razer (open support tickets) that have been open for several months now. I don't expect Razer to fix the software any time soon. It was the combination of the bad software quality and the multiple mouse replacements and the replacement process that made me switch to the G600. The laser in one mouse failed. A replacement mouse came in bad and wouldn't let my Mac sleep.

    You're welcome.
     
  7. spaz8 macrumors 6502

    Joined:
    Mar 3, 2007
    #7
    I haven't had any problems with my Naga 2014.. and Synapse 2.0.. Make sure to get the latest build.. from Dec 19 2013? v1.18?

    I'm on 10.6.8 BTW. Works perfectly.. set polling down to 125hz.
     

Share This Page