Razer Naga Epic buttons not working

Discussion in 'Mac Accessories' started by zViiPeR, Aug 29, 2011.

  1. zViiPeR macrumors member

    Joined:
    Jul 30, 2010
    #1
    Hi there :),

    I bought a razor naga epic a couple of days ago and it worked fine for the first few days until this morning when none of the buttons work, only the scroll wheel, but it can still track perfectly. Also, the lighting will not turn on in wired or wireless mode even though the drivers recognise it as being attached both wirelessly and when it is charging. I have already tried reinstalling the drivers and restarting the computer. I am using OS X Lion if that matters. I would appreciate any help anyone can offer.

    Thanks.
     
  2. pionata macrumors 6502

    Joined:
    Oct 12, 2005
    Location:
    Montreal
    #2
    Also got one one week before you, after reloading the mac mouse button 4 and 5 stopped working. They worked on install. Must be a driver bug.
     
  3. pauldy macrumors member

    Joined:
    Jun 8, 2007
    #3
    the drivers don't appear to be lion compatible. I've had similar issues, the disconnected issue should be resolved by updating the mouse firmware to 1.0.3. So far the mouse is usable but not 130 bucks usable right now. Here is to hoping they fix the drivers soon.
     

Share This Page