Razer Orochi mouse does not Auto Switch profiles and macros disappear

Discussion in 'Mac Accessories' started by Libertine Lush, Jul 8, 2010.

  1. Libertine Lush macrumors 6502a

    Joined:
    Nov 23, 2009
    #1
    This is with the latest Orochi drivers and OSX 10.6.4 (and 10.6.3).

    Whether the Orochi is plugged in via USB or Bluetooth, it will not automatically switch between my customized Profiles when I launch the associated programs. The "Auto Switch" radio box is checked for the Profiles in question. Is there any resolution to this?

    I also find that macros I've set up often disappear. Some stay in place, but others consistently vanish. Any fix for this as well?

    Thank you.
     
  2. verbcrunch macrumors newbie

    Joined:
    Jul 8, 2010
    #2
    My Orochi switches profiles OK

    My Orochi switches profiles perfectly. I have specific buttons set for a specific application - it switches back and forth as i click in and out of the application. SO pysched Razer finally provided the ability to program the Orochi on our Macs - couldn't do application specific profiles when programmed on the PC.

    Now i need this ability for the Mamba..
     
  3. Libertine Lush thread starter macrumors 6502a

    Joined:
    Nov 23, 2009
    #3
    Well that's good to know that it can work. Indeed I had googled and found another person saying switching didn't work for him, so I wondered if it was a universal driver issue.

    Though I remain lost on how to troubleshoot this. Maybe I could reinstall the driver. How would I do this? Right click the Orochi icon in Preference Pane and delete? Is that the same as uninstalling the driver?

    Oh, do you have the "Default" profile in your list? I tried checking and unchecking its "Auto Switch" box. No difference.

    Thanks.
     
  4. NewSodEnt macrumors newbie

    Joined:
    Oct 27, 2003
    #4
    Has your profile switching problem been solved?
    I am having the same problem with not auto switching and macros disappearing.
     
  5. Inrianian macrumors newbie

    Joined:
    Oct 10, 2010
    #5
    Razer Orochi Issues

    I am also having problems with my Orochi, but mine are just Macro issues. My Profiles switch fine.
     

Share This Page