Razer Pro 1.6 with Leopard. HELP!

Discussion in 'Mac Accessories' started by Piepz, Oct 28, 2007.

  1. Piepz macrumors member

    Joined:
    Feb 7, 2007
    Location:
    Riga, Latvia
    #1
    Hello,
    Just bought Razer Pro 1.6 mouse, worked just fine with default OS X drivers in Leopard, but buttons 6 and 7 didn't work, so I installed Razer drivers (1.6.5, latest) and now all buttons act like button 1 (main click button). I can change whatever I want in Razer system preferences, but no effect.. Even the scroll-wheel isn't working.
    Please help me, what should I do ? How can I fully remove Razer drivers and revert back to original, because left clicking (or ctrl + click in my case) and selecting "remove razer pane.." doesn't solve anything, still no control over the buttons.
    I'm desperate, please help me! :(

    Thank you in advance!
     
  2. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #2
    I know it sucks, but the mouse doesn't work in Leopard, YET. Please see the developer's site here:
    http://www.razersupport.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=118
     
  3. Lh'owon macrumors newbie

    Joined:
    Oct 24, 2007
    Location:
    New Zealand
    #3
    That does suck, but on the bright side it really does look as if Razer is working on it (surprise! ;)).

    On the front page of RazerPro.com there's a box saying "Calling All Pro|Click and Pro|Type Users - Sign Up Below For Crucial Driver Updates On The Mac OS X Leopard Update", so do that to receive updates.

    Not that I'm advertising for Razer or anything, it really is bad that the Pro1.6 would stop working, but I'm glad we're not getting a wall of silence.
     
  4. Dynamooo macrumors newbie

    Joined:
    Oct 29, 2007
    #4
    Negative!

    I had a Mac Pro prior to Leopard and I also had a Pro Click to go with it. The drivers provided were useless, they recorded two keystrokes when assigning a key to each mouse button. The work around was to click with the right hand mouse button on clear until you were left with one key stroke in the feild.

    I have however just got another Mac Pro and updated it last friday to Leopard. On Monday my new pro click arrived, I didnt install any drivers I just used system preference to assign keys and everything worked fine without the crappy drivers. (Note in both cases the drivers with 1.6.5)

    To me this is interesting in two ways, first razer said they would resolve the driver problem I originally had...... when? Next year?

    The second is Apple Devs beat them at their own game, and to top it off, Razer are soooo in touch with leopard they dont even know when they arent needed!

    Sort Yourselves out Razer very lame. One the plus side the mous rocks, its not some crappy mighty mouse that drops something if I have to lift the mouse, or cant click if somethings under the front edge or hold on this message has a character limit, apple mighty mouse ? Why? ? Really Why?
     
  5. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #5
    I only had one issue with the Razer Pro before this, and it was when it was pre-release and wouldn't accept commands like Copy or Paste. The fixed it.

    Are you sure you don't have a hot key enabled for the action you're trying to program to the mouse? If the hot key IS active, it will override your actions of trying to assign it to the mouse. You have to deactivate the hotkey, assign it to the mouse, then re-enable the hotkey. This particular issue is an OS X issue and not a Razer issue.
     
  6. nawks macrumors newbie

    Joined:
    Oct 2, 2007
    Location:
    Far Far Away.
    #6
    i'm having the exact same issue as the ts! =( one minute i was doing my work on aperture, the next minute after upgrading to leopard, my mouse is most definitely crippled, with no scroll, no right click, no nothing. there are 7 buttons and a scroll, and they all work as the main click function. :mad:

    but i have a friend who's razer pro is working fine. :confused:
     
  7. Knack macrumors newbie

    Joined:
    Feb 22, 2006
    #7
    I had the same issue, too. After I exchanged some angry comments, I went searching for some mouse drivers, and I stumbled upon a gem.

    SteerMouse serves as sort of a 'placebo' driver, but it still makes everything function properly (including acceleration and side buttons). Sadly, you won't be able to take full advantage of the 1600dpi that makes this mouse truly amazing - we just have to wait for Razer to revise their drivers for that.
     
  8. Lh'owon macrumors newbie

    Joined:
    Oct 24, 2007
    Location:
    New Zealand
    #8
    Yay! I just got my Razer this morning. Kind of creepy actually... I went to the door at about 8:10am, and checked to see if it had arrived. It hadn't, so I went down to the computer, turned it on, and tracked the order online with the courier's website. It said "Delivered at 8:11am". The clock on my computer said 8:12am.

    I go back to the front door, and the box is sitting on the mat. :eek:

    Oh, and it's awesome. I'm currently on a stop-gap G3 iMac running 10.2 (!) because my old iMac died and I will be getting a new iMac very soon. It actually works with OSX mouse support – left, right, and mouse wheel are fine, and I can adjust mouse sensitivity in system prefs, although obviously the software isn't compatible.

    I'm hoping the new drivers will be out by the time I get my new iMac with Leopard.
     
  9. I WAS the one macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #9
    I will give it a try, and If it works like you said... to hell with the dpi feature. :)

    I was using a five button Kensington Mouse and then I bought that Razor because it came with seven, at the end I ended with the same quantity of buttons because the old Kensington mouse was combining buttons for a total of seven... so Now I got two mice with same features, but if with this driver I can take full advantage of every mouse and all of that I will be glad!
     
  10. n0d3 macrumors regular

    Joined:
    Oct 12, 2006
    #10
    The drivers from Razer for the 1.6 weren't that great to begin with, during my days on Tiger the sensitivity and mapping were kinda screwed up sometimes.

    Good thing Leopard recognizes the extra buttons so I was able to map Expose to those.
     
  11. shinji macrumors 65816

    shinji

    Joined:
    Mar 18, 2007
    #11
    It works just fine for me...I'm not using Razer's drivers though...just the default Leopard mouse driver.

    I have it setup so pressing the scrollwheel brings up dashboard, pressing the left side button does expose, and the buttons on the right side do page up/page down.
     
  12. iFry macrumors member

    Joined:
    Jul 30, 2006
    #12
    i don't see any options in Leopard for the Razer Pro. it recognizes the mouse, but gives no options for customizing the scroll wheel or extra buttons. is there anything i need to do to use this "default Leopard mouse driver"
     
  13. batmanforever macrumors newbie

    Joined:
    Nov 21, 2007
    #13
  14. ikir macrumors 65816

    Joined:
    Sep 26, 2007
    #14

    Drivers don't work for me.... and withour drivers i can't use buttons on the right part. So i have "only" 5 buttons.
     

Share This Page