Razer Synapse 2.0 driver & Yosemite?

Discussion in 'OS X Yosemite (10.10)' started by Zorn, Aug 16, 2014.

  1. Zorn macrumors 6502a

    Zorn

    Joined:
    Feb 14, 2006
    Location:
    Ohio
    #1
    Anyone else using a Razer mouse with their Yosemite Mac and running into issues with the driver not working? When I go to open the Synapse app, it just has a message saying to "Connect a Synapse capable device." The mappings of the side buttons on my mouse that I set up previously using the app also appear to be gone.

    Anyone know if this is just a thing with Yosemite, or if my install could have gotten corrupted somehow?
     
  2. eXoBrute macrumors regular

    Joined:
    Aug 7, 2008
    #2
    I'm having the same problem with the imperator driver, probably just gotta wait for an update from razor
     
  3. crazyxzer0 macrumors 6502

    Joined:
    Oct 28, 2008
    #3
    I have the same issue with the imperator driver.
     
  4. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
  5. Vaizard88 macrumors newbie

    Joined:
    Sep 17, 2014
    #5
    Same here

    I too had the synapse crash on me. I've yet to resolve it. but it does hinder ones gaming when you have, the Naga, the Orbweaver & the Blackwidow ultimate at factory settings.
     
  6. Noldat macrumors newbie

    Joined:
    Sep 18, 2014
    #6
    I really hope they release an update soon for this. It's really the only thing holding me back from going with Yosemite. Also I really hope they do it soon so it's in place for release.
     
  7. Razgael macrumors newbie

    Joined:
    Oct 3, 2014
    #7
    Same here, the response I got from Razer was pretty much like "you are screwed and have to wait".....so if you have Mavericks don't use the beta for yosemite or you will loose the ability to have your mouse detected. and of course not be able to use your macros
     
  8. aleck macrumors member

    Joined:
    May 6, 2006
    #8
    Yosemite final is out and the drivers do not work at all.

    Left-click button is impossible to use nor change Synapse 2.0 sw. I love the mouse (Orochi 2013) and recommended it to all my friends, but this is really amateurish of them.

    Sent support email, will see what they will say.
     
  9. aleck macrumors member

    Joined:
    May 6, 2006
    #9
  10. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #10
    Is there a way to backup my Synapse settings before I open it and lose everything? Where is the profiles file located?

    I love my Orochi, too, but Synapse is the crappiest buggiest piece of software I have ever seen and their support sucks when reporting these bugs. Every update is like spinning a roulette wheel.
     
  11. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #11
    There was an update today, 1.28.4 but I don't see my issues resolved.

    I'm not having the same crashing problem as you guys. My issue is I'm getting lots of click stuttering thrown in randomly. I made a video here where I click the mouse at a steady beat but you can hear Razor throwing in a lot of double taps: https://www.youtube.com/watch?v=Q0aufF-oFmo

    Interestingly putting a macro on a button prevents this from happening. Unfortunately you can't set one for the left mouse button so this isn't really a solution. Is anyone else getting this same phenomenon?

    Also, are there any mice similar to the small Orochi form factor? I'm thinking of trying another brand because I'm getting so fed up with Razer software issues but I don't know what to try.
     
  12. cosminsel macrumors member

    cosminsel

    Joined:
    Oct 8, 2014
    Location:
    Ontario, Canada
    #12
    I didn't update yet but I've been experiencing random double clicks as well.
     
  13. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #13
    I think this may be the last straw for me with Razer. Can anyone suggest a good alternative mouse to the Razer Orochi? I use a claw/fingertip grip and like the small form factor, not the large palm grip ones. I just want to switch to a brand that actually has decent mac support.
     
  14. mzb4455 macrumors newbie

    Joined:
    Nov 28, 2014
    #14
    I just created an account here to post this.

    So I got a Deathadder last week and I immediately noticed random double left clicks around 10% of the time.

    Whenever I was in any game the double click issue increased to around 80% of every single left click.

    So I thought, well, fck, I'll just get it replaced since it's in warranty, which I did.

    Got the new one a few days ago, and, surprise, random double left clicks 10% of the time. Again, in any game double left click 80% of the time.

    I mean, I can't really have that of a bad luck to receive two faulty Deathadders, it's just too much of a coincidence. It has to be a software issue.

    I've read above some of your had the same problems. Is there any fix to this? Is it expected that some Razer update will fix this or better just ask for the money back?

    Do other people really have the same issue?
     
  15. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #15
    If Razer hasn't updated their driver this far past the Yosemite release their software team blows chunks. There is no excuse at this point with the time they had in the beta and the months since it's been released.

    I've bought at RAT TE mouse and it and the drivers are working flawlessly in Yosemite and I don't even miss my Orochi anymore and I'm not even bothering to check if it's been fixed anymore. I'm done with Razor and I think you should return their crappy unsupported mouse while you can and get something/anything else and not try to wait it out, who knows how much longer they're going to procrastinate. I don't have any confidence they will handle future OSX upgrades any better.
     
  16. mzb4455 macrumors newbie

    Joined:
    Nov 28, 2014
    #16
    Razer Synapse issue confirmed.

    So I just uninstalled Synapse and guess what it's working flawlessly. 0% double clicks no matter what you do, games etc.

    So it's a Razer driver issue 100%.

    Will it be fixed? - Who knows.

    I'm gonna send my back anyway and just buy a mouse from a proper company instead even if they might fix this problem sometimes in the future.
     
  17. cuongnq macrumors member

    Joined:
    Jul 16, 2014
    #17
    Mine work normal but that thing bother me a lot.
    [​IMG]
    How to disable that free gift code?
     
  18. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #18
    None of this surprises me in the least. I tried a 2013 orochi as my mouse last year. Looked great on paper but in practice it was the worst mouse I've ever owned.

    I'm not a gamer, I just wanted an ambidextrous mouse with some side buttons I can map to expose. I was drawn to the Bluetooth capability, but was implemented so terribly I couldn't use it. The mouse would auto sleep way too quickly, and took the better part of 10 seconds to wake up.

    Even using it wired was awful, it would regularly freak out on tracking, synapse never EVER worked right, and their support was abominable.

    I finally gave up and went back to an el cheapo ms wireless mouse and havent had any issues since. Razer was a total waste of money.

    About the only charitable thing I can say is judging by their absurd glowing neon aesthetic, this thing really was only designed for PC gamers, and they probably shouldn't have even attempted the half baked OS X support.
     
  19. cosminsel macrumors member

    cosminsel

    Joined:
    Oct 8, 2014
    Location:
    Ontario, Canada
    #19
    I'm done with Razer and Synapse as well. I've had so many issues with the driver--this latest one is the nail in the coffin.

    Unfortunately for me, I've had my DeathAdder for over a year so I can't return it. As my first "gaming" mouse, it seemed like a good buy for the first few months.

    I've found that USB Overdrive is a good replacement for Synapse since it can do pretty much everything I need it to do.
     
  20. enjourni macrumors newbie

    Joined:
    May 10, 2009
    #20
    Just wanted to chime in that the double-click issue in Yosemite with the razor drivers is absolutely confirmed. I noticed it immediately after upgrading. Thinking my Death Adder was bad, I bought a brand new Naga yesterday. Same issue - random double clicks. Also check out this

    https://www.facebook.com/razer/posts/10153299680927576

    Everyone else is having the same problem.

    I have the latest drivers that are out, which are 1.32.21.

    They better fix this crap soon or I'm going to have to dump razer
     
  21. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #21
    The tards on Razor's software team have had over 5 months to fix this stupid bug and have not. I'm sorry, but with that timespan and the severity of the problem it is clear that their Mac drivers are purposefully being ignored/sidelined. Return their **** and buy another brand that actually gives a **** about mac development, don't give a company that doesn't care about you another cent. I've found R.A.T. drivers to work perfectly on Yosemite from day one and really like the RAT TE. Unfortunately the choices are a bit limited for gaming mice with good mac support. I heard Logitech is usually pretty good, though.
     
  22. ddwwbb macrumors newbie

    Joined:
    Aug 26, 2015
    #22
    I have still been running into issues regarding this even with the new 2.0 Update. I have the Razor Naga Chroma mouse as well as the Anasi Keyboard. I get the same thing. I log in to synapse and its blank with a little green spinner in the middle, then when I install the updates. It hangs out at 50% and then says restart required for this. I do and open and its the exact same thing.

    I have been working with a tech from razor for the past week and I have done almost everything that there is including, Deleting the Razor information in keychain while getting and updating new certificates... Also going into "like he was saying" Users to delete the .rzdata folder information, and I have uninstalled and reinstalled about 50 times. This is a crappy issue and I hope they actually do something because I hate to just throw away my Razor products because of a update that is not ready to be a update yet. This update still today as it stands as 2.0 is like that cheezeit commercial where the cracker just is not ready to be cheddar! Anyway, if anyone has really found the issue and the fix for this, I would appreciate it.

    D
     
  23. truth1ness macrumors regular

    Joined:
    May 8, 2011
    #23
    They still haven't fixed this? If a company can't fix their damn driver a year after a major OS release they don't deserve my business. I'm glad I bailed their ****** platform last year.
     
  24. ddwwbb macrumors newbie

    Joined:
    Aug 26, 2015
    #24
    Yea I would have figured that everyones post was from like Christmas that they might have fixed this, thats why I was asking maybe someone found something to work. :/
     
  25. Chris153, Aug 11, 2016
    Last edited: Aug 12, 2016

    Chris153 macrumors newbie

    Chris153

    Joined:
    Aug 11, 2016
    #25
    Did you ever find an answer for how to backup Synapse settings? I'd like to backup my profiles, but can't find where they are. Nor can I figure out how to disable launch at login... because there doesn't seem to be a .plist in the LaunchAgents folder.

    The latter problem was my primary issue because I'd like to uninstall it for the time being until I need it again, maybe months from now.

    EDIT: My mistake regarding disabling launch at login. The appropriate plist (with the OnDemand item) IS in /Library/LaunchAgents, but not in /Users/[self]/Library/LaunchAgents
     

Share This Page