RE-Downloading App from Store

Discussion in 'Mac Apps and Mac App Store' started by Oldmanmac, Apr 20, 2013.

  1. Oldmanmac macrumors 6502

    Joined:
    Mar 31, 2012
    #1
    I downloaded an app from the App Store. I'm finding that I am missing something from the program and want to re-d/l it. But the App Store says 'Installed' and is greyed out.

    I know that I d/led M Lion several times, so it must be possible.
    How?
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    If you hold down the option key and click the Purchased icon at the top of the App Store window, there's a good chance that the status button for the app in question will change from "Downloaded" to "Download," or from "Installed" to "Install."
     
  3. Oldmanmac thread starter macrumors 6502

    Joined:
    Mar 31, 2012
    #3
    Thanks, but that didn't work. Tried several different key combo, but nada.
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Remove the app completely from your Mac...Use search to find all files related to it.

    Then re-boot the machine and you should be able to download and install the app from the MAS without issue.
     
  5. jrhillma macrumors newbie

    Joined:
    Sep 30, 2012
    #5
    This. I had the same issue when reinstalling ML onto a bare drive. I had backed everything from the original install to an external USB drive using CCC. After I reinstalled ML, I had the USB drive connected. No matter what I tried, I couldn't get App Store to let me re-download my purchased apps.

    At some point it occurred to me that App Store was seeing the apps as installed because it found them on that external drive. I ejected the drive and re-started App Store. All of the "Installed" buttons changed to "Download".

    App Store is apparently very thorough in indexing apps.
     

Share This Page