Re: HandBrake not encoding properly after 10.11 update.

Discussion in 'OS X El Capitan (10.11)' started by TwinCities Dan, Oct 31, 2015.

  1. TwinCities Dan macrumors 603

    TwinCities Dan

    Joined:
    May 19, 2008
    Location:
    Double Parked out front of the Courthouse
    #1
    Found this on the HandBrake forums...

    Re: HandBrake not encoding properly after 10.11 update.
    Postby Drake7 » Sun Oct 04, 2015 9:24 am

    Solution:

    Short background Info:
    The problem with Handrake occurs because the libdvdcss file is missing. It has to be copied in the "lib" folder. But this folder can't be modified.
    This is because El Capitan has introduced System Integrity Protection that prevents certain folders from being removed or modified. You have to disable the System Integrity Protection temporarily.


    1. Disable System Integrity Protection
    + Restart the computer, while booting hold down Command-R to boot into recovery mode.
    + Once booted, navigate to the "Utilities > Terminal" in the top menu bar.
    + Enter "csrutil disable" in the terminal window and hit the return key.
    + Restart the machine and System Integrity Protection will now be disabled.

    2. Download the file "libdvdcss.2.dylib" from thge following URL:
    http://download.videolan.org/libdvdcss/1.2.12/macosx/

    3. Copy the file "libdvdcss.2.dylib" to the "lib" folder

    + Open the hidden folder in the Finder by Go to > go to folder
    + Enter "/usr/lib"
    + Drag the file "libdvdcss.2.dylib" into the "lib" folder
    + Start Handbrake and verify if it can encode protected DVDs again.

    4. Reenable System Integrity Protection
    + Restart the computer, while booting hold down Command-R to boot into recovery mode.
    + Once booted, navigate to the "Utilities > Terminal" in the top menu bar.
    + Enter "csrutil enable" in the terminal window and hit the return key.
    + Restart the machine and System Integrity Protection will be enabled again.
     
  2. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #2
    Please don't follow this instructions. If you really want to use libdvdcss put it in /usr/local/lib/ , you will be able to without disabling SIP.
     
  3. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
  4. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #4
    No, we (the HandBrake developers) do not recommend using libdvdcss, if you want to use it you can, but will do nothing at all on this issue caused by .pkg file we did not make. And there is need for an HandBrake update, because there is nothing to change in HandBrake.
     
  5. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #5
    What is libdvdcss?

    I haven't had trouble encoding on El Capitan, so I am not really sure what this is about, or if the OPs title is stating something for a minority of users?
     
  6. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #6
    It's a library that removes the dvd encryption. It's needed if you want to encode directly from the dvd, instead of ripping it before with makemkv or another ripper.
     
  7. jfer421 macrumors newbie

    jfer421

    Joined:
    Nov 2, 2015
    #7
    I found this folder, but it won't let me change anything within it. I've opened up the info window and unlocked it, but I still can't make any changes. Anyone have any suggestions? I'd really REALLY love to get this fixed, bc I def do not want to pay $50 for a DVD ripper - that's crazy. Thank you to anyone who can help!

    First photo is my current lib folder, after that it's the old one that I found under system migration. Says it hasn't been opened since 2012.

    I'm using a late 2011/early 2012 MBP, running El Capitan (just updated so it's all set there), and I checked the updates for Handbrake as well - nothing there.
    Screen Shot 2015-11-03 at 7.42.35 PM.png
    Screen Shot 2015-11-03 at 7.43.46 PM.png

    Screen Shot 2015-11-03 at 7.38.51 PM.png Screen Shot 2015-11-03 at 7.38.59 PM.png Screen Shot 2015-11-03 at 7.39.08 PM.png Screen Shot 2015-11-03 at 7.39.13 PM.png
     
  8. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #8
    /usr/local/lib , not /usr/lib , you are looking at the wrong folder.
     
  9. KALLT, Nov 4, 2015
    Last edited: Nov 4, 2015

    KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #9
    You might need to create the /usr/local folder yourself, if it is not there. You can use the following Terminal command:
    Code:
    sudo mkdir /usr/local && sudo chflags norestricted /usr/local && sudo chown -R $(whoami):admin /usr/local && mkdir /usr/local/lib
    System migration just contains those components that your system doesn’t allow in system locations anymore. These don’t do anything anymore as long as they are in this folder.
     

Share This Page