Read iMessages handling

Discussion in 'iOS 6' started by IvanX, Aug 13, 2012.

  1. IvanX macrumors 6502

    Joined:
    Mar 10, 2012
    #1
    What cheeses me off with current iteration of iMessage service, and what I hope they wil fix with the next one (preferably iOS 6), is how read iMessages are handled.

    Case in point: during the day I tend to use my iPhone. I get a bunch of iMessages and I respond to them. However, when I use my iPad in the evening (it's offline during the day), those same iMessages flood back in as push notifications as if I've never seen them before. iMessage server knows what iMessages I have read and which ones I have not because, when both devices are connected and a new message arrives, reading it on one marks it as read on the other. Same treatment does not seem to be administered when refreshing iM conversation threads.

    Whereas I am supposed to be able to pick up where I left off, akin to moving between 2 rooms while watching the same movie, I have to bear through equivalent of fast forwarding from where I was when I left this room last time and where I paused in the room I just came from. Personally, I would expect iMessage to silently update my conversations, reflecting unread message count as applicable.
     
  2. Luddicus macrumors newbie

    Luddicus

    Joined:
    Sep 3, 2012
    Location:
    Cotati, CA
    #2
    Yes, my friend, this has finally come to an end in iOS 6. A big relief, isn't it? :)
     
  3. rabbitjetta macrumors member

    Joined:
    Nov 16, 2010
    #3
    I am running iOS 6 beta on my ipad and it still does this... i dont think that they are going to fix it.
     
  4. Vell843 macrumors regular

    Vell843

    Joined:
    Jun 20, 2011
    #4
    Have y'all tried (on iPhone) setting, messages, receicve at phone number only? And then on your iPad receicve at your apple ID only? I don't have an iPad, just an iPhone so not 100% sure if this will work?
     
  5. VTECaddict macrumors 6502

    Joined:
    Sep 15, 2008
    #5
    That is not fixing the problem. Then you have to go through the trouble of using, and telling other people to use, different ways to reach you. It's confusing, annoying, and it breaks the continuity of the conversation. The major appeal of iMessage is to have your conversations sync between every device. Only receiving at your number on your phone and at your Apple ID on your iPad/Mac defeats the purpose. Might as well turn off iMessage and use just an IM program on your iPad then.

    They had better be fixing this in iOS 6. Otherwise once they link phone numbers to Apple IDs for iMessage, iPads and Macs everywhere will be exploding with notifications when people iMessage with their phone numbers.
     
  6. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #6
    My messages are in perfect sync between my 4s, iPad 3, mini and mb

    Obviously I'm on iOS 6 and mlion
     
  7. IvanX thread starter macrumors 6502

    Joined:
    Mar 10, 2012
    #7
    Are you devices connected to the Internet at all times?
     
  8. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #8
    4s, mini and iPad are the mb isn't
     
  9. IvanX thread starter macrumors 6502

    Joined:
    Mar 10, 2012
    #9
    That's the thing: your iOS devices are online and Apple probably added something to Mountain Lion to cater for such situations. In my scenario, iPhone is connected and iPad is not.
     
  10. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #10
    when my mba is connected to wifi and asleep powernap receives all the messages as they come and everything is current when i open it up.

    my ipad and mba when regaining a connection will go thru a process of downloading all messages and during that process will show some as unread but by the time its downloaded everything the notifications are gone.

    It seems that imessage downloads all new messages from the server and then checks to see which ones are unread.
     
  11. jasonmac21 macrumors member

    Joined:
    Jan 15, 2008
    #11
    Very annoying problem. Happens when my MB connects to the internet.
     

Share This Page