Reading files larger than 2GB from a DVD

Bruno123

macrumors newbie
Original poster
Aug 16, 2006
3
0
Hello,

I'm trying to read a 2.5GB file written on a DVD, but MacOSX seems unable to recognise it. The Finder shows a "-- Kb" filesize and "ls -l" in a terminal shows a negative file size.
The file has been written under linux (on a PC) using growisofs. It can be read very well both under linux and windows (on a PC). Is there any "extension" (sorry if my OSX terminology isn't quite right, I'm just an occasional user) that could help. I'm using MacOSX version 10.4.7 (on a PowerPC MacMini). Would more recent version of MacOS solve this?

Thanks,

Bruno.
 

Suzuki

macrumors member
Aug 7, 2006
33
0
United Kingdom
I thought 10.4.7 was the most recent version?

You could use rar or something to compress and split the file into smaller chunks to get it onto the mac?

Or does OS X have difficulty with files larger than 2GB ?
 

Bruno123

macrumors newbie
Original poster
Aug 16, 2006
3
0
Thanks for your comments and suggestions.

Suzuki said:
You could use rar or something to compress and split the file into smaller chunks to get it onto the mac?
Indeed, this would certainly work. However, the reason I'm leaving it in one chunk is to be able to use it straight away, from the DVD, to avoid another copying/merging pass.

Suzuki said:
Or does OS X have difficulty with files larger than 2GB ?
I've just checked and transfered the file to the Mac main HDD from a PC/Linux machine (using sftp). It does support files greater than 2GB (it's in fact 2.2GB). I've also checked the checksum of the file and it's correct. Reading from the DVD remains a problem.
I remember MacOS 9 was unable to handle files larger than 2GB. I think it was due to the HFS/HFS+ format at the time as well. The new HFS format seems not to have this limitation (after this experiment).

Regards,

Bruno.
 

Bruno123

macrumors newbie
Original poster
Aug 16, 2006
3
0
I've just found a partial solution to the problem. Just in case someone is interested...

I was using growisofs (under linux) with the following options: -J and -r (for Joliet and Rockridge respectively). In fact, these are options to mkisofs which is called by growisofs.
Adding "-udf" to the options list makes a DVD that is both ISO9660 and UDF formatted.
Files larger than 2GB on such a DVD seem to be readable using MacOSX (based on a single test, but it works), linux and windows.
It doesn't solve the problems of existing non-UDF DVDs with large files, but at least, it's a good solution for future DVDs.
(For non-linux users, I believe tools like Nero under windows force the use of UDF when there is a file larger than 2GB anyway. I don't know how MacOSX behaves.)

Various searches on the web seem to indicate that ISO9660 is not supposed to be able to handle files larger than 2GB in the actual standard, although I haven't found any reference document to substantiate this claim.
In addition, maybe this has something to do with the level 3 of Joliet (it seems that MacOSX only supports levels 1 and 2 at the moment), whereas the original DVD I tried was regognised as Joliet level 3 under linux.

Regards,

Bruno.
 

erikh

macrumors newbie
May 1, 2005
17
0
Bruno123 said:
I've just found a partial solution to the problem. Just in case someone is interested...
I'd just like to tag onto the end of this old thread, and ask if anyone's found a more robust solution to the problem of reading Joliet Level 3 DVDs?

I found this hint at MacOSXhints, but it seems that it doesn't help at all with the large-file-issue, just the problem of reading ordinary files off of a Joliet3-CD (or DVD). And I found this old Mac OS 9 utility, called Joliet Volume Access, which supposedly gained support for reading >2GB files from Joliet 3-volumes right before development seized back in 2003/04. Apart from that I have found nothing, so I posted a message at the Apple Discussions, here.

So, if anyone has any insight to share, I'd be glad to see a reply either here or there, so that we can inform those that stumble upon this problem in the future... :)
 

solvs

macrumors 603
Jun 25, 2002
5,684
1
LaLaLand, CA
I've had larger than 2GB files on my Mac, transferred them back and forth to DVD, with no problem. I have had issues back and forth with Windows with large files, but usually smaller files work fine on DVDs made with OS X's built in software or Toast. Burning CDs from Windows usually works too, the Mac sees them fine, but I haven't tried DVDs. If you can network the 2 machines, transfer the file, make sure it works on the Mac, then burn to DVD from the Finder and see if that works on other machines. Maybe it's something weird with the Linux software, so keep using the UDF option I guess.
 

erikh

macrumors newbie
May 1, 2005
17
0
solvs said:
I've had larger than 2GB files on my Mac, transferred them back and forth to DVD, with no problem. I have had issues back and forth with Windows with large files, but usually smaller files work fine on DVDs made with OS X's built in software or Toast. Burning CDs from Windows usually works too, the Mac sees them fine, but I haven't tried DVDs. If you can network the 2 machines, transfer the file, make sure it works on the Mac, then burn to DVD from the Finder and see if that works on other machines. Maybe it's something weird with the Linux software, so keep using the UDF option I guess.
Well, I know that the Mac can handle files larger than 2GB, and I know that there are ways to burn DVDs with such files that work on both Windows and Mac (and that this is possible to do on both platforms). And the *only* problem is for the Mac to read Windows-burned DVDs that specifically are made with the Joliet (Level 3) extension. And that is really my only problem... :)

I have actually gotten the movie off from the DVD on the WinXP PC of a colleague of mine, and copied it over the net to my PowerBook. And the large 3GB DV file works just fine. However, I'd hate to do that every time I get one of these DVDs, thus the question still applies; how can I read DVDs with large files that uses the Joliet Level 3 file system extension?

But, hey, thanks anyway; I suppose any information is added to the thred, that may be useful to anyone encountering a similar problem in the future, is beneficial. :D
 

bostonrhino

macrumors newbie
Feb 12, 2008
1
0
Still finding this on latest Leopard - any solutions?

Hi all,
I have been transferring masses of photos and files from my old windows laptop by using the standard windows compressed folder, then burning to RW DVD.
One approx. 2GB zip is failing despite others working on the disk.

When I try to look at the file in Finder the file size field stays at "Calculating Size", and when double-clicked a zero-length file is stored onto Downloads. As per an earlier poster, in Terminal I see a negative file length (-1400214024 bytes).

Any ideas how I can read this file? I have a MBP 2.6.

Thanks.