Really annoying 'identified developer' problem...

NervousFish2

macrumors regular
Original poster
Mar 23, 2014
197
279
UPDATE: Fixed... sorry...!

Hey all,

Weird problem. On my new MacBook Pro, I can't change the associations for any file types. For example, if I want all my PDFs to open in PDF Expert, its telling me that PDF Expert is not from an identified developer. But it is! I bought it off the App Store!

Now, PDF Expert works fine as default for all my PDFs, on my old iMac. But somehow I keep getting the security alert on my new MBP, kicking me back to System Preferences --> Security & Privacy.

The solution that I imagine should work, isn't working -- see this, from PDF Expert:

https://pdfexpert.com/help/117-why-am-i-getting-the-error-message-while-trying-to-open-the-file.html

Any ideas?

Nick
 
Last edited:

chrfr

macrumors G3
Jul 11, 2009
9,185
3,162
Holy hell! This worked! Thanks a lot
Be aware that command completely turns off Gatekeeper functionality. It solves your immediate problem but makes it easier to run insecure apps. In general, it's important to understand commands that you find online before you run them.
 
  • Like
Reactions: MacDawg
Comment

MacDawg

macrumors Core
Mar 20, 2004
19,824
4,503
"Between the Hedges"
Be aware that command completely turns off Gatekeeper functionality. It solves your immediate problem but make it easier to run insecure apps. In general, it's important to understand commands that you find online before you run them.
Great advice here ^^^^
 
Comment

whoisyourdaddy

Suspended
Oct 2, 2018
217
84
UPDATE: Fixed... sorry...!

Hey all,

Weird problem. On my new MacBook Pro, I can't change the associations for any file types. For example, if I want all my PDFs to open in PDF Expert, its telling me that PDF Expert is not from an identified developer. But it is! I bought it off the App Store!

Now, PDF Expert works fine as default for all my PDFs, on my old iMac. But somehow I keep getting the security alert on my new MBP, kicking me back to System Preferences --> Security & Privacy.

The solution that I imagine should work, isn't working -- see this, from PDF Expert:

https://pdfexpert.com/help/117-why-am-i-getting-the-error-message-while-trying-to-open-the-file.html

Any ideas?

Nick
Instead of disabling Gatekeeper, it's better to reset/repair the policy database. Restart your OS after this reset. Open Terminal and execute the following command.

Code:
sudo spctl --reset-default
 
Comment

NervousFish2

macrumors regular
Original poster
Mar 23, 2014
197
279
OK, sorry - I'm not proficient in unix-speak. But if I run your command, whoisyourdaddy, then will that turn gatekeeper on, once again?
 
Comment

BigBoy2018

Suspended
Oct 23, 2018
964
1,819
Be aware that command completely turns off Gatekeeper functionality. It solves your immediate problem but makes it easier to run insecure apps. In general, it's important to understand commands that you find online before you run them.
It doesnt disbale gatekeeper. it adds back the ‘allow from anywhere’ option in your secirty preference pane. You can still toggle back to ‘identified developers’ in that same pane of you want.
It merely adds back the user option that existed prior to el capitan.
 
Last edited:
  • Like
Reactions: NervousFish2
Comment

NervousFish2

macrumors regular
Original poster
Mar 23, 2014
197
279
It doesnt disbale gatekeeper. it adds back the ‘allow from anywhere’ option in your secirty preference pane. You can still toggle back to ‘identified developers’ in that same pane of you want.
It merely adding back the user option that existed prior to el capitan.
Thanks!
 
Comment

chrfr

macrumors G3
Jul 11, 2009
9,185
3,162
It doesnt disbale gatekeeper. it adds back the ‘allow from anywhere’ option in your secirty preference pane. You can still toggle back to ‘identified developers’ in that same pane of you want.
It merely adding back the user option that existed prior to el capitan.
Turning that off exactly is what constitutes turning off Gatekeeper. This is even spelled out in a link on the page you referenced. See here: http://osxdaily.com/2015/05/04/disable-gatekeeper-command-line-mac-osx/
 
Comment

BigBoy2018

Suspended
Oct 23, 2018
964
1,819
Turning that off exactly is what constitutes turning off Gatekeeper. This is even spelled out in a link on the page you referenced. See here: http://osxdaily.com/2015/05/04/disable-gatekeeper-command-line-mac-osx/
but you can toggle it back on easily right in system prefs. So its no big deal.
And frankly, I’ve been fine with my macs for 30 years without apple being my babysitter and forcing gatekeeper down my throat, so I have no problem having the simple option to turning it on or off as I see fit.
 
Comment

chrfr

macrumors G3
Jul 11, 2009
9,185
3,162
but you can toggle it back on easily right in gatekeeper. So its no big deal.
And frankly, I’ve been fine with my macs for 30 years without apple being my babysitter and forcing gatekeeper down my throat, so I have no problem having the simple option to turjnit on or off as I see fit.
While you may recognize and understand that, not everyone on the internet does. For most users, it's an unnecessary exposure to disable security features like Gatekeeper. Certainly, nobody should be running commands they don't understand before doing so.
 
Comment

BigBoy2018

Suspended
Oct 23, 2018
964
1,819
While you may recognize and understand that, not everyone on the internet does. For most users, it's an unnecessary exposure to disable security features like Gatekeeper. Certainly, nobody should be running commands they don't understand before doing so.
I guess. But personally I think apple is just using ‘security’ excuses as a way to slowly but surely remove user options and flexibilty that used to always be a hallmark of a computer os. (not pleased with MS either and their forced updates).
The os used to have 3 options:
1) allow only from app store
2) allow only from identified developers
3) allow from anywhere.
I choose to leave it allow from anywhere, because I know what I’m installing on my system and have never had an issue with software doing anything nefarious.
Apple, and people like you apparently, dont believe we should be treated like adults and instead have baby gates installed all around the os we use.
No thanks.
[doublepost=1546982232][/doublepost]I’ll add for the OP that instead of running that terminal command that re-enables the option to ‘allow from anywhere’, you can usually just right click on an app thats from an unidentified developer and click ‘open’ from the pop up window. That will open a dialog box asking you to confirm you want to open it, and you have to click ‘open’ there as well.
That another way to get around apps that gatekeeper initially refuses to let you open.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.