Really annoying iPad Safari bug

Discussion in 'iPad Tips, Help and Troubleshooting' started by Anaemik, Feb 13, 2011.

  1. Anaemik macrumors 6502

    Joined:
    Feb 25, 2009
    #1
    Hey all,

    I have a 32GB WiFi iPad running the latest version of iOS, and ever since upgrading to iOS 4 I've experienced an occasional behaviour in Safari which I haven't been able to find an explanation for or a solution to.

    Generally speaking, Safari will tend to work as expected, but then 2-3 times a day as I go to load or refresh a webpage, instead of that page loading I'll get an error notification saying:

    Cannot Open Page
    Safari cannot open the page because the server cannot be found.

    Other pages will continue to load just fine, but every time I try to load any page on the same domain as the page that I got the error notification from, it will keep generating the same error. The only way I can kickstart it back to life is to go to into Settings, turn Airplane mode on then back off again, and then go back to Safari and reload the page.

    It's not a show stopping bug because there's a workaround for it, but it's a real PITA, especially if you have things streaming or downloading in the background.

    Incidentally, I also have an iPhone 4 with the latest software and to my recollection I have yet to experience this issue on the phone.

    My attempts at Googling the issue so far have been fruitless, with only vaguely similar issues being reported generally related to the iTunes store.

    Does anybody else experience this issue? It's one of a number of annoyances that got introduced with iOS 4 which are collectively really starting to taint the iPad experience for me.
     
  2. Neilyoung macrumors newbie

    Joined:
    Jan 12, 2011
    #2
    I have the same issue. I can't figure out what is causing it. It comes and goes. Seems only to be an issue on my iPad (not iPhone or macbook). I have check router, etc. But no luck getting rid of the problem.
     
  3. ajikoe macrumors newbie

    Joined:
    Apr 13, 2008
    #3
    me to has the same problem...:confused:
     
  4. kazaam93 macrumors member

    Joined:
    Apr 14, 2011
    #4
    this happens to me as well, mostly with hotmail and its really beginning to piss me off!!
     
  5. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #5
    This is the error message that you get when the server is not responding. That is why it doesn't happen at other web sites that are on other servers. This is not a bug in Safari.
     
  6. kazaam93 macrumors member

    Joined:
    Apr 14, 2011
    #6
    I am pretty sure it is! I never have this problem using my PC or laptop or phone. NEVER!
    It works when I use atomic browser, and why do you think it works straight away when I quickly switch flight mode on and off. It may not be a bug as many people do not seem to be affected but its definitely something to do with safari, could be my router, but I doubt it as I have mentioned above, I only have this problem with Safari on the iPad
     
  7. RedSunshine macrumors newbie

    Joined:
    Oct 17, 2011
    #7
    I hate digging up an old thread but it wasn't solved and I am having the same problem. I can be surfing on one site and then try open another site and I get this error. If I wait awhile, it might load. It doesn't seem to matter what site...amazon, apple, this site, etc...it's happened on all of them. Yet I am still able to load other sites at the same time without any issues.

    Is there something with my wifi settings that needs to be changed?
     

Share This Page