iPhone Really crucial question! Proffesional jaibreakers' help needed

Discussion in 'Jailbreaks and iOS Hacks' started by alexpleasehelp, Mar 10, 2013.

  1. alexpleasehelp macrumors newbie

    Joined:
    Oct 17, 2011
    #1
    Hi! it's been a while since my last post but anyway.... i have an iphone 4 with 03.10.01 baseband (4.1.2 firmware / jailbroken) and the phone is unlocked with gevey sim.

    many apps are incompatible with my ios and require ios 5.1 or greater so my ? is how can i update my iphone to 5.1 or 6.1 in order for all the apps to work???? i've had an iphone 3gs in the past and all i did was jailbreal with redsn0w but from what i've figured out so far it's not as easy as with gevey sim.... i think i have to preserve BB somehow or else i'll have a brick phone... please help me to update.....
     
  2. cyber16, Mar 10, 2013
    Last edited: Mar 10, 2013

    cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #2
    Do you have any SHSHs Blobs saved with cydia or locally for the ipsw you wish to update to?
    If yes then you can go to any ver ios you have them saved for.
    Or just start now with the current ios

    Windows
    http://www.iclarified.com/25144/how...e-4-3gs-without-updating-the-baseband-windows

    Mac OSX
    http://www.iclarified.com/25142/how-to-upgrade-your-iphone-4-3gs-without-updating-the-baseband-mac

    Use the right ipsw from here that you want to update to
    http://www.iclarified.com/entry/index.php?enid=750

    Yes preserve BB "NO BASEBAND UPDATE"

    Then jailbreak with the current Evasi0n

    Are you sure your gevey sim is compatible with ios 6.xx ?

    It maybe easier to just save the current SHSHs now, then purchase a iphone 4 factory unlock online.
    Let itunes unlock your phone, then update to 6.xx & jailbreak, this way you can move away from the gevey

    btw:
    I am NOT a Proffesional jaibreaker ;)
    Just been doing it for years with the great tools from the dev's

    Agreed with dhlizard, Sn0wbreeze maybe the better way to go. All you need to is NOT update your baseband
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Don't know if I fit the category of "professional jailbreaker" ?

    Use the newest Sn0wbreeze to do a No BB restore to 6.1.2 or to any older firmware you saved the SHSH for.
    It will upgrade your firmware but preserve your baseband so you can still unlock.

    Note: Redsn0w has not been fully updated for OS6 yet - it can get you safely to any 5.x.x firmware you have SHSH saved for but not to the newest firmware versions 6.1.x

    If you don't have any SHSH saved, you can only go to 6.1.2 but make sure your sim interposer will work on iOS6 - many do not !

    @cyber16 - you beat me by seconds :D
     
  4. alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #4
    i apologize for incorrect./ridiculous title

    i just got this phone so no i didn't save any blobs

    ok all i need now is 5.1.1

    please tell me step by step guide on how to update to 5.1

    once again i'm really afraid that might screw up my givey sim and stuff so please guys make sure you give me a safe way of doing jaibreak
    1) save shs blobs??? (how?)
    2)
    3)
    4)
    and so on...

    i greatly appreciate your help!



    p.s i'm running os X 10.8.2

    p.p.s i have to go to work guys. i'll read and respond to your posts tomorrow. thank you!
     
  5. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #5
    Just because you did not save the SHSHs, does not mean someone else did not.
    Use redsnow or TinyUmbrella to query the cydia server, just maybe the previous owner did at one point.

    You could try iFaith to see if you can pull the current 4.1.2 shsh's from the phone
    Not sure if you will need them later, but it only takes a few minutes to check.
     
  6. alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #6
    confused....

    i need shsh saved for upgrade from 4.1 to 5.1? i thought it was only for downgrade????

    ----------

    i was googling a bit and some people said ttat it can be checked on cydia home page!

    on cydia on the very top it says in green:

    SHSH: IOS 4.1, 4.2.1, 4.2~b3, 4.3, 4.3.2, 4.3~b2, 6.0.1, 6.1.2


    does it mean anything to you?
     
  7. iRooney macrumors 6502

    iRooney

    Joined:
    Jul 14, 2011
    Location:
    Charleston, SC
    #7
    You need shsh for whatever version of iOS you want to install because apple is only signing 6.1.2. Any other upgrade will fail. Looks like your device has shsh for every version of iOS but 5. You're SOL buddy.
     
  8. alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #8
    ahahah oh wow! i didn't even notice it doesn't have 5XXX versions..... wow that sux..... so i guess i'm stuck with current FW forever.... do u think it's worth trying to upgrade to ios 6 or it's gonna be useless?

    ----------

    like what if i try to install 6.1 ios? will i f** my phone up? i mean it's like the worst scenario for me.... i wanna make calls...
     
  9. iRooney macrumors 6502

    iRooney

    Joined:
    Jul 14, 2011
    Location:
    Charleston, SC
    #9
    Worst case scenario....you've got a really expensive paperweight.
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Have you considered an IMEI unlock ?
    Determine which carrier sold the phone via Model #.
    If the cost to unlock with a grey market vendor is reasonable, then you can do that and never worry about firmware or baseband again.
     
  11. braxton34, Mar 11, 2013
    Last edited: Mar 11, 2013

    braxton34 macrumors member

    Joined:
    Mar 18, 2012
    #11
    According to various posters at gsmforum, the gevey still works on iOS 6 as long as you preserve the baseband (use the latest sn0wbreeze).

    You will likely have to do the manual (dial 112 etc) method as FuriousMod was last updated for iOS 5, although again, some posters claim that Furiousmod still works on iOS 6 to automate the unlock.

    I have not confirmed this myself, but you can check GSMforums for yourself...

    Good luck!
     
  12. alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #12
    well i have to dial 112 everytime i reboot or turn on the phone anyway! thanks for the good news and i'll be sure to check that out! Thanks to everyone!
     
  13. alexpleasehelp, Mar 12, 2013
    Last edited: Mar 12, 2013

    alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #13
    wooohooo!

    success! i've successfully updated to 6.1.2 and gevey works just fine with preserved base band! the funny thing is when i first booted into jaibroken 6.1.2 ios i got full bars!gevey sim didn't request to dial 112! i tried to call to my sister and everything was fine! i decided to reboot and on my second boot up i got a msg that i have to dial 112... well everything works well! and i can install some apps that were completely incompatible with 4.1 ios....

    this is what i did!
    1)checked on Cydia which SHSH i had saved and then chose to install 6.1.2
    2) i've downloaded official 6.1.2 Firmware and then used sn0wbreeze expert mode to make a custom firmware! (in expert mode,check hacktivate or you'll get stuck on activation screen)
    2)then i used iReb to boot into PWNED DFU mode
    3) then i used itunes to restore custom firmware (hold alt + restore )

    specs as of now
    6.1.2(10b146)
    modem 03.10.01
    unlocked with gevey ultra

    hope it will help some1 in the future !!! Peace!@
    :):):):):):):):):D:D:D:cool::cool::apple::apple::apple::eek:
     
  14. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #14
    Great Job.
    Now be sure to keep up and save them shsh blobs from now on as the A4 cpu idevices do have options that are not yet available to the newer A5,A5x +A6 CPUs
     
  15. alexpleasehelp thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #15
    112 dial problem is solved ultrasn0wCN!~ now the phone is almost like neverlock condition ahahahh!))))

    all SHSH's are saved! Thanks everyone who helped me to figure this all out! This is my last post in a while! Cya!
     

Share This Page