REALLY need help, PLEASE!

Discussion in 'Mac Basics and Help' started by NatalieJulie, Apr 14, 2008.

  1. NatalieJulie macrumors newbie

    Joined:
    Apr 14, 2008
    #1
    I am an idiot. Last night I decided to "edit" the username I use (the one that shows in the Finder window), shut down my computer, woke up, and everything was started anew and GONE.

    I went into the hard drive "Users" section and I have a duplicate User profile. Now the "user" I am using now is logged in with my password, but everything I have had saved in the past 2 years is in the OTHER User name that was edited. Does this make sense?
    My username was nataliajulie, so I wanted to edit it to be Natalie Julie. Now all my apps, files, etc are in the new Natalie Julie. I tried logging off to see if I can log into Natalie Julie but it's not even listed as a user when the log-on screen pops up.

    So my question is, how do I switch? I am on nataliajulie right now and no files are here, I want to be on Natalie Julie where my LIFE is on :eek: and I can't even log onto it, but all my files are in there. How do I go about this?

    Thanks!
     
  2. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #2
    Did you edit the short name or the full name? You should never edit the short name!
     
  3. NatalieJulie thread starter macrumors newbie

    Joined:
    Apr 14, 2008
    #3
    I'm not sure what that means, but I edited the name from the actual Finder window in the side bar. It was "nataliajulie" and I right clicked in the Finder side bar to make it "Natalie Julie" :(
     
  4. DizzyRose macrumors regular

    DizzyRose

    Joined:
    Oct 17, 2007
    Location:
    Barrowford, UK
    #4
    The best you can do now is to move the folders and files to your new user... However, that may cause errors.
     
  5. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #5
    The name next to the house? How did you change that, I can't :confused:

    EDIT: ah, you must be using Tiger. You can't change it in Leopard. Have you tried changing it back?
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    This may or may not work, but try it...

    1. Go into Applications/Utilities/Directory Utility (launch it)
    2. In Directory Utility, click the lock (to make changes).
    3. Under the "Edit Menu", select "Enable Root User"
    4. Set a password for Root User if prompted.
    5. Quit Directory Utility
    6. Go to System Prefs and open the Account Pane.
    7. Click the lock to make changes.
    8. Under login options, change "Display login window" to "Name and Password".
    9. Close System Prefs and under the Finder "File" Menu, logout as your current user.
    10. At the login screen, for user "Root", for password (see step 4).

    11. Once you are logged in as root, navigate to the new (bad) nataliajulie user folder and drag that to the trash leaving the user (good) folder you renamed "Natalia Julie". Rename that back to "nataliajulie" as it was originally.

    12. Now empty the trash.

    13. Then go into System Prefs -> Accounts Pane and click the login options again setting the login window to display a list of users. Then click on the "nataliajulie" account and change the user name (it will not affect your user folder name) to "Natalia Julie". This new name should appear at the login screen.

    14. Again logout (as root user). Your new name should now be listed at the login screen as well as "Other" (in case you have to login as the root user again). Login using your password (not the root password if different).

    If all is well, disable the root user the same way you enabled it in the "Directory Access" application.
     
  7. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    Sorry, but this applies to Leopard as far as the way to enable the "root user". For Tiger I think it is in the "netinfo" utility, but since all of my macs are running Leopard, I have no way of testing this for Tiger.
     

Share This Page