Really odd wifi issues. Apple are stumped. I'm stumped. How about you?

ss957916

macrumors 6502a
Original poster
Jun 17, 2009
861
0
My June 09 MacBook Pro has massive problems staying connected to my Airport Express or Airport Extreme - it'll intermittently disconnect, not be able to connect and the range is dreadful. My partner's Macbook and our iPhones have no problems at all.

My MBP had a new Airport card, screen and HDD(?!) installed by Apple, but it still won't connect to our network (called 'Free Public WiFi').

However, and here's the really odd bit, I used my old Linksys WRT54G wifi router for over a month and there wasn't a single problem - revert back to my week-old Extreme or my 18 month old Express and the problems return.

What could it be?!
 

Attachments

GGJstudios

macrumors Westmere
May 16, 2008
44,427
762
Wireless issues are often closely related to your environment. Some areas have more interference sources than others. I lived for years next door to a TV station.... wreaked havoc with anything wireless. I'd use whatever router is least susceptible to interference, regardless of the brand.
 

ss957916

macrumors 6502a
Original poster
Jun 17, 2009
861
0
Wireless issues are often closely related to your environment. Some areas have more interference sources than others. I lived for years next door to a TV station.... wreaked havoc with anything wireless. I'd use whatever router is least susceptible to interference, regardless of the brand.
Just to reiterate - my MBP has problems whereas my partner's MacBook and iPhone 3G, and my iPhone 3GS have no problems at all. Could interference really only ever effect my MBP and no other unit??
 

Reflow

macrumors 68000
Mar 30, 2005
1,567
0
NJ/PHL
Try changing wireless channels on your extreme. Sometimes that helps if you live in a populated area.
 

AaronX

macrumors member
Jul 29, 2009
50
0
Australia
I'd try disabling things on the router, like only using 802.11 b/g and turning off the security (temporarily). Try using Windows on your MBP and see if it can connect.
 

Primejimbo

macrumors 68040
Aug 10, 2008
3,295
131
Around
I couldn't connect to my in-laws router at all and when I went to the Apple Store and I couldn't even get on the open networks at all. So under "Network Preferences" Change the Location at the top from "Automatic" to "Default". I hope this helps. They showed me this at the Apple Store and haven't had a problem since.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.