Really Slow Internet only on New MBP

Discussion in 'macOS' started by cosmokanga2, Oct 24, 2008.

  1. cosmokanga2 macrumors 6502a

    cosmokanga2

    Joined:
    Jan 7, 2008
    Location:
    Canada, where we live in igloos.
    #1
    I really hope you guys can help.

    Ever since I set-up my new Late "08 Macbook Pro, my internet connection has been excruciatingly slow. I have tested it against two PC laptops on the same network and every single time the MBP is slower. All of the computers are connected to the same network which I control and both are using Safari and loading the same sites. Both are also connected to the router using 802.11g as the PC's don't have N.

    I have tried all of the suggestions listed in these 1 2 3 4 5 6 threads but none have seemed to help.

    The weird thing is that it may take 10 time longer to load a web page on the Mac versus the PC, but some downloads are much faster on the Mac. Also the only site that seems to be fast is google, loading almost instantly.

    Does anyone have a similar problem or know of any solutions? I am really loving my first Mac but this one problem is getting annoying.

    Thanks.

    EDIT: I just downloaded the nightly Safari webkit but it didn't speed web browsing up at all. I also ran Speedtest on my MBP and the PC and the Mac had download speeds of 1081kb/s while the PC had download speeds of 886kb/s. Loading web pages was still slower on the Mac though.
     
  2. hiddenpremise macrumors regular

    hiddenpremise

    Joined:
    Jul 25, 2008
    Location:
    Somewhere between my imagination and reality
    #2
    Sounds like you possibly may be slow resolving DNS. Look and see if perhaps you have specified an incorrect DNS server in your system preferences.
     
  3. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #3
    Seconded. Try downloading Firefox, it's less embedded into the actual OS itself so any problems that might afflict Safari because of a corrupt system plugin, hack, mod or etcetera aren't going to get in the way.
     
  4. AquaMethod macrumors member

    Joined:
    Jun 17, 2008
    #4
    Try this as the Terminal:
    Code:
    dscacheutil -flushcache
    ping -c5 google.com
    And see how long it takes for
    Code:
    PING google.com (209.85.171.99): 56 data bytes
    to appear (the IP address may be different). Try this with several websites, including some you haven't visited recently. If it takes a long time for that line to appear, it's a DNS issue. If it shows up quickly, look at the `time` on each line of the ping. It should be below 100 ms or so.

    Try setting your MBP's DNS to OpenDNS. To do so, open System Preferences and click on `Network`. Make sure the `Airport` connection is highlighted in the sidebar on the left, and then click `Advanced`. A sheet will pop down, where you need to click the `DNS` tab. Once there, you may see a grayed-out item in both panes. This will most likely be our router's DNS. If you see any other entries, write them down and try removing them. When you're ready to try OpenDNS, click on the `+` icon below the lefthand pane. This will create a new item in the pane, where you can type in an IP address. Paste in 208.67.220.220 and then repeat the process, pasting in 208.67.222.222
    Go back to the Terminal and type dscacheutil -flushcache again, and see if things improve.

    You might also try disabling IPv6. IPv6 is a technology that allows for many more internet addresses than the current system, IPv4; however, few ISPs or routers use the technology, so it's safe to turn it off, and turning it off sometimes alleviates this problem. To do that, go to the TCP/IP tab of the pane you were in to change the DNS settings. Click on the `Configure IPv6` pulldown menu, and choose `Off`. Go to the Terminal and type dscacheutil -flushcache and try browsing again.

    If you have another Mac that doesn't have this problem, put your new MBP into Target Disk Mode, and boot your other Mac from the MBP's hard drive. To do this, connect the Macs via Firewire, and hold down the Option (⌥) key during boot—your MBP's hard drive should show up as an option. Once booted, repeat the tests. If you still suffer from slow internet, it would appear to be an issue with the MBP's OS X installation.
     
  5. ryanwarsaw macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #5
    There was also an update to airport today, try installing that.
     
  6. jamespabbott macrumors newbie

    Joined:
    Oct 25, 2008
    #6
    slow FTP

    I share the problem with a sluggish internet, and will try some of the suggestions I have found here. But my biggest problem is with my FTP upload and download speeds. I am on an imac, 2.16 GHz Intel, using 10.5.5. The newer my OS X, it seems, the worse my FTP speeds are. I had been using fetch 4.0.3, but just switched to yummy FTP, which at least does not keep shutting down when the speeds get too slow. Or is between 1.5 and 2.5 Kb sec what I should expect?
     
  7. cosmokanga2 thread starter macrumors 6502a

    cosmokanga2

    Joined:
    Jan 7, 2008
    Location:
    Canada, where we live in igloos.
    #7
    Thank you!!! I added the IP addresses to the DNS and webpages are now blazing fast. Don't know what id did but it sure works.

    Thanks to everyone for their help, this is why I love Mac Forums.:)
     
  8. AquaMethod macrumors member

    Joined:
    Jun 17, 2008
    #8
    Cool—glad it worked! You can set your router to use those DNS addresses if you'd like all of your computers to use them, but it sounds like you're pretty happy as is.
     
  9. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #9
    Actually, that might be the problem. This problem is either caused by bad ISP DNS servers (less likely), or a buggy DNS implementation in some routers. Some routers, when given DNS IPs, don't actually pass those along to the computer via DHCP. Instead, they pass their own IP as DNS, and then NAT it. It is these type of routers that might be the cause of this problem, in the cases where the ISP DNS is not the problem.
     

Share This Page