Really strange bluetooth issues on power mac g5

Discussion in 'PowerPC Macs' started by L Oquence, Dec 23, 2014.

  1. L Oquence macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #1
    For some odd reason my usb bluetooth receiver ever since i changed the batteries in my apple wireless keyboard is defaulted to off at startup and i have to plugin a usb keyboard to type my password in.

    and then after that turning bluetooth on and off in the normal bluetooth settings is greyed out and unclickable.

    the only way i can get bluetooth on is by going to "keyboard and mouse" then "bluetooth" and set up new device, then it notifies me bluetooth is off then i tell it "turn bluetooth on" and it does so, but it resets to off again on startup.

    anything you guys think i could try to fix this odd issue? I'm on 10.5.8 if that helps.
     
  2. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #2
    Is the adapter plugged into a USB card or other peripheral like Studio Display or USB hub? If so try giving it one of the regular USB ports. Does it work if you unplug and replug the adapter?
     
  3. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #3
    ive tried all of the basic stuff. plugging it into every single usb port i have.

    the only combination that works is "keyboard and mouse" "turn bluetooth on" then discover the keyboard
     
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    When it starts acting up, does the Bluetooth USB adapter show in System Profiler?
     
  5. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #5
    Yes.
     
  6. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #6
    Can other devices work with the Bluetooth when it is acting up?
     
  7. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #7
    No because bluetooth is not on, at all. The only way I can even turn bluetooth on is by going to "keyboard and mouse."
     
  8. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #8
    I am thinking the adapter maybe going out. Can you try this on another Mac or at least a different OS install?
     
  9. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #9
    sadly, no. my powerbook is out of commission until i get the hard drive put it.
     
  10. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #10
    Not sure how else to test it then.
     
  11. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #11
    Any other ideas about what might be up?
     
  12. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #12
    I am thinking that the adapter would be wonky but you said that it shows properly in System Profiler. You said this issue only occurs with the new batteries as well, so have you tried a fresh set?
     
  13. L Oquence thread starter macrumors regular

    L Oquence

    Joined:
    Jul 10, 2014
    #13
    Yeah I put more batteries in too...

    What Bluetooth adapters would you recommend
     
  14. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #14
    I have had good luck with these micro Rocketfish USB adapters. They are under $10.00 on eBay and are very sleek and small even when on the side of a PowerBook or iBook.
     

Share This Page