Really strange OS X mail behaviour

Discussion in 'Mac Apps and Mac App Store' started by peterdevries, Apr 22, 2010.

  1. peterdevries macrumors 68040

    peterdevries

    Joined:
    Feb 22, 2008
    Location:
    Amsterdam, The Netherlands
    #1
    Emails that show up in my mail app in OS X are showing strange behaviour.

    If I click on a new (or old email) then the email that is shown in the preview pane or is opened is an entirely different one than the one I clicked on. I have rebooted etc. No changes previously to the system that could have caused this, so I'm at a loss what the cause is of this..

    Can anyone help?

    [​IMG]
     
  2. frenetic macrumors regular

    Joined:
    Feb 11, 2004
    Location:
    Amsterdam
    #2
    That's an odd problem - the most logic thing to try would be to clear out your caches with Onyx or any other utility. BUt never heard of this problem, though.
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    Try rebuilding that mail folder (all of them individually, if it happens in any folder).

    From the menu bar: Mailbox -> Rebuild. That will reindex all of the individual messages, which should clear up that issue.

    If not, no clue…

    jW
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    minor point:

    Mail is an Application. Mine is version 3.6 - I don't use it.

    OSX is the operating system. Currently, that's version 10.6.x

    They are two separate things. Mail is not part of OSX, but comes with it.
     
  5. peterdevries thread starter macrumors 68040

    peterdevries

    Joined:
    Feb 22, 2008
    Location:
    Amsterdam, The Netherlands
    #5
    Thanks all for your help. The above mentioned solutions did not work however. A few minutes after I posted this my MBP crashed completely and all things like repairing permissions, safe booting etc. failed. I ended up doing a clean install and using migration assistant to restore the system.

    It now works fine of course..
     

Share This Page