Really Strange Wifi problems

Discussion in 'iPod touch' started by dawnraid, May 31, 2008.

  1. dawnraid macrumors regular

    Joined:
    Nov 9, 2007
    #1
    Hi all
    I brought my 8gb week 38 ipod touch in october last year, and have been having problems ever since getting safari, itunes and youtube working. It connects to my homes wifi (WPA encryption) fine and works fine, it will load web pages etc but stops working after around 20 seconds, I cannot load web pages even though my ipod is still apparently connected the my network. It will work again for another 20 seconds after rebooting my router or forgetting my network and rejoining on my iPod. My Wifi router Is a Gigabyte GN-BRO1G which is hard wired to my adsl router which is the dhcp server . the wifi works on my psp, my macbook, a laptop and a desktop pc around my house. I have quite a resonable knowledge of networking and this has left me stumped. the ipod also seems to work well on a neighbors unencrypted wifi except the signal is so weak i cant really use it. I have also tried changing the security and unencrypting my wifi network but the internet on my ipod stops loading/working after about 20 seconds.

    here are the technical things
    Wireless router ip :192.168.1.254
    adsl router (dhcp server aswell) : 192.168.1.1
    working macbooks wifi settings (using dhcp) ip 192.168.1.6 dns 192.168.1.1 router/gateway 192.168.1.1 and subnet 255.255.255.0
    Type of encrytion WPA AES
    iPod's firmware 1.1.4

    ive tried static and dhcp on my iPt but both seem to fail to give me anything that works. i have changed my encrytion to wep and unprotected but it still wont work. im 99% sure the ip setting on my touch are right aswell (it receives an ip from my router when doing dhcp)
    any suggestions to getting it
     
  2. sgtboy macrumors 6502

    Joined:
    Dec 19, 2007
    #2
    Well i hate to ask, but have you unplugged modem/router for 30 sec and back in?

    also try hitting "forget this network" on your touch when you select your home wifi signal

    also try restoring the ipod
     
  3. dawnraid thread starter macrumors regular

    Joined:
    Nov 9, 2007
    #3
    Yes I have many times. I would really like this problem to be resolved, does anybody have any idea what wrong?
     
  4. imaketouchtheme macrumors 65816

    Joined:
    Dec 5, 2007
    #4
  5. dawnraid thread starter macrumors regular

    Joined:
    Nov 9, 2007
    #5
    When I follow those steps it does not even load google, so it is something other than the DNS
     

Share This Page