iPhone Really tricky JB situation

Discussion in 'Jailbreaks and iOS Hacks' started by cameronjpu, Oct 1, 2012.

  1. cameronjpu macrumors 65816

    Joined:
    Aug 24, 2007
    #1
    OK so I have an old 3GS. It has the new bootloader. I unlocked it legally through ATT so it can be messed with without losing that. I am right now running IOS5.0 with a tethered jailbreak from Redsn0w. Far as I can tell everything works normally when tethered boot.

    The problem is I really need to get away from the tethered boot (the phone is being given to someone who will not have a computer and wouldnt know what to do with one anyway). When I try to restore the phone I get a 3184 error.

    The thing that REALLY complicates this is that.... wait for it.... I'm in China, and I don't speak mandarin. I'm trying to do this all on a hostel public PC. I cant hardly read any of the errors when they do happen.

    I found an untether tool but it requires 5.1.1, which I can't get to. I've tried creating a customer ISPW with Sn0wbreeze. Tried doing standard restore in iTunes. Tried doing those things after a tethered boot and after a normal boot, and in DFU boot. All fail quickly with the same error.

    I tried TinyUmbrella but it won't run on this computer. No clue why - it just closes immediately.

    Any ideas on a next step? Exhausted in China!
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Did you save the 5.0.1 or 5.1.1 hashes for the phone ?
    You cannot,upgrade without the hashes.

    What type of computer, Mac or PC are you using ?
    What operating system ?
     
  3. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #3
    Why not? The phone is unlocked... i dont understand why I can't restore it back to factory settings.

    I dont know if I saved the hashes - I downloaded the redsn0w tool and followed the instructions to unlock, but I don't recall anything about hashes in there. :(
     
  4. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #4
    Do you require a jailbreak? Or are you trying to go back to a completely stock device? If you want an untethered jailbreak, your only option is restoring to a firmware which has an untethered jailbreak. In order to restore to any of these firmwares, you will need your shsh blob and apticket in order to do so. This is why lizard is asking if you saved your hashes. If you didn't use tiny umbrella when apple was signing any of the previous firmwares, theres a chance cydia grabbed them for you. dhlizard is extremely knowledgeable. Just follow his lead and he'll get you to where you need to be. Restoring to anything other than the current 6.0 you will need saved blobs. If you don't have them you are SOL.

    Edit: Unlocking is completely separate from jailbreaking. You are carrier unlocked which means you can use a sim card from a different carrier. But regarding firmwares, you are still bound to Apple's rules and regulations. Unless of course you saved blobs from an earlier firmware like 5.1.1 or 5.0.1. Both of those firmwares have an untethered jailbreak. I hope this helps clarify things. You're in good hands. Dhlizard won't mislead you.
     
  5. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #5
    If you don't have your hashes, you can't choose older firmware. You can install stock fw 6.0 or tethered 6.0 jb fw though. You can check your hashes on Tinyumbrella, Cydia at the top w/ green letter or using redsn0w.
     
  6. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #6
    I don't require a jailbreak. First need is to not be tethered. I cant have this phone turning into a brick the first time it needs to be rebooted because my friends don't have a computer.

    The phone when i got it had 5.0, and thats from where I used redsnow to jb it. Should anything be saved as a result? Where do i find it if so?

    My problem is that nothing I have done allows me to even get into the restore process. I get that 3184 error.... in about 90 minutes i'll be leaving this hostel for the airport. Ugh....

    ----------

    So is that why I am getting errors when trying to install 5.1.1? Do I need to install 5.0? Then upgrade once I have that to 5.1.1? Or is there a way to do that at all or do I have to go to 6? Don't really want that - I'm overseas so having google transit is important to me.

    When i open Cydia it says it has SHSH 4.1, 4.3.3 and 4.3.5. I dont understand how thats possible unless it's for another phone of mine though... this phone never had 4.x in my possession.
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #7
    Unlocked is irrelevant to being able to restore the phone to current or older unsigned firmware.

    And Redsn0w doesn't unlock anything, it is a jailbreak tool.

    Honestly, you need to fire up Google and research jailbreaking, unlocking and restoring firmware.

    iClarifed.com has a lot of tutorials.
     
  8. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #8
    I've been on Google for about 12 hours in the past 2 days, so clearly that hasn't helped. The problem there is there are 1000 terms that I don't understand and time is a crucial factor. I came here hoping for someone knowledgeable to actually help my exact situation. The other poster said you were very knowledgable and helpful, so hopefully that will be true, but sending me to Google for more scattershot help (hoping someone else has the same problem as I do) is not going to help at all. Thanks for trying I guess.

    Edit yes I know that Redsnow doesn't unlock - i misspoke. As I said and as you konw, my phone is factory unlocked. 36 hours ago I was on a plane from DC to Beijing - last night I slept 4 hours and the night before, 4. So i'm doing my best to put all the words together in the right way. I wish you would talk to me like I am not a novice with the vocabulary and expectations of an expert. I'm an intermediate unlocker (ive been doing it on a couple phones for a couple years now) who doesn't do it often enough to be an expert. Thanks

    Simple question : is the solution to my problem likely to be restoring to 5.0 firmware? And if so, what should I do to make that happen? A simple Shift-Restore to that IPSW that I am downloading now? Or do I need to do something else to that IPSW first?
     
  9. BumpyFlatline, Oct 1, 2012
    Last edited: Oct 1, 2012

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #9
    Hey FYI this isn't a support forum. Just because time is crucial for you doesn't mean dhlizard is going to sit and wait for your replies especially when you are pretty uneducated in regards to jailbreaking and unlocking. What you should do is backup your device if you can whether via iCloud or iTunes. Put it into DFU mode, then upgrade it to 6.0 via iTunes. You MUST be using the latest version of iTunes in order to install 6.0. If you are getting errors it's because you are not on iTunes version 10.7.

    Update iTunes, backup device, enter DFU mode, upgrade to 6.0, then restore from backup. That's your quickest option. Your phone will remain unlocked.

    You can NOT update to iOS5 without saved blobs. If tiny umbrella does not show that you have them then if I were you I would upgrade to 6.0 and use that non-jailbroken. That's my advice. It's quick and easy.
     
  10. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #10
    Can I download the ISPW for iOS6 manually and do the upgrade that way? I don't trust the internet connection here enough to hope that iTunes will succeed in the long download.

    Thanks
     
  11. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #11
    What I see is your not listening to what people are telling you so it's really difficult to help you. dhlizard gave you proper advice if you would have done this about a week ago when 5.1.1 was still being signed advice would have been different. As of right now you can stay at 5.0 or go to 6.0 unless you have blobs check cydia [​IMG] if you don't have them there is nothing you can do. tutorials are Iclarfied.



    you can download any IOS firmware from here it's very trust worthy

    http://www.felixbruns.de/
     
  12. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #12
    Yes. Labman referred a great site for official IPSW files.
     
  13. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #13
    Good - i know, I just wanted to make sure that that was the same as letting itunes do it.

    ----------

    There is a difference between not listening to what people are saying and not understanding what they are saying.
     
  14. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #14
    Let me try, then. In order to restore any firmware to a an iPhone 3GS or later, one must have the restore request signed by Apple using its secret encryption key. This signature comes in the form of an SHSH BLOB retrieved from Apple's servers and attached to the firmware before it can be uploaded to your phone. Your phone will not accept any firmware unless it has such a signature attached to it, and these signatures are unique to each firmware. Once Apple stops signing old firmwares, the only way to install those firmwares is by using special software to sign the firmware yourself using a previously-saved version of the signature file. If you do not have such saved signatures for the firmware you wish to restore to, there is no way for you to restore to that firmware.

    Since you appear to have SHSH 4.1, 4.3.3 and 4.3.5 saved through Cydia it is possible for you to restore your phone to those firmwares. You will, sadly, be unable to restore to any 5.x version of the firmware.

    The only other option is to restore to iOS 6.0. You can do this following the normal procedures in iTunes. You will not be able to have an untethered jailbreak, but can either run stock or have a tethered jailbreak.
     
  15. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  16. cameronjpu thread starter macrumors 65816

    Joined:
    Aug 24, 2007
    #16
    Agreed. Thank you thelatinist - I bet a large percentage of potential jail breakers would benefit from someone finally explaining that clearly instead of assuming everyone knows it and berating those who don't.

    I just didnt fathom that there were iOS 5x versions for which there was still only a tethered jb! In the meantime since I have rebooted many times without computer, I have been using chrome, sparrow and luckily china Unicom supports personal hotspot so I could still do that.

    I am resigned to upgrading the phone to ios6. Too bad because 5 is fine and I'm sure on a 3GS 6 will be pretty slow. Now if I could just find a computer here in china decent enough to download and install that. This place is not the most Internet connected place (duh)!

    Thanks for your help.
     

Share This Page