Really Weird iPhone Calling Bug

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MikeTadd, Sep 8, 2009.

  1. MikeTadd Guest

    Joined:
    Jun 17, 2009
    Location:
    London, United Kingdom
    #1
    I had this problem with my 3G, wonder if anyone has had similar:

    Had a contact, had a address book entry and a photo. When they called me, the phone was ringing their end, but iPhone screen did nothing. When the got voicemail, the screen would light up and inform me of a missed call.

    If I tried to ring the contact, all is working as normal on my phone, but when i press End Call, nothing happens. if i go out of the call menu (press home button) it says Press to return to call as normal, and if you press it, nothing happens, so was no way to hangup appart from force phone reboot.

    I tried removing the contact, dialling without it being in address book, re-adding into address book and also a complete factory restore and restore from backup, but still the same happened. The only way i could fix the problem was to restore iphone and not use my backup.

    Would like to add that this had nothing todo with the iPhone 3.0 firmware. Just thought I would see if anyone else has had anything similar at all?
     
  2. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #2
    I've seen it happen once, but a colleague has had it happen a lot of times.

    He has a full signal, and someone calls, but the phone doesn't ring and eventually just goes to voicemail. I don't know if it's specific to an individual contact though.
     
  3. MikeTadd thread starter Guest

    Joined:
    Jun 17, 2009
    Location:
    London, United Kingdom
    #3
    This wasnt a straight to voicemail, as that can happen if the iPhone is on Edge or GPRS and downloading data, happens to all phones, but the phone was actually ringing!
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #4
    This happens when you're surfing on EDGE.
     
  5. MikeTadd thread starter Guest

    Joined:
    Jun 17, 2009
    Location:
    London, United Kingdom
    #5
    This isnt the problem. Have had this, but the phone was ringing on the other end.
     
  6. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #6
    Got it. I was responding to the other poster.

    Well, seeing as no one else replied, you might try the solutions in this thread, if you didn't already see it (change sim card or reset network settings):

    http://forums.macrumors.com/showthread.php?t=778641
     

Share This Page