Really werid Internet connection problem with imac

Discussion in 'Mac Basics and Help' started by captainbeefheat, Jan 6, 2008.

  1. captainbeefheat macrumors regular

    Joined:
    Jan 21, 2006
    Location:
    UK
    #1
    -sorry for the long post, lots of info.

    Ok yesturday my iMac wouldn't work with the Internet even though every other computer in the house would. First I noticed that it had a self assigned IP and was connecting to some odd IP address and domain mask. So I manually typed in the address as on my other machines and gave it a IP address that fitted with the rest. This seemed a little better in network diagnostic I had the first three green lights but not sever and Internet, sometimes I could get server or internet green as well randomly. With the wifi on; all green after it took a while to connect (its not ideally situtated for router so could be that) and the diagnostic said my internet was working but could not browse any sites.

    Anyway tried lots of things, reset the pram, new location, repiar permissions! I rang up apple who said I could take it into my nearest store (not esspially near at 30 miles!) and they could look at it.

    Low and freaking behold it works on their system! Though when they check the ethernet (what I usually connect with) it seemed to take ages to see the network. I asked him if this wasn't a little odd and he said sometimes it takes a while with the powermacs downstairs when he plugs them in and blamed it on their network, though didn't seem to say that while it wouldn't connect only when it suddenly did. But they seem to have washed their hands of it, but did say I could take it in again if the problem persisted.

    Anyway took it home, upgraded the firmware on router and then did a reformat of the machine. Again at first it wouldn't work during the registration process then when osx loaded it worked! It did a software update restarted...didn't work! I tried a different router which it picked up then didn't. Then just tried sharing the internet from my ibook to imac with firewire but that was dog slow. It did another software update and now it is working through ethernet! Though for how long is anyones guess.

    Anyone come across anything like this before? I am just pretty sure as soon as I restart after putting back my stuff it will not work again. Vista was on this machine btw which also didn't work wih the internet though removed the windows partition thinking maybe that had something to do with it. Basically I am baffled by all this seems to deify logic which probably means its software related! But it worked fine for aaaaaaages, had the machine a year and half.

    -using leopard btw.
     
  2. darwinian macrumors 6502a

    darwinian

    Joined:
    Jan 4, 2008
    Location:
    In R4, more or less
    #2
    If things changed after the software update, then perhaps that's where to focus your attention. There have been a few updates since Leopard was released -- which update killed your connection; perhaps someone might be able to help based on that info.
     

Share This Page