Rear USB ports quit working

Discussion in 'Mac Pro' started by Reddog99, Aug 15, 2012.

  1. Reddog99 macrumors newbie

    Joined:
    Aug 15, 2012
    #1
    I unplugged my USB scanner several weeks ago and suddenly the rear USB ports quit working. They're completely dead functionally, but when I run Hardware Test, it says "No Problems Found". This tends to give me some hope that I can revive them, but I've tried the SMC reset and zapped the PRAM several times with no effect.

    Lucky for me that the front ports function, but it's very disappointing that just unplugging a device would kill three ports. Does anyone have any suggestions to add?

    Early 2008 Mac Pro 3,1
    OS 10.8
     
  2. lssmit02 macrumors 6502

    Joined:
    Mar 25, 2004
    #2
    I think you have to unplug the Mac Pro, leaving it unplugged for several minutes, for the USB to reset. Here's a link that goes into more detail.
     
  3. Reddog99 thread starter macrumors newbie

    Joined:
    Aug 15, 2012
    #3
    Thanks for the link. I already did the SMC reset unplugging bit, but I'll try the little white button next and see what happens.
     
  4. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #4
    Open the MP and check the the connections and cables.
     
  5. Reddog99 thread starter macrumors newbie

    Joined:
    Aug 15, 2012
    #5
    I unplugged the scanner at the scanner, not the Mac, so the Mac Pro connections were undisturbed by the action. Besides, the USB ports are buried behind the memory modules inside the case.

    I've tried everyone's suggestions with no luck. I must have reset the PRAM & SMC four times. Oddly, even though the two bongs sounded, and resetting the PRAM is supposed to hose all the mouse and network settings, etc., I've seen no adverse effects.

    I suppose I'd feel better if the Hardware Test had told me that the USB ports were toast, but to tell me that they're OK and not be able to revive them is frustrating.
     
  6. degl macrumors member

    degl

    Joined:
    Jun 12, 2010
    Location:
    Caracas
    #6
    My 2009 Mac Pro USB ports work erratically, just one of the front has been working properly, this happen from some time ago, since 10.6 Leopard and now 10.8 Mountain Lion, this begun with the Cinema display loosing the sound.

    What is more strange, is that nothing of this happen in Bootcamp at windows all USB ports work perfectly.

    I have buy a Belkin USB card to try, waiting to arrive.

    My conclusions: one of the mac pro firmware, i think was when the Mac pro has a issue with temps using Itunes, since those days just became to act strangely.

    Looking for similar problems on internet and none have a solution, this happens in the Macbooks too!
     

Share This Page