Reason behind launchd "issue" (ReportCrash.Self)

Discussion in 'macOS' started by serpient4, Sep 4, 2010.

  1. serpient4 macrumors newbie

    Sep 4, 2010
    First off this is not a serious problem, more a failure and solution analysis out of interest. If you enjoy this kind of thing feel free to participate :)

    I kept getting these in my syslog:[77] ( Falling back to default Mach exception handler. Could not find:

    I have since fixed the issue by following this tip:

    however i put the from /System/Library/LaunchAgents to /Library/LaunchAgents and NOT as described to the <user>/Library/LaunchAgents so it would work globally and for new users as well.

    The messages have since left completely, after a single time getting[79] Already loaded

    this happened when the file existed at both locations (in /System/Library/LaunchAgents and /Library/LaunchAgents)

    All of these messages appeared only after system startups.

    My question is what difference it makes for these files whether they reside in /System/Library/LaunchAgents or /Library/LaunchAgents? And of course: What would be the most natural solution for this problem?
  2. Azagar macrumors member


    Nov 29, 2008
    San Francisco
    You received no other errors? When I tried this I got a new error.[79] launchctl: Dubious ownership on file (skipping): /Library/LaunchAgents/

    The reason behind this error is when I authenticate the copy into the launchagents folder permissions are changed, they become (User), System, & Everyone instead of System, Wheel, & Everyone.

    Repair disk permissions did not fix the error in the console log so I restored it to how I had it before.

    In general this error shows up a lot on console logs of various users when they have other problems, so I always assumed it was one of those "ok" errors from Apple.
  3. serpient4 thread starter macrumors newbie

    Sep 4, 2010

    on my machine the procedure I described worked just fine (I think i did chown it however)

    -r--r--r-- 1 root wheel 619 4 Nov 2009

    this would be
    sudo chown root:wheel
    chmod 444

    I also did a archive&install since back then so this should be about right.

    My Log goes something like this:

    19.11.10 13:22:44[1] *** launchd[1] has started up. ***
    19.11.10 13:23:07[112] Already loaded

    best regards :)

Share This Page