rebuilding, defrag, disaster.

Discussion in 'macOS' started by mcdawn, Oct 22, 2008.

  1. mcdawn macrumors newbie

    Joined:
    Oct 19, 2008
    #1
    Well,

    I posted a thread earlier this week 'rebuilding/restoring osx' or something the like, and I got some pretty good advice.

    I can let u know before hand that I can still access my drive. That means I can boot up in target mode and access all the files and back them up.

    That is not the problem however. To summarize what happened, I run disk warrior on my hard disk in target mode, since I had some troubles with my system of late (see the other thread). I just wanted to try this, before I resumed into a clean install (me=stupid!!). Everything went smooth (though I do not know whether it would have solved my problems) and after rebuilding my directory I decided, while I was at it, to defrag my drive using drive genius.

    That also went fairly smooth, until, here it comes, someone accidentally unplugged the firewire.

    That is when all hell broke loose.The drive did not reappear on the desktop, but I could still boot it (using my own macbook pro). I wanted to repair this problem and I again booted in target mode and ran the rebuild in disk warrior again (as disk utility did not want to repair, because it did not appear on the desktop, I think, though I have to admit, maybe it gave an error, I cant remember, since then I have tried so many things...)

    So, after rebuild, which passes successfully, I ran a permission verification. That seemed horribly wrong, because the estimated time was over 2 hours. So, I canceled that and thought that it might be better to do so while I booted the disk. So, I ejected the drive and restarted my macbook pro. What happens (and has happened ever since); it starts up, the apple logo appear, the spinning wheel appears and then, after about a minute, it restarts itself! And I bet it will keep on doing that forever, until the end of time, if I let it!

    So, I tried save mode and single mode. In save mode nothing happens (nothing different) in single mode, the shell comes up, but right before the prompt should appear, it restarts itself.

    Since then, I have tried everything. Rebuilding, permission restoring, restoring, verifying, rebuilding etc ect ect. And every time all repairs/rebuilds are fine. It can find only minor problems (even the disk permissions), but when I boot my machine, it runs into the start up loop. I also started up another machine using my drive to boot, and it has the same problem (so it is def. in the drive directory/system)

    The question is, does anyone know what the * is going on here. I tried to google the problem, but I could not find anything like it. Obviously, I should probably do a clean install, but maybe someone has a better idea. Especially because at the moment and for the next week I don't have access to a installer cd, which makes my computer unusable for the time being.

    Any help would be greatly appreciated.

    daan

    PS: one of the odd things is that the drive appears as smart status not supported (though i am not sure if this unusual when u access it in target mode)
     
  2. mcdawn thread starter macrumors newbie

    Joined:
    Oct 19, 2008
    #2
    one follow up question,

    with the osx installer cd for leopard, is it possible to just install the OS as a replacement for the malfunctioning OS, without doing a clean install, if the install cd is 10.5.4, while the running OS is 10.5.5. I vaguely remember that apple does not allow you to replace a newer os, with an older one, without doing a clean install...
     
  3. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #3
  4. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #4
    No, with a damaged file system, your best is an Erase & Install. Just make sure you've backed up first.
     
  5. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #5
    That's true but it's worth a try in my opinion. Especially if you don't want to reinstall everything from scratch. You can always do the erase and install later. Of course assuming you have time to do both.

    In any case backup first!
     
  6. kirkbross macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #6
    Is there a way (maybe a util) to check if your file system is damaged but may not be displaying obvious symptoms? ...kind of like a pre-emptive scan...?
     
  7. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #7
    That is what Disk Utility is made for.
     
  8. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #8
    If Disk Utility shows clean, sometimes the fsck program that you run in single-user mode will show errors. My personal experience was with an external boot drive that had problems with the cable; the file system was corrupted in ways that were either undetectable or unfixable. fsck would claim all was fixed, but within a couple days (or even hours) a problem would reappear. This was AFTER the problem with the cable was fixed. My guess is that some part of the file system was corrupt, and that led to additional corruption when the drive was used.

    It was a journaled system as well, but the bottom line is that when the hardware isn't working right, all bets are off. In fact, by the time I realized what had happened, the drive was so screwed up it wouldn't mount with Journaling on and I found & compiled a neat program that edited the drive to turn off journaling, because Apple's tools refused. That way, I was able to grab the data I needed.

    If you think you have a file system in such a state, feel free to just backup, reformat, and restore (preferably just your data, not Apps or OS, since they might be damaged as well). But you should keep in mind it is not normal for this to happen, and if it did, you should be looking for the cause.
     

Share This Page