"Rebuilding Library" Trouble

Discussion in 'iPhone Tips, Help and Troubleshooting' started by grimwwr, Mar 5, 2011.

  1. grimwwr macrumors member

    Joined:
    Sep 27, 2007
    #1
    Well I'll try and keep this short.
    I've got an iPhone 4 with 4.2.1

    I was at a concert tonight attempting to film the performers. My phone began to lag but didn't want to restart it because it would be my only chance to film the certain song. So I get the last minute of the song and the performers walking off stage (About 3 feet away, so this was a pretty exciting deal at the time) I stopped recording and pressed the sleep button. I walked back to my seat and pulled out my phone to make sure the film had saved. However, my phone had restarted and was on the Apple logo. When it started back up, I opened up my Photos app and it said "Rebuilding Library" which took about a minute or two. When it was finally done my video was gone.

    Is the video officially gone? Or would it be somewhere in the back up? Of all the footage and pictures I got of tonight's concert, that's the video I had hoped to keep the most.

    Any help would be wonderful!
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    How many photos/videos do you have in your camera roll?
     
  3. grimwwr thread starter macrumors member

    Joined:
    Sep 27, 2007
    #3
    I've got 2,242 photos/videos which all are backed up with the exception of last nights concert. I know that's a lot to store on the phone, I'm waiting on my MacBook Pro to come in to load them all on there first. Right now I'm a PC user.
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    That is not a lot to store on the phone, but that is way to many to have in the camera roll. To many photos in the camera roll, can and will cause corruption, as you found out.
    Remember, that camera roll is like any other camera, and most photographers don't store their photos on the camera.
     
  5. gigapocket1 macrumors 6502a

    Joined:
    Mar 15, 2009
    #5
    over 2 grand in photos and videos.. Wow...

    Are u sure you had enough space to save the video?
     
  6. grimwwr thread starter macrumors member

    Joined:
    Sep 27, 2007
    #6
    Yeah I agree, I have been trying to organize my photos but it is quite an undertaking any time I work on it. I've looked through backup data and every where in the camera roll and it's no where to be found. I also learned a few pictures taken before the lost video are gone too. So unless there is another method I haven't tried, I fear that it is gone forever.

    Any yes I had enough room for the pictures. I feel like this way mainly a memory problem and the iPhone just didn't have enough to function and had to restart in the middle of the saving of the video, causing it to not save at all. That's my guess, but I'm no expert.
     

Share This Page