Receiver Says PCM When Using My Atv2

Discussion in 'Apple TV and Home Theater' started by ohsnap, Jun 24, 2011.

  1. ohsnap macrumors regular

    Joined:
    Aug 5, 2004
    #1
    So my Onkyo receiver is handling all the video and audio processing of my A/V devices. My cable box sends a Dolby Digital audio signal and my BD player sends an even better HD Dolby Digital signal but when I use my ATV2 it only registers that I am using PCM processing. All 3 devices are connected via HDMI. How do I encode the audio stream to use digital audio as well?
     
  2. Dannymonky macrumors member

    Dannymonky

    Joined:
    Feb 6, 2007
    Location:
    Rats Mouth, Fl
    #2
    I'm going to assume your running the latest iOS software. Under setttings/audio & video did you play w/ any settings there? Set digital to on instead of auto? Change audio output setting? Maybe try an optical cable instead of just the HDMI. When I use my ATV2 in the bedroom with no receiver and only HDMI connection I also get PCM audio. When same ATV2 is in living room connected to receiver by optical (and to the tv w/ hdmi) I get Dolby Digital according to my receiver and my ears.
     
  3. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #3
    Keep in mind too, it will depend on what you are watching. If the program has a 2.0 soundtrack you'll see PCM. It will only switch to Dolby Digital on 5.1 encoded files.
     
  4. slothrob macrumors 6502

    Joined:
    Jun 12, 2007
    #4
    Have you tried selecting Audio: Digital in the audio settings panel on the aTV2?

    Otherwise, you might need to hold the select button down, while watching the video, to select the digital audio track.
     

Share This Page