Receiving iMessages from blocked people on my laptop

Discussion in 'MacBook Air' started by jjukebox12, Apr 12, 2014.

  1. jjukebox12 macrumors newbie

    Joined:
    Apr 12, 2014
    #1
    Good morning, well at least here in California.

    I basically signed up for the forums just to ask this question. So when someone iMessages me on my iPhone, the message will be pushed to my Messages app on my macbook air, so I have the option of sending iMessages from my laptop rather then my phone, I'm sure most of you knew this.

    But I blocked several people on my iPhone, and I can tell they still message me because their messages pop on on my Messages app on my macbook. But of course it doesn't pop up on my iPhone as they're blocked.

    So is there a way just to completely disconnect the Messages app between my macbook and iPhone, so I don't receive any messages at all? Or a way to synch my block lists so I don't see any messages at all on my macbook air from the people I blocked? I'm obviously new to using a Macbook.

    Thanks in advanced.
     
  2. kage207 macrumors 6502a

    Joined:
    Jul 23, 2008
    #2
    From what I am seeing: http://www.wired.com/2013/09/iphone-call-block-faq/

    The answer is no. There is a blocking way to do it on Messages on Mac. Though there is a button under Buddies, though whenever I tried to do it, it was greyed out. :/
     
  3. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #3
    I don't think there is any interdependence between your iPhone and MBA. iMessages are delivered directly to the computer over the internet. They are not always consistent in my experience though, messages randomly seem to appear only on the computer, others only on the phone. I think this is just bugginess, not something intentional and it doesn't happen often.

    I don't have any blocked senders so I don't know how that works. But if you just want to stop getting all messages on your MBA you can go to the Accounts tab in Preferences inside the Messages app and disable your account.

    You might check what you have set there because messages can be sent to your phone number or multiple e-mail addresses. If you're clever, maybe you can use that to block unwanted people. Through icloud you can create several aliases for example. http://support.apple.com/kb/PH2622?viewlocale=en_US&locale=en_US

    It may be that you have blocked messages from a phone number, but the same person can still send an iMessage to your e-mail address.
     
  4. jjukebox12, Apr 13, 2014
    Last edited: Apr 13, 2014

    jjukebox12 thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    #4
    Thanks for your reply, and that link! It was a nice read. :)

    Thanks for your reply, extremely helpful. Never though about them responding directly to my e-mail address, yet more to look into! Thanks for that link too by the way. :)
     
  5. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #5
    It gets very confusing. I have a friend in Europe and the way she had iCloud setup initially, I could send iMessages to her EU phone number. Then she visited the US, put a local SIM card in her phone and I could iMessage her at that number too.

    When she returned Europe, I couldn't send iMessages to her EU phone anymore, just (expensive international) SMS. Turned out that she had changed the iMessage configuration to only include her e-mail address and not her phone number. :)
     

Share This Page