Receiving phone calls on the Mac

Discussion in 'macOS Sierra (10.12)' started by dashwin, Sep 25, 2016.

  1. dashwin, Sep 25, 2016
    Last edited: Sep 25, 2016

    dashwin macrumors regular


    Sep 19, 2015
    With El Cap I had incoming phone calls working great on the MacBook Pro 15" Early 2011. Now after the upgrade to Sierra no matter what I try incoming calls don't work. The iPhone 6s Plus is on iOS 10.

    I've tried these options:
    • Made sure iCloud and Facetime accounts are the same and functioning, toggled these settings for good measure on all devices and tried rebooting both the iPhone 6S Plus and the Mac.
    • All devices are connected to the same Wifi network.
    • Turned off Wifi calling, tried receiving a call. Turned it back on (Enable wifi calling and click the Enable wifi calling on all devices on the phone), tried receiving a call. No luck.
    I can make outgoing calls to phone numbers using iPhone from the Mac (it doesn't use Wifi calling but uses the iPhone even if Wifi calling is on). With Wifi calling on and with the iPhone 6S Plus in Airplane mode, I can't make calls from the Mac (which pretty much means Wifi calling is off on the Mac).

    UPDATE: I was able to resolve this, see below for the update.
    --- Post Merged, Sep 25, 2016 ---
    Resolved it! Posting the fix in case anyone else faces the same issue.

    NOTE: This issue may not have been specific to the Sierra or iOS 10 upgrade, but I am posting here since I thought this may have been the case.

    The following sequence helped with a Sierra Mac and iOS10 phone:
    • Made sure Facetime and iCloud are logged into the same iCloud account on both the phone and the Mac
    • Made sure Wifi calling is on (Settings -> Phone -> Wi-Fi Calling, turn on if your carrier supports it) AND made sure Calls on other devices is also on (Settings -> Phone -> Calls on Other Devices)
    • Made sure both phone and Mac are on the same WiFi network
    • Reset the Network settings on the phone (General -> Reset -> Network settings). Rejoin the same Wifi network that the Mac is connected to.
    • Sign out of iCloud on the phone (Settings -> iCloud, scroll all the way to the bottom, Sign Out)
    • Wait for two minutes
    • Sign into iCloud on the phone
    After this I was able to test an incoming call just fine.

    Works perfectly now.
  2. DrVinnie macrumors newbie

    Sep 26, 2016
    thanks for putting that together and sharing.

    I have a similar problem and tried your solution, but still no go.

    early 2011 13" MacBookPro with 16GB Ram and SSD with upgraded wifi-bluetooth card with CAT activated running 10.12beta1 (although its been all previous Sierra versions). So iPad Mini2 will Handoff to MacBookPro and vice versa. iPhone6 will handoff to iPad and vice versa. However, iPhone will not handoff to MacBookPro. When I get a phone call, FaceTime starts up but when you hit the answer it freezes and appears to not communicate back to iPhone.

    When I tried following your suggestion and got to resetting Network, all three devices hiccuped. I needed to sign into the network on all three devices. I think when I reset, it reset the iCloud Keychain on everything. Anyhow, I'm pretty puzzled why two iOS devices work fine with Continuity & Handoff and one iOS device to laptop works fine, but the second does not see that laptop. Frustrating.

    BTW- El Capitan worked perfectly fine.
  3. yellowscreen macrumors regular


    Nov 11, 2015
    Do any of you have problems with call quality over mac?
  4. dashwin thread starter macrumors regular


    Sep 19, 2015
    Have you tried just signing out of iCloud on both the phone and the MBP and then signing back in?

    I am not using the CAT tool. If that doesn't fix it, I wonder if it's CAT related. Theres another thread on the issues of CAT and Sierra that you may want to check under.
    --- Post Merged, Sep 26, 2016 ---
    Works fine from what I can tell, no issue here. Are you referring to you not being able to hear the other party or the other way around?
  5. yellowscreen macrumors regular


    Nov 11, 2015
    No, its just the quality, people hear me like im speaking from the water well or a cave
  6. DrVinnie macrumors newbie

    Sep 26, 2016
    --- Post Merged, Sep 27, 2016 ---
    I've signed in an out on all three devices. What I have not done is sign in and out on the other two devices that I have. Neither of them are on the same network, a desktop on El Cap and a laptop at work. I suppose its worth a try.

    I wonder too whether its CAT related. Actually, I hope it is, so there might actually be a fix.

  7. DrVinnie macrumors newbie

    Sep 26, 2016
    Ok, finally figured out what was going wrong with Handoff. I was looking at another thread which referred to cloudpaird process. Went into activity monitor and forced quit cloudpaird, and voila, Handoff working again. Still no receiving phone calls on Mac.

Share This Page

6 September 25, 2016