Recent Files - Right Clicking Dock

Davieis

macrumors regular
Original poster
Aug 20, 2007
152
0
Melbourne, AU
It appears that Lion shows all recent documents when right-clicking an app in the dock. For example right-clicking Pages shows a list of recent pages documents or QuickTime shows a list of recent videos.

Anyone know how to turn this off? Makes it difficult to keep private files hidden :D
 

rorschach

macrumors 68020
Jul 27, 2003
2,064
591
That was really annoying me but I figured out today how to clear them!

Go to ~/Library/Preferences. Find the preference file for the app (Preview is com.apple.preview for example). There should be a second preference file for each app with "LSSharedFileList.plist" appended to the end. Delete that "xxx.LSSharedFileList.plist" file.

You'll have to kill the Dock in Activity Monitor or in the Terminal, but it does clear them.
 

richard.mac

macrumors 603
Feb 2, 2007
6,299
2
51.50024, -0.12662
i really like that feature as it works for closed apps and hoped Apple would add it to other apps like Safari with most browsed sites and iTunes with most recent songs for example.

an easier way to clear the list is just clearing recent items from the file menu and then relaunch the app.
 

MartiNZ

macrumors 65816
Apr 10, 2008
1,196
98
Auckland, New Zealand
Oh that's great news that such a feature made it in! One of my favourite things that Windows 7 does better. And of course Office:Mac already did it, so very much a Microsoft signature, good on Apple for following suit.
 

rorschach

macrumors 68020
Jul 27, 2003
2,064
591
i really like that feature as it works for closed apps and hoped Apple would add it to other apps like Safari with most browsed sites and iTunes with most recent songs for example.

an easier way to clear the list is just clearing recent items from the file menu and then relaunch the app.
Doesn't work. There's no way via the GUI to clear that list.
 

richard.mac

macrumors 603
Feb 2, 2007
6,299
2
51.50024, -0.12662
im pretty sure i cleared the list in the GM by clearing recent items and then relaunching the app (or maybe it was dragging the icon in & out of the Dock), sorry if im wrong i couldn't double check as right now i don't have Lion installed.

if it doesn't then deleting the LSSharedFileList plist will be the way to go.
 

SDRacerR1

macrumors member
Aug 28, 2009
64
6
Saw this today which is very helpful regarding this (http://simon.heimlicher.com/hints/macosx/disable_recent_items)

Lion lists recent items with each application in the Dock (accessible via right-click) and in the Application View of Mission Control. To remove those and disable future additions, run the following commands in the Terminal. Note that to figure out the application's bundle identifier, you can open Activity Monitor, click the application in the list of processes and then click the “Sample Process” button. Then makes sure the “Display:” popup is set to “Sample Text”.

Output for VLC:

Sampling process 66975 for 3 seconds with 1 millisecond of run time between samples
Sampling completed, processing symbols...
Analysis of sampling VLC (pid 66975) every 1 millisecond
Process: VLC [66975]
Path: /Applications/VLC.app/Contents/MacOS/VLC
Load Address: 0x100000000
Identifier: org.videolan.vlc
Version: 1.1.11 (1.1.11)
Code Type: X86-64 (Native)
Parent Process: launchd [175]
[...]
VLC's application bundle identifier is thus org.videolan.vlc.

Now, to disable recent item listing for VLC, you would issue the following commands in Terminal:

defaults write org.videolan.vlc NSRecentDocumentsLimit 0
defaults delete org.videolan.vlc.LSSharedFileList RecentDocuments
defaults write org.videolan.vlc.LSSharedFileList RecentDocuments -dict-add MaxAmount 0
 

oddbob

macrumors newbie
May 8, 2010
16
8
Scotland
Easiest way

For VLC, recent items in dock.

Open applications - Utilities - Terminal, copy and paste
defaults write NSGlobalDomain NSRecentDocumentsLimit 20

Change 20 with whatever the number of items you want listed
Hit enter, you should get a confirmation with the name of your mac.
Kill Terminal and restart VLC, I had to do it twice.

http://hints.macworld.com/article.php?story=20050919045154542
 
Last edited:

Similar threads

  • Misses9098
11
Replies
11
Views
596
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.