Recently bought iPhone stuck in recovery mode

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TimGeerts, Jan 3, 2011.

  1. TimGeerts macrumors newbie

    Joined:
    Jan 3, 2011
    #1
    So, I recently bought an iPhone 3GS 16GB from a dude with an ad on the internet, so yes, secondhand.
    Since it still had all his data on it, I used the "Erase all data and settings" feature, which would clean out the iphone completely.

    Now, when I try to connect it to iTunes, it says it's in recovery mode and I have to restore it. Since I don't have any previous stuff to restore from, I downloaded the 4.2.1 ipsw file, and used the "option"+"click" on restore to select that file.

    None the less, it doesn't seem to work.
    iTunes seems to be restoring the iphone, but after a minute or 5, I just get an error message (1015) as it could not be restored.

    I totally don't know what to do now.

    I don't know if that guy had a jailbreak, but, I'm quite sure he didn't. I know he had 4.2.1 on the iPhone.

    What else can I try to do to get the iPhone to just be a "new device"??


    PS, I'm sorry if some of the stickies should answer my questions, I've searched around a bit, tried some approaches, but nothing seems to work...
     
  2. astrakick10 macrumors newbie

    Joined:
    Jan 3, 2011
    Location:
    Uk
    #2
    Hi have you tried putting phone into dfu mode to restore it?? If not google iPhone dfu mode and click on first website that comes up on top. Worth a try first!!
     
  3. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #3
    I've just now tried that (home + power button for 10 seconds, then release power but keep home button pressed).
    Iphone screen remained black, which is a sign that I'm indeed restoring in DFU mode (or so I've read).
    Yet, it seemed to have failed again :(
    Still receiving the error 1015.

    I've also tried kicking it out of recoverymode with TinyUmbrella (another tip I found around the net), yet it seems to just kick it out, restart it, and iTunes just pops up and says it's in recovery mode...
     
  4. edrodriguez951 macrumors newbie

    Joined:
    Jun 14, 2010
  5. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #6
    Just tried the tool (thanks for the link), but it didn't do anything either.
    It said it was kicking the iPhone, the iPhone went off, and on again, iTunes popped open giving me the nice message the iPhone is in recovery mode and needs to be restored... vicious circle much =(
     
  6. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #7
    A bit of googling brought me to this page indeed, yet, I stopped reading after "you need to have the SHSH blobs...", seeing I'm new to this, I don't even know what it is. Let alone that I should have those files seeing I just bought the iPhone today from someone I've only seen when I went to pick up the phone...
     
  7. X2thaP macrumors member

    Joined:
    Nov 28, 2010
    #8
    Might be a stupid question, but have you tried just doing this normal restore that iTunes offers you?

    Because even if you have nothing to restore from, it will simply do a fresh install and after that it should
    ask you wether you want to restore from a backup or as a new phone, in your case you would choose the latter.
     
  8. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #9
    Yeah, the normal restore was the first thing I tried when I noticed it wasn't booting correctly anymore. I was hoping for such a feature "new phone", but after doing that normal restore, I got the same error that the restore couldn't complete.
    Is it worth trying to restore it to a previous version? (I downloaded the 3.1.3 ipsw to try that)
     
  9. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #10
  10. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #11
    Yeah, that's indeed the firmware with which I tried the restore, the exact same file. But, as said, sadly it doesn't seem to work...
     
  11. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #12
    Ok, so I emailed the seller, and he acknowledged that the iPhone isn't factory unlocked, but that they used a software unlock.

    I also came accross this site (http://www.coveringweb.com/2010/12/restore-iphone-3gs-3g-to-ios-421-41-on.html)
    (@moderator: if I'm not allowed to link stuff here on the forums, please remove the link)
    on which one phrase cought my eye: "If you are currently on 4.2.1 then you’ll have to restore back to 4.1 (because 4.2.1 will not allow you to kick the phone out of recovery when 1015 occurs due to the silly BB / iOS mismatch check added there".

    So, what are my options here?
    I don't have any SHSH files to use in the restoration process, so I can't downgrade, yet I can't get out of recovery mode either. And there's also no jailbreak out yet for 4.2.1 (and even then, I wouldn't know where to begin).

    Isn't there a simple way to get 4.1 back on the iPhone, and then jailbreak/unlock it again myself?
     
  12. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #13
    There is a jailbreak available for 4.2.1,(Called redsn0w) I have never unlocked so I am not sure what is needed to unlock the iPhone (Whether you need a old BB or something) so can someone else please shed some light on this?

    However I do know to fix your iPhone you are going to need to put it into DFU mode and will have no choice but to restore and stay at 4.2.1, downgrading is impossible. I am almost sure that 4.2.1 won't be unlockable, which would make the iPhone useless unless you use the carrier it was locked too.
     
  13. TimGeerts thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #14
    I "think" (don't quote me on this) that unlocking works with something called ultrasnow, which I read a bit about yesterday as well.

    Sadly, I am starting to believe you are right, I'm quite sure I rendered it unusable. Or at least untill there's a 4.2.1 jailbreak with unlock possibility...
    I truly hope it's still fixable, now, or at some point in the not to distant future...

    For now I passed the phone on to a friend of mine that has way more knowledge about all this, I'll see what he has to say...

    Thanks so far guys, and I'll try to keep people posted on the progress.
     
  14. memoryleaves6 macrumors newbie

    Joined:
    Mar 12, 2011
    #15
    Resolution?

    I'm having the same problem. Did you ever figure this out?
     
  15. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #16
    I suspect that this 3GS has an Ipad 06.15 baseband on it. So, you can't use official Apple firmware to restore your phone to. You need to have a customs firmware (search on the net or have your friend with Mac burns one for you) and restore it through Itunes. Make sure the phone is in DFU mode to restore and not recovery mode.
     

Share This Page