Recently purchased iPod Classic requires iTunes 11.1 or later?

Discussion in 'iPod' started by logicstudiouser, Oct 19, 2014.

  1. logicstudiouser macrumors 6502

    logicstudiouser

    Joined:
    Feb 4, 2010
    #1
    Just bought one of the last iPod classics a couple weeks ago, but just noticed the back of the box says 'iTunes 11.1'. I am still a loyal iTunes 10.7 user and thought I could use the iPod classic with 10.7. (Especially because this is the late 2009 gen iPod classic.) How could this possibly say iTunes 11.1?

    Has anyone else recently got an iPod classic that has this label? Is it true that it requires iTunes 11? If so, when did Apple change the requirement to iTunes 11? :(

    Still sealed in packaging. This is the label on my box:

    [​IMG]
     
  2. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005

Share This Page