Reconnecting mighty mouse and kb BT impossible

Discussion in 'Mac Accessories' started by p.burgisser, Apr 1, 2009.

  1. p.burgisser macrumors newbie

    Joined:
    Apr 1, 2009
    #1
    Hello everyone,

    I tried to find an issue on the web but I still have the same problem.

    So, firstly I connected my Apple Aluminum Wireless KB and my BT Mighty mouse on my mac on monday, it worked very well until today!

    Today, I wanted to install windows XP in bootcamp (Windows on mac.. shame on me) and tried to connect the mouse and kb, it worked well for the mouse and it didn't work for KB, as I read it's impossible to connect the kb to XP.

    Then I came back to mac os and none of these peripherals wanted to work again!! I tried to delete them from the BT manager and reinstalled them, it didn't work. I tried to delete the com.apple.bluetooth.plist on /Library/Preferences and same result...

    It always find them, ask to pair them put after less than 1 min I get a pairing error... the mouse led still blinking and the BT manager ask to enter the passkey in the keyboard, but it doesn't work if I press the enter key.

    I'm going to be crazy because it still working on windows!! and on my former powerbook g4 12''....

    I don't want to format my mac after only 4 days!!

    Does anyone have an idea?

    Thank you for your help!
     
  2. p.burgisser thread starter macrumors newbie

    Joined:
    Apr 1, 2009
    #2
    Found the answer :eek:)

    I connected them to my former powerbook
    Renamed them, disconnected and deleted from the powerbook.

    On my macbook, I deleted the file com.apple.bluetooth.plist and restarted the computer.

    Finally, I tried for the last time to reconnect the KB and mouse, worked perfectly!

    Lost 3 hours to tad :S:S

    Thank you !
     
  3. tamasvarga67 macrumors regular

    Joined:
    Sep 29, 2007
    #3
    My early MBP and new Mini works perfectly with Apple BT wireless mouse and keyboard under Leopard and BC XP. I had troubles under BC XP first but the solution is that when you add a new BT device after you selected you have to right click on the mouse/keyboard name and thick the drivers check box under services tab. No problems since then...
     

Share This Page