Recording the screen with audio

hieuky

macrumors member
Original poster
Nov 15, 2008
44
0
Hello, everyone! I recently installed Soundflower, and am still struggling in getting it to work. The issue here is that I'm deaf, and would like to ensure that the audio is working properly, so my nephews could hear and watch the movies. The only way to find that out is using my iPhone Voice Memos to see if it responds when capturing sounds.

So, can anyone please provide clear step-by-step with Quicktime and Soundflower? I think I may have adjusted the preferences of sound in System Preferences, resulting both Quicktime and Soundflower not working properly.
 

AlexCC

macrumors newbie
Mar 24, 2012
10
0
Netherlands
I have recently successfully recorded some stuff from the screen (with audio) using Soundflower and Quicktime. Although I don't think using Soundflower is strictly necessary in the process. I use Soundflower to be able to control the volume on my sound card with the standard up/down buttons.

Anyway, this is what I did:

- Set up Soundflower (2ch) as output device (you can of course also use 16ch) via Alt-Click (not right-click, because that only gives the volume slider!) on the little loudspeaker in the menubar.
- Select the audio output in "Soundflower (2ch)" again via de menubar. In my case that is the name of my external sound card.
- Then open QuickTime and select "New Screen Recording" under "File" and a little screen pops up.
- On the right side of that little screen there is a down-pointing arrow.
- Click it and select "Soundflower (2ch)" from the drop down menu.
- Once that's done, click the red record button.
- Then click somewhere random to start a full-screen recording
- Or drag a box around the thing you want to record (you can crop it and move it about after the initial drag) and click "Start Recording".
- Then click the stop button on the controller to stop and wait a bit to let is finish the video.

I noticed that the sound levels in my recording where very low. Eventhough, the actual sound I was hearing through my speakers whilst recording was on a normal level. Furthermore, I put the volume slider under the record button all the way to the right, but it didn't make much difference.
So in order to hear the actual sound of the recording on a normal level you have to put the volume on your computer all the way up and possibly also that of your speakers.

That is maybe the reason why the app is not showing any indications of there being sound around. So maybe you were already doing everything right, but it is just that the sound level of the finished product are rather low.
 
Comment

M-B-P

macrumors regular
May 15, 2010
169
0
Thanks

I have recently successfully recorded some stuff from the screen (with audio) using Soundflower and Quicktime. Although I don't think using Soundflower is strictly necessary in the process. I use Soundflower to be able to control the volume on my sound card with the standard up/down buttons.

Anyway, this is what I did:

- Set up Soundflower (2ch) as output device (you can of course also use 16ch) via Alt-Click (not right-click, because that only gives the volume slider!) on the little loudspeaker in the menubar.
- Select the audio output in "Soundflower (2ch)" again via de menubar. In my case that is the name of my external sound card.
- Then open QuickTime and select "New Screen Recording" under "File" and a little screen pops up.
- On the right side of that little screen there is a down-pointing arrow.
- Click it and select "Soundflower (2ch)" from the drop down menu.
- Once that's done, click the red record button.
- Then click somewhere random to start a full-screen recording
- Or drag a box around the thing you want to record (you can crop it and move it about after the initial drag) and click "Start Recording".
- Then click the stop button on the controller to stop and wait a bit to let is finish the video.

I noticed that the sound levels in my recording where very low. Eventhough, the actual sound I was hearing through my speakers whilst recording was on a normal level. Furthermore, I put the volume slider under the record button all the way to the right, but it didn't make much difference.
So in order to hear the actual sound of the recording on a normal level you have to put the volume on your computer all the way up and possibly also that of your speakers.

That is maybe the reason why the app is not showing any indications of there being sound around. So maybe you were already doing everything right, but it is just that the sound level of the finished product are rather low.
Thanks a lot!
I actually noticed that the sound was a little low too, but I used VLC to output the audio at about 200% and it worked fine for me. Thanks again!
 
Comment

adeedew

macrumors regular
Dec 29, 2005
168
1
This worked perfectly. Is there a way to crank the volume tour capturing even more or manipulate soundflower setting or do in post? Anything recorded off say a live webstream the audio is always very low even if you crank it before recording. Thanks
 
Comment

Similar threads

  • jparker402
3
Replies
3
Views
275
  • ShellBell0827
0
Replies
0
Views
333
Replies
4
Views
801
Replies
2
Views
430
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.