iPhone recover an iphone 3GS

Discussion in 'Jailbreaks and iOS Hacks' started by exterminator, May 19, 2013.

  1. exterminator macrumors regular

    Joined:
    Jun 6, 2010
    #1
    Hi all,

    I am writing this post after having spent no less than ten straight hours in trying to recover an iphone 3GS.
    I was given this broken iphone 3gs which wouldnt even start. So i tried recovering it.
    However when I attempt to do so nothing happens. I have no idea what OS it is on, I have no idea what happened to it nothing.

    I plugged it to itunes where it went straight into a recovery mode, and i attempted to restore and install 6.1.3 -> nothing

    I have downloaded various tools and firmwares and sending it into DFU mode to install -> nothing.

    When i use the fix recovery application, I get a number of errors

    libusb:error darwin transfer status transfer error timed out (from the console)

    then form the phone i get some error at the start about missing
    gBdevlist
    gimagelist
    fs_mount
    fs_unmount
    fs_load_file

    At the end it tries to download something but it times out. it gives an error, no successful download after 60000ms, giving up. Something related to AppleBCMWLAN

    I literally have tried everything and attempted different versions.
    Can someone give me some advice as to how I can proceed?? I am under the impression that the device is completely wiped out

    I repeat, i have no idea what software it had.

    Thanks in advance to all those who reply.
     
  2. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #2
    its probably not usable. something must be wrong with the internals. have u tried dfu mode, and recovery mode?
     
  3. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #3
    the phone goes always immediately to recovery mode. When i try to run something I always get some form of response from the device but it seems to fail afterwards. I get a white screen, apple logo with progress bar anything... But it freezes then..

    Would a new battery help? or would i have to change the logic board??

    Any help would be greatly appreciated as Im literally clue less about this.
     
  4. segers909 macrumors regular

    Joined:
    Jun 7, 2009
    Location:
    Belgium
    #4
    During a regular iTunes restore form DFU mode, what error does iTunes end with?
     
  5. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #5
    On a completely regular attempt to restore, the device's screen lights up, the apple logo is displayed, then an empty progress bar underneath.

    On the Mac i get waiting for iphone, preparing software and a progress bar. It stays like that and nothing ever happens. I dont remember exactly what it says but i think its preparing software for update. No error message when I attempt a regular restore. I tried it a few times to no avail.
     
  6. segers909 macrumors regular

    Joined:
    Jun 7, 2009
    Location:
    Belgium
    #6
    Have you tried the restore using a different USB cable and computer? Give it lots of time next restore, eventually it'll error out. This error can tell you a lot about what is wrong with your iPhone by looking it up here.
     
  7. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #7
    I have tried a windows pc. Once it gave an error causing the entire os to crash (no surprises there) and another time it simply stood there as had happened on the mac. i changed wire 3 times.

    I was thinking of either reinstallign itunes or else trying on my sisters macbook. but i didnt want to use her macbook. When you say lots of time... Would you recommend leaving it for more than 3 hours? i was afraid of leaving it that long, because it got somewhat warm after 30 mins... Ill leave it overnight if i must
     
  8. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #8
    What about restoring to a firmware with no baseband just encase the iPhone 3gs as the iPad baseband on it
     
  9. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #9
    Can you go into some detail as i have no idea what that means :)
     
  10. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #10
    *bump*

    Update: I have found out that there were blobs for ios 4.1, so i proceeded in attempting to restore to a custom version of the 4.1 OS.

    However it stays preparing software or waiting for iphone. and it just stays like that. I get an apple logo on the display along with an empty progress bar. IT stays forever like so.

    I have attempted to restore to the normal 6.1.3 OS and i got the same result.

    Sometimes, i cant remember when, i got an error 1600
     
  11. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #11
    You don't need blobs for 4.1 currently as its still being signed. Have u taken it to apple?
     
  12. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #12
    We don't have an apple store in my country, just an apple store official reseller, which is probably different.


    What I cannot understand is this. Its previous owner damaged considerably its screen whilst he was pushing something with the device in his pocket. In fact the screen (not the display itself) is heavily damaged. When i attempt to restore a firmware, the display itself shows no signs of damage.

    I cannot understand how this physical damage led to the phone not even booting at all. Could it be possible that some internal component was damaged and maybe that is why it is not booting? I was thinking of replacing the battery. Would it make any difference??
     
  13. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
  14. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
  15. novice121, May 26, 2013
    Last edited: May 26, 2013

    novice121 macrumors member

    Joined:
    Feb 15, 2013
    #16
    I had a much worse situation that needed a more extreme mode of reset, not just software.

    I was at a point where the screen would always be black, no matter what, and way past the white screen of death. No software tricks out there worked, even came up with a little trick after so many attempts using iRecovery in a way all instructions and tutorials out there didn't show.

    Anyways, the only thing that saved me was a hard hardware reset done by disassembling the phone and disconnecting the battery from the motherboard completely for at least one hour. No less than one hour. It's really simple really, just follow a tutorial on Youtube.


    After that, I was able to finally restore to (luckily) 5.1.1, because someone saved those to cydia using Redsnow before...

    But Redsnow, in the latest and other versions failed to create a custom ISPW, even in different computers with XP, Windows 7, and 8, all fresh and formatted... It even let me download those blobs but later wouldn't verify the same blobs as valid, even though it did before... just a complete mess of many many many variations of ways to get it to restore... (quick tip: if Jailbreaking with Redsnow and getting many many errors after the Limerain exploit phase.. just press "Back", and hit Jailbreak again, and this time it goes through, speacially for those keyplist missing or whatever error, or the other one about not supporting your device)


    Finally I was able to restore doing a weird combination of a custom ISPW with iFaith (WITH the "invalid" blobs), and iTunes, and for some reason, TinyUmbrella as well, I forgot how that helped, but I believe it had something to do with Apple's IP adress in the host file... I forget...


    Anyways, I couldn't see anywhere in this forum that trick about disassembling the phone for a true hard reset, but trust me, it was the only thing that worked to give back life to my 3GS.


    Tip: disassembling the phone it's too easy, the only thing to worry about is the lifting of the glass, preferably with a suction rubber cup, done gently from the bottom... some tutorials don't show this, and people end up ripping the lcd cables, so look at this one:

    http://www.youtube.com/watch?v=d07cCZ1BWPs
     
  16. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #17

    Thank you for this feedback! I will have a look at it in detail and I shall let you know how everything goes!
     
  17. novice121 macrumors member

    Joined:
    Feb 15, 2013
    #18


    Ok, you don't need to worry about baseband upgrade or blobs right now, all you need to do is at least restore 4.1.1 one time successfully. Once you do that, downgrading baseband, jailbreaking, and fetching blobs (if available) it's pretty easy...


    There is one limit or 2 to worry about later though, not now... that is; if you want a tethered jailbreak on 6.1.3, and you happen to have an old bootrom on that 3GS, you are in luck, and you can!!! if not, then no cake for you!! and you will have to jailbreak other firmware (if you have the blobs for them, except 4.1.1)

    Also, about that baseband downgrade... you truly want baseband version 05.13.04 on it, that way, you have no GPS issues, and you'd be able to do an IMEI unlock IF you wanted to... for that, you have to upgrade to the iPad baseband, and then downgrade from it using Redsnow.

    Pretty simple, except that if your iphone was made on week 45 of 2009 or later, you're screwed, and you shouldn't flash it... week 40 to 45, results may vary, and 40 or below is what you want.

    To determine that, just look at your serial number, the third, fourth and fifth digit will tell you. For example serial number XX926XXXXXXXXXX means that it was made on week 26 of 2009, so you really want that third digit to be 9, and the other 2, to be lower than 40.


    Mine was week 42, and they were right about results varying, because I think that somehow damaged my phone and put me in a black screen of death at first, so, it's a gamble.
     
  18. exterminator, May 26, 2013
    Last edited: May 26, 2013

    exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #19

    I have done successfully what you said. Now I have proceeded to restoring, using redsn0w to iOS 4.1. on the device I have the apple logo with an empty progress bar, on the app I have Creating Partition map. its been like that for quite a while now. What would you recommend?

    Should i try again using iTunes? patch hosts file? try a different iOS?

    EDIT: i have tried 4.1 on itunes, keep getting error 2009
     
  19. novice121 macrumors member

    Joined:
    Feb 15, 2013
    #20

    Don't use Redsnow for restore, after you have done a "hard reset" disconnecting the battery from the motherboard for an hour, fetch whatever blobs you can using both Redsnow (more-even more- blobs -fetch) and iFaith as well. Use them more than once to be sure.

    You can either stitch the blobs you have to whatever ISPW the blobs are for (preferably 5.1.1 for me), or just go ahead to 4.1.1 (no blobs needed). You can use iFaith to create a custom ISPW to preserve baseband, do so just in case, and only use the custom ISPW created by iFaith, not by Redsnow.


    After that, and before opening iTunes, make sure your hosts file doesn't have the apple IP in it, otherwise iTunes won't restore to that firmaware.


    MAJOR tip: at first, my device would not accept the custom IPSW created by iFaith, but I notice iFaith created my first custom IPSW at 300MB or something, and something was off about that, so I re-created it with iFaith again, and then it took it correctly... after that everything else was easy.


    Remember that later on, if you have an old bootrom, you can upgrade and jailbreak 6.1.3. Use These tools to do the work, always get them from their original website:

    Code:
    http://ih8sn0w.com/
    (tinyumbrella, I can't remember, but I think I only used it to start it's TSS server, but now I think removing the Apple IP manually would've been enough. I made such a mess of things I tried, that I forget easily)


    Also, remember that when you create a Custom IPSW with iFaith, you open iTunes and hold Shift + Restore to choose that custom IPSW you created (in case you didn't know)

    Last tip: Getting the device in DFU mode properly takes a bit of manual skills and right timing... at that time I did it so many times, I could do it with my eyes closed (literally, because the screen was black and not even an apple logo appeared)
     
  20. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #21
    dang... I used redsnow after the hard reset. Guess I'm gonna have to hard reset it again then...
     
  21. novice121 macrumors member

    Joined:
    Feb 15, 2013
    #22

    Sorry, I should've specified better.

    Did you notice anything different after the hard reset? For me, for example, I actually got a small sign of life that it didn't have before, iRecovery could read a USB connection properly, which is all I needed at the time.
     
  22. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #23
    well in all fairness, redsn0w reacted a bit better.

    I got reading NAND something and the creating partition map came up earlier.
    Other than that, I got the usual. the apple logo, the blank white screen etc... I can't understand how it got in this state when all its owner claim he did was break its cover due to an impact

    I think ill hard reset it again and start afresh. I have also decided to purchase a new battery
     
  23. novice121 macrumors member

    Joined:
    Feb 15, 2013
    #24
    I hardly recommend NOT replacing the battery until you are finished with this. Then do as you please.

    I got freaked out at the white screen the first time, but it was nothing compared to the black/ no usb read one lol...

    I got the white one first, fixed it, and then out of curiosity messed it up even worse again later doing more experiments that I didn't have to do really. I think it was either of the 42 week when flashing the baseband, or because I chose YES whe I should've chosen NO on the "is this a new model" question in Redsnow... don't do things rushed and pay attention lol



    About the battery, many many scams out there with them, I could never find an original OEM battery, I just got lucky and found one that seemed to work (others seemed to failed to lots of people)

    This is for my 3GS 16G iPhone, don't know if the serial numbers are the same for the 8G version:

    This is the original battery:

    [​IMG]

    And I replaced it with this one, and it worked. I had to take a gamble and make sure the serials matched:

    (The pictures on Amazon from the sellers don't always match, I just got lucky)

    Code:
    http://www.amazon.com/gp/product/B004JHE7ZO/ref=oh_details_o07_s00_i00?ie=UTF8&psc=1


    ----------

    Umm, you didn't mention this before. I'm no guru on this, but I believe all of software related issues are fixable if you have patience, BUT if it really is hardware related (white screen due to a bad lcd connection or whatever), then I won't be able to help you much.
     
  24. exterminator thread starter macrumors regular

    Joined:
    Jun 6, 2010
    #25
    Thank you for your feedback, this is all much appreciated. I will proceed in doing this again soon.

    I dont think its a hardware issue related to the LCD. as I get an apple logo, text on screen(When i attempted to jailbreak). Im pretty sure the LCD is fine.
    I will attempt to reset it again and try again in a few hours. Hopefully all will go well this time. I will keep you posted :)

    Quick question again: so you recommend i create a custom firmware for 4.1.1 using iFaith and restoring in iTunes (in dfu mode)?? just to make sure i understood correctly. I think I have already created one of those here somewhere.
     

Share This Page