Recover Data off 2010 Mac Mini RAID Drives

Discussion in 'Mac OS X Server, Xserve, and Networking' started by GandGNetworks, Jan 21, 2013.

  1. GandGNetworks macrumors newbie

    Jul 6, 2011
    San Diego, CA
    I have a Mac Mini with OSX Server. Its the older model around late 2010. Instead of the optical drive, it came with an additional hard drive configured as a RAID volume to make it a 1TB total disk space. The server will not boot and it gives the "You need to restart your computer. Hold down the power..." after about 15 minutes of it on the Apple logo screen. It has other information on the screen that reads:

    panic(cpu 1 caller 0x47f5ad): "Process 1 exec 1 of /sbin/launchd failed, errno 85\n"@/SourceCache/xnu/xnu-1504.15.3/bsd/kern/kern-exec.c:3145

    Debugger called: <panic>
    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)

    BSD process name corresponding to current thread: init

    Mac OS version:
    Not Yet Set

    Kernel version:
    Darwin kernel version 10.8.0: Tue jun 7 16:33:36 PDT 2011; root;xnu-1504.3~1/RELEASE_I386
    System Model name: Macmini3,1 (Mac-F22C86C8)

    System uptime in nanoseconds: 219628964041

    I really need to recover data that was from the week of the crash. I have a backup that was ran the Friday before but there is REALLY important client files that I need from this week. Is there a way I can pull data from the drives individually? Can I put them in two separate enclosures and rebuild the RAID? I dont have an external DVD drive that I can use to boot from the OSX Server disc.
  2. Soverc macrumors member

    Oct 7, 2005
    Target disk mode

    Not sure if this will work, but should and will cause no harm to try.

    Connect mini to another mac with firewire.

    Boot mini while holding 'T' this will put you in target disk mode.

    Since this is softraid your other mac should see the VOL. Backup data ASAP at this point. If you only see the disks in disk Utility as separate and they are not mounted let me know there is one other thing to try.

    !!!!!DO NOT MOUNT if you are not seeing the raided vol.

    As for the error, with out seeing console logs not sure what to tell you.
  3. GandGNetworks thread starter macrumors newbie

    Jul 6, 2011
    San Diego, CA
    I tried booting it to target mode but it does the same thing. When it starts, I get the grey screen without the apple. After about 5 minutes the apple logo appears. After another 5 minutes, I get the same error and restart prompt. I tried target mode and recovery mode. Both don't work
  4. Soverc macrumors member

    Oct 7, 2005

    IF you have no backup, pull the drives and put them in a working machine that has a boot drive. Yep this will most likely not be that easy, but an external case or mac-pro desktop should work. If using external case/s for drives, try and avoid USB altho it may work.

    If you have a backup, I would first try and install over top of what you have, if that does not work, wipe and reinstall.

    If you have to wipe and reinstall, consider

    Not running softraid , you can use a sym link to sorta put the 2 vols together
    If you do softraid and have another computer around, consider dumping your syslog from this mini elsewhere. Google remote syslog syslog.conf and you will find how.

    Reason I would do that is to find out if this panic happens again is if the issue is hardware or software.

    One last thought and might be better than the above ideas, connect external drive, install OSX to this drive, now you should have access and did not have to remove the drives.


Share This Page