Recover from TM Backup-Computer Hangs!

Discussion in 'macOS' started by Blair230, Dec 31, 2009.

  1. Blair230 macrumors regular

    Joined:
    Feb 17, 2009
    Location:
    Near Philly
    #1
    I am still troubleshooting this but I would appreciate any suggestions as well. Last night, my 24" C2D imac became unresponsive and had to had a force shut down. When I rebooted, I got the white apple screen for approx 10 mins.

    I then booted from the Snow Leopard CD and did a complete restore from my Time machine Backup. The computer did come back but when I tried to open most programs (Safari, Mail, Itunes, iPhoto) they all unexpectedly crashed. When I looked at the crash log it mentioned something about a java webkit being missing?

    Finally I got firefox to open. But the computer would hang every 10 seconds and have a spinning beach ball. It would hang for 10-30 seconds then it would just continue that cycle.

    I restarted from the CD again, ran Disk Utility and repaired permissions. I tried running from my hard drive and still had the freezing/hanging issue. I then restored my HD from another TM backup (different time). But still had the same issue

    I downloaded the combo update 10.6.2 on another machine, tried reinstalling that to no avail.

    I currently am restoring yet ANOTHER TM backup from yesterday morning (since I know that was a good boot).
    I dont think it is a hard drive issue because I do have a bootcamp partition, and can boot into that with no problems/issues.

    I wanted to ask if there were any ideas of what this could be or anything else I could try? I was thinking about redownloading the java updater and seeing if that helped...

    Any suggestions would be GREATLY appreciated. Thanks!!!:apple:
     
  2. vansouza macrumors 68000

    vansouza

    Joined:
    Mar 28, 2006
    Location:
    West Plains, MO USA Earth
    #2
    How does your system behave when you just do an install and do not restore any files? In other words ... before you restore what could be problematic data...
     
  3. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
    #3
    this happened to me once. apple said it was a bad backup. do a clean install of snow leopard and pull off ur files from the backup, or use an earlier backup....the one u were using is corrupted. it sucks i know, but u know..what are u gonna do.
     
  4. KoolStar macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #4
    Its possible to restore the TM backup and then use the disk to boot and repair disk permissions. This may fix it.
     
  5. Blair230 thread starter macrumors regular

    Joined:
    Feb 17, 2009
    Location:
    Near Philly
    #5
    Thanks to all who replied. I didnt get a chance to post back here. The computer is still not working...tried different backups, and all the Apple Apps Crash. Looking at the crash logs, it notes that there was a problem with webkit file in the frameworks folder. I also restored the entire frameworks folder from TM and still no joy... Tried reinstalling SL from CD and I get Install fail.

    I dont know if my HD is going bad or why it is having trouble reading from the DVD...

    The weird thing is I have a bootcamp partition on the same drive and it runs fine....
     
  6. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #6
    If Windows is working find, that's a pretty strong indication that your hardware is fine. The problem is most likely OS X and something in your backup. Your posts weren't clear but I'd suggest you do a CLEAN install and don't back anything up and then go from there.
     
  7. Blair230 thread starter macrumors regular

    Joined:
    Feb 17, 2009
    Location:
    Near Philly
    #7
    Thanks to everyone who responded. Just to clarify, after trying to restore from my TM backup unsuccessfully (tried 4 different restore dates), I did try 3 times unsuccessfully to do a clean install of SL.

    Turns out the hard drive was bad. brought it in for service, and got a new HD covered under apple care.

    Got the computer back last night, restored from my TM, and works great now.

    Thanks again to all!!:D
     

Share This Page