Recover hard drive, drive appears, no data

Discussion in 'Mac Basics and Help' started by JBeck, Jul 20, 2008.

  1. JBeck macrumors newbie

    Joined:
    Jul 20, 2008
    #1
    I have a crashed ibook G4 that I am attempting to recover files from in target disk mode to my macbook. They are both OSX. The crashed drive appears but no files appear. At the bottom it says 9 GB available. When clicking about this mac it says 37.7 GB hard drive, 9 GB available.
    i've also tried searching the crashed drive in target disk mode.

    How is it that I can't get the files. Clearly they are there as indicated by the GB, but are they corrupted beyond recognition?

    Thank you for any suggestions.

    Jared
     
  2. MisterEd macrumors 6502

    Joined:
    Jan 2, 2006
    #2
    My guess would be that all that space being taken up is from bits and fragments of files, too corrupted to read a whole file from. Sounds like you'd have a struggle to retreive anything from it :(
    Try leaving it there in Finder for a while, see if it can read anything after some time.

    Ed
     
  3. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #3
    I would try DiskWarrior, I have heard good things about it when recovering damaged volumes. Best thing is to leave the drive alone until you get Diskwarrior. Using the drive may only aggravate the situation since the lost data may get overwritten.

    Of course depeding on the importance of the data you should also think about sending the HD to a professional for a recovery before destroying more data.

    Anyway what do you mean with crashed?
     
  4. JBeck thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #4
    Thank you for the posts, in reply:
    When the drive appeared but no files I let it run for over an hour, still no files.
    The data might be corrupted, but the 9 G available was the status quo before the crash.
    By crash, I mean my wife called me at work said the computer's making a funny noise. When I came home it had the grey screen of death with the dreaded "you must restart your computer" in four languages.

    The odd thing is, when you switch on the mac, the log-in screen brings up my user profile but the computer name says "unknown"

    Still entirely a mystery, I can't find any forums on it. Any other guesses?
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    Disk Utility:
    - "Repair Volume"

    Then use Disk Warrior

    Sounds like the HD is failing. Have another HD with enough space available before attempting to do this. If you can see your files, copy all files at once, don't think you can access it again.
     
  6. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #6
    ^ Yup. Even better, get a Firewire external drive NOW. My preference is an 'internal' hard drive plus a case from MacAlly -- this lets you swap the drive in and out of the case as you see fit.

    Plus, get DiskWarrior and optionally DataRescue II (Yes this will cost a couple of hundred bucks. How much is your 30 GB of data worth?)

    Hook the external Firewire up to the machine, boot from your OSX CDs and install a new system on the external. Then boot from the external in order to start your repairs.
     
  7. purpleismyfav macrumors newbie

    Joined:
    Jul 22, 2008
    #7
    so it's kernel panicking. More than likely it's the HD but it could also be something like the RAM and on those machines the RAM is built in to the logic board. That will not allow you to boot into target disk mode if it's the logic board. The noise points to the HD though. Maybe before you spend a lot of money and if you have confidence enough to open your machine (if it's out of warranty) I would open her up extract the HD, but the HD in an enclosure like they guy above said and see if the data can be read then. The removal of an HD on a iBook is a pretty complicated procedure as in you have to remove a bunch of crap to get to it. Good luck

    P.S. if you can boot from the install CD, if you can then it's not the logic board. Do what the guy above said if that's the case.
     

Share This Page