Recover notes from recovery moder on [ex]stock

Discussion in 'Jailbreaks and iOS Hacks' started by uSheep, Jul 24, 2011.

  1. uSheep macrumors newbie

    Joined:
    Feb 21, 2010
    #1
    Okay, it would be very, very awesome if someone could help me with this.
    Like, I would owe it to the community big time.

    Like most joes, I jot down my new jillion-dollar business ideas and inventions on the built in Notes app. Douchebag that I am, I've been on the road the last few months so I skimped on docking/syncing my iPhone, and, given that frickin unwavering law, it suddenly went into recovery mode on its own while charging.

    Of course Itunes will only give me the option to restore it (which I presume will wipe it all clean). What are the ways to get to my notes so I dont lose them forever?

    The phone had never been JBed before it went into Recovery Mode. After googling for a solution I tried FixRecovery, which showed successful at delivering the exploit (GP) but eventually it said 'unable to mount fs' (I know what that means from my novice Linux shell dabbling!) and it went back into RM. I then talked to an iphone repair friend I know for help who said that (a) FixRecovery and these tools only work on RM of JB'd phones not stock ones,and (b) you'd need to know which iOS version I had on the phone (which I don't remember and itunes won't tell me anymore just n/a). It's a 3GS with some iOS 4 update. He says my only option is to restore in iTunes and lose all my data since the last backup (that's if iTunes recognizes it, it doesn't even show me the name or serial or give me the option just restore right now).

    I know you gurus have a way. Is there any sw tool or hack I can give a shot at? I hope he's wrong and there's a simple method. If not, how straightforward is data recovery and does anyone know who can do such a job?

    In theory NAND always retains data in memory which I presume should make it easier for forensics than magnetic, but I don't know if the encryption is a beeyatch. I hope we don't have to go down that road but it's on the table for me if the only option.

    I'm willing to not restore the phone and buy another, keeping this one until the day my notes can be recovered from it if there's that possibility. Really appreciate your advice guys of what you'd do in my shoes.
     
  2. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #2
    Download ifaith.
    And dump shsh blobs .
    This will tell u your firmware and also save shsh blobs ( wiki it)
    We can proceed further after you provide this info :)
     
  3. jjk454ss macrumors 601

    jjk454ss

    Joined:
    Jul 10, 2008
    #3
    I would try iPhone Explorer, I have used it to get stuff off a non JB iPhone before. Never tried Notes, but its worth checking out:

    http://www.macroplant.com/iphoneexplorer/

    When you plug it into iTunes I assume it doesn't do any sort of "Backing Up?"
     
  4. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #4
    If iPhoneExplorer doesn't work, it's also worth checking out PhoneView (on Macs) or TouchCopy (on Windows). Download the free trial, it will at least tell you if you can actually access the phone or not. PhoneView has saved my data more times than I can count. And it sometimes can access things that iPhoneExplorer can't seem to find, even on a stock device.

    And going forward, if you're not going to sync regularly (I don't, iTunes and I have a mutual loathing for one another), don't use the stock Notes app. Get an app that backs up to the cloud in one method or another. Some are free, some cost money, but that money is well spent if one of your jillion dollar business ideas is saved and comes to fruition. I use Notebooks for iPhone (and the companion app Notebooks for iPad)--some of the best money I ever spent was on those two, which not only sync my data to Dropbox or MobileMe, but allow me to actually ORGANIZE it, unlike Notes. I have 10000+ words of a novel typed in Notebooks and another 10000 in backstory for it, along with a few dozen JB notes, research on contractors for an upcoming remodel, notes from seminars, and hundreds of random bits like the best flowers to attract hummingbirds. It's all very easy to find--and I can't imagine trying to do that with Notes! But there's plenty of alternatives out there.
     
  5. uSheep thread starter macrumors newbie

    Joined:
    Feb 21, 2010
    #5
    I've certainly learned my lesson moving forward (or have I, it seems I never learn, I've lost count of the times I lost data due to not having the discipline to back up)! But I'm not ready to give up on this one, I'm hanging in there, I know there's a way through.

    Abs_p: I had a lot of faith in iFaith and I still do, but I'm losing it: While it was exploting with limerain, before any blobs were captured, the following dialog appeared: "UNSUPPORTED DEVICE! ABORTING!" And then iFaith closed. That said, iFath is brand new - this month - and looks very very polished. Could it be possible that it is seeing stock firmware, then accordingly expecting carrier-specific/AT&T code, and failing when it gets surprised with otherwise? Not sure if it makes any difference in this case, but I got my iPhone from an Apple store in a country with unlocked GSM - so those are the update IPSWs Apple would have delivered to me (if they are different in the first place).

    I tried TinyUmbrella as it too has a show/save SSH feature, but shows nothing, there's also a built in Fix Recovery button that basically said code sent, wait to reboot, and the device just stayed in DFU mode as if nothing happened.

    Onto iPhone Explorer... with iTunes open, unplugged and repluged my iPhone but it just doesnt show up in iPhone Explorer. Status is still 'Connect an iOS device'. Touchcopy couldn't see it either. Tried in both recovery and DFU modes. Seems they're not made for phones stuck in the recovery mode loop.

    Correct jjk that iTunes doesn't back anything up (I checked in iTunes preferences and my last backup for it was December). Every time I connect the darned brick I just get the dialog box that itunes detected a phone in recovery mode and i have to restore it - the only ungreyed button. in the itunes summary for the device under iphone I just see Name: iPhone (not the name I gave the device). Capacity, SW Version, and SN are all n/a... BUT under version I see something interesting which is 'Your iPhone software is up to date. iTunes will automatically check again on 28-Jul-11'. I wonder if this means truly I am on the latest ios 4.3 or is this a remnant of an old dialog that isnt necesarily accurate now since the phone isn't signed anymore before restoring.

    What's the Plan B?

    P.S. Vixen, 20,000 words for a novel on an ipad? Let me guess, you either have the BT keyboard accessory, or carpal tunnel syndrome and a whole lot of typos.
     
  6. uSheep thread starter macrumors newbie

    Joined:
    Feb 21, 2010
    #6
    I tried to get a clue on the last installed iOS version from the iTunes logs under Users/AppData/Roaming/Apple Computer/iTunes.

    No IPSWs under the iPhone Updates folder (nor after doing a Recuva scan of deleted files on my magnetic hdd). Only under iPhone Carrier Support folder an IPCC that I initially applied in JUNE 2010 (developed by our local Mac community to allow tethering). Under iPhone Updater Logs I fished out the following line, if meaningful: 2010-11-18 22:26:29.927 [8124:1ce4]: iTunes: Software payload version: 8B117.

    Under iPod Software Updates folder, I have an IPSW and its related sig file: iPod_134.1.0.1 modified 25 Dec 2010. Funny thing is, I don't have an iPod. Could it be that my iPhone is running iOS 4.1.0.1?
     
  7. IrishVixen, Jul 25, 2011
    Last edited: Jul 25, 2011

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #7
    FWIW--The 8B117 suffix IS tied to 4.1 (at least according to Google). Without blobs for 4.1 though, I'm not certain how much good that does you.

    Lord, but I wish Apple didn't make this so difficult!

    I would still think iFaith is probably your best hope. Try emailing the dev? I don't *think* it's a carrier specific tool, but I've not used it myself.

    Also--assuming it's still in Recovery Mode, any friends with Macs? RecBoot is a Mac only tool, and it supposedly works on non JB phones.

    (and I do most of my typing directly on the iPad. It took a while to master, but it's actually easier on my wrists than the BT keyboard, if a bit slower. LOL)
     
  8. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #8
    It is not a carrier specific tool :)
    It basically uses limera1n to fetch shsh from the device itself. I guess you know that already.. You can try contacting the dev ( he is an ass)..
    Or try doing it from another pc... The reason your phone doesn't boot is because phone checks for shsh on every reboot and if it doesnot find it, it won't boot. Limera1m being a bootrom exploit allows you to boot tethered even in absence of shsh blobs but that's useless :-/
     
  9. uSheep thread starter macrumors newbie

    Joined:
    Feb 21, 2010
    #9
    Alrighty, I'll try all these and post ze outcome. Ciao for nao...
     
  10. uSheep thread starter macrumors newbie

    Joined:
    Feb 21, 2010
    #10
    I HAVE BLOBS!

    Sing Halleluljah! An update to iFaith was divinely inspired yesterday, 1.2.1, and this one parted the seas!

    <revision>1.2.1</revision>
    <ios>4.1 (8B117)</ios>
    <model>iPhone 3GS</model>
    <board>n88ap</board>
    <ecid>000003A6361C6DF4</ecid>
    ...

    So what does one do now, having blobs on hand?

    [​IMG]
     
  11. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #11
    Make a signed ipsw using the shsh.
    Put phone In pwned dfu.
    Shift restore
    Done.

    U wil loose everything btw :)
     
  12. uSheep thread starter macrumors newbie

    Joined:
    Feb 21, 2010
    #12
    Now you tell me!

    oh well, then hardcore forensics is my only recourse, stuff along the lines of
    http://www.hackint0sh.org/f159/130617.htm

    i'm going to need a forensics-experienced wingman, which will take a bit of exchanging emails back and forth, doing a Zdiarskical iLiberty+ or similar, and possibly writing a custom IPSW that will keep my NAND data on restore etc, so if there's anyone who's done the research, knows they can get the job done, and willing to walk me through it remotely, I'm willing to pay for their time. They can PM me me here on my macrumors profile... unless anyone knows someone like that and can refer me to their website so I can contact them.

    ThX guys for all the advice you gave, really.
     
  13. ebizowner macrumors newbie

    Joined:
    Aug 18, 2011
    Location:
    Honolulu, HI
    #13

Share This Page