Recovering from not using TRIM

Discussion in 'MacBook Pro' started by Mufasa804, Mar 16, 2016.

  1. Mufasa804 macrumors regular

    Joined:
    Mar 6, 2009
    #1
    Question!

    I've been using my MacBook Pro for about 4 years. I put in 120GB SanDisk SSD that I got for a really good price. Lately it's been EXTREMELY slow (running 10.10.5) and I find it very odd that this has started all of a sudden.

    Then it hit me, was this thing ever running TRIM? No it wasn't. So my question is if an SSD's health can be restored somehow after 4 years of not running with TRIM enabled.
     
  2. CoastalOR, Mar 16, 2016
    Last edited: Mar 16, 2016

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    Enable TRIM First (trimforce)
    Enable TRIM using the terminal command: sudo trimforce enable
    No need to touch kext signing. Only run the terminal command, accept the terms, confirm you want to continue, and then reboot.
    To check that Trim has been enabled check:
    About This Mac
    System Report…
    Hardware
    SATA/SATA Express
    TRIM Support: Yes
    To Disable TRIM: (for future reference if needed, you should normally leave trimforce enabled)
    sudo trimforce disable

    Then TRIM the SSD
    Do a command + s boot to single user mode (command + s) and type "fsck -fy" (without the quotes) at the command line. At the end of the run you will see a message about "all unused blocks TRIMed."

    Now type reboot.

    This will TRIM the free space that got cluttered up while you had TRIM off and should restore your write speeds.

    Edited to clarify steps sequence. Thanks Weaselboy. :)
     
  3. Weaselboy, Mar 16, 2016
    Last edited: Mar 16, 2016

    Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Just to add on to the good advice from CoastalOR, you will want to do that sudo trimforce enable command before you run the fsck -fy command from single user mode. That way TRIM is enabled so fsck can TRIM the unused blocks on the drive.
     
  4. Mufasa804 thread starter macrumors regular

    Joined:
    Mar 6, 2009
    #4
    This is fantastic! I will give this a try. Thank you so much for your input.
     
  5. karsten, Mar 18, 2016
    Last edited: Mar 19, 2016

    karsten macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #5
    what if you run the trimforce enable and it comes back after reboot as still disabled? 10.11.3

    EDIT- got it working. kind of. I got cindori's disk software and tried that but it still didn't work at first. so i disabled the official command and tried cindori's again. still no. opened console and noticed my kernel cache was rebuilding itself every 30 seconds or so! yikes. i had tried to install an old logitech unifying mouse and it never did work but i forgot to uninstall it. also turns out I had hwmonitor installed and it was complaining about missing fakesmc kext so the cache wasnt building properly. removed all of that, rebuilt the cache and tried cindori's app again and now it's working.
     

Share This Page