Recurring invalid volume file/directory/free block count

Discussion in 'macOS' started by spandmand, Oct 24, 2011.

  1. spandmand macrumors newbie

    Oct 24, 2011
    Been struggling with my new HD that I installed a few days ago - after installing the drive I used a clean install and migration assistant. Really hope someone can help with this!

    The problem is that when I verify the drive in disc utility, it gives me the following feedback with minor variations:

    Checking volume information.
    Invalid volume file count
    (It should be 693445 instead of 693120)
    Invalid volume directory count
    (It should be 146379 instead of 146186)
    Invalid volume free block count
    (It should be 54214500 instead of 54225168)
    Volume header needs minor repair
    The volume McMac was found corrupt and needs to be repaired.
    Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk."

    I have already tried repairing with disc util from the recovery HD and I have also tried to fix it with DiskWarrior running from an installation on an external HD. When I run these repair tools, they all report that the problem is fixed. And when I boot back into OS X, the disc until usually reports back with no errors initially. But if I use my mac for some time and then run another scan, the error is there again.

    Maybe I need a new drive, but what strikes me is that everything seems to be running just fine, and I tried to scan for bad blocks with DriveGenius - nothing indicated any errors..

    Any ideas?
  2. maflynn Moderator


    Staff Member

    May 3, 2009
    If a new drive that I just bought started exhibiting those symptoms, I'd return it, as there's something wrong.
  3. wnorris macrumors member


    Feb 16, 2008
    I am seeing a similar problem. I am using a 240GB OWC SSD and am seeing the need to do a Disk Repair every few weeks.

    This was not an issue until installing Lion.
  4. zillion42 macrumors newbie

    Oct 30, 2011
    Same issue here... drives me nuts... any news on the subject...
  5. spandmand thread starter macrumors newbie

    Oct 24, 2011
    My drive seems fine now.
    I made a full Time Machine backup, formatted the drive and installed Lion from scratch. This time I did not use migration assistant or time machine - instead I just pulled my iTunes library, documents etc. from my Time Machine backup with finder and reinstalled all my programs manually. I did all this yesterday, and haven't been able to reproduce the error since.
    I will report if the error occurs again, but it seems to me that the error is caused when migrating to a new type of drive with migration assistant or time machine.
  6. rafarc21 macrumors newbie

    Jan 19, 2012
    Same problem!

    I'm having the same problem for about a month now I've having frequent random freezes, visiting mac installation disc more than I wanted to. And of course repairing disk permissions dosent seem to help much. I will try Disk Warrior now and come back to post answer. Waiting on yours too. Did installing lion from scratch solved the problem?

  7. Damo01 macrumors regular

    Feb 11, 2010
    They're probably bad blocks on the Hard Drive that need to be zeroed out by using the erase option.
  8. jesmith09 macrumors newbie

    Feb 3, 2012
    Don't worry about it

    This is an older post from Apple Support, but it applies to newer version of OS X as well for the same reasons:

    You can safely ignore some errors that fsck reports when journaling is enabled.

    Note: This document applies to Mac OS X 10.3.9 or earlier.

    Below is a list of errors that fsck reports that you can safely ignore when using journaling:

    "Volume bitmap needs minor repair"

    "Invalid volume free block count"
    Note: The volume free block count is a type of cache of the real information stored in the volume bitmap, and the count being off does not mean your volume is damaged in any way. An incorrect volume block count message (block count changed from X to Y) is an example of this type of message.

    "Volume header needs minor repair"

    "can't locate IOPlatformMonitor"

    "Incorrect block count for file"
    Note: In the case of this message, you can erase the file and restore from the most recent backup if needed.
    Each of the messages above is benign, and indicates no damage to the file system. You may safely ignore them.

    Additional Information
    With a journaled volume you do not need to start up into single user mode. When a volume is made available to the file system, the journal is replayed and the file system brought up to a consistent state. If you do run fsck, it is best if you use -n and -f flags so that it will not actually modify the volume. Options explanation from fsck man page (short for manual page):

    -n Assume a no response to all questions asked by fsck except for 'CONTINUE?', which is assumed to be affirmative; do not open the file system for writing.

    -f Force the check.
  9. melgaard macrumors newbie

    Feb 24, 2012
    Albuquerque, NM
    Remove rEFIt

    I was experiencing the same HDD problems as those stated previously.

    As the previous post suggested, some of the issues can be ignored, however in my case, whenever I restarted my computer it would hang up on the gray apple screen and the cooling fans would run on high. I would have to hard reboot in order for the computer to work again.

    The solution to my HDD issues was to remove rEFIt.

    (YouTube link for procedure, or follow the instructions below.)

    1. Double click "My Hardrive" and find the "efi" folder. Drag that folder to the trash.

    2. Again under "My hardrive" go "library" then "startupitems" and drag "rEFItblesser" to the trash. (if your library folder is hidden, Google how to unhide it.)

    3. empty the trash

    4. restart

    When restarting, I rebooted in recovery mode (by holding the alt/option key) and repaired the HDD with disk utility. So far, I have no issues with restarting and my HDD comes up clean when verifying with disk utility.

    Hope this helps.
  10. opw macrumors newbie

    Mar 29, 2012
    It sure did. I spent all day trying to figure it out, until I removed rEFIt...

    Glad I did not replace the hard drive....:)

  11. zakee00 macrumors regular


    Jul 7, 2004
    Anchorage, Alaska
    Reviving this dead thread.

    I got the rMBP in my sig a few months ago (with 512GB SSD) and I've had the 'Incorrect Block Count' error occur twice. Each time I've booted into 10.8 Recovery to attempt repair with Disk Utility, and each time the repair has failed and resulted in a corrupt partition, which I have to restore with a Time Machine backup. I'm typing this on my Boot Camp partition which is still working fine. When I try to boot into Mountain Lion, the computer hangs on bootup and shuts down automatically.

    This post suggests that the error is benign (the incorrect block count was limited to a single file) and that I should not worry, but it bugs me that this brand new machine is having errors like this. Is it possible for SSDs to have bad sectors like an old platter disk? Should I bring it up with a Genius or just follow the above post and not worry about it?

    Thanks in advance :)
  12. Quad5Ny, Jan 20, 2013
    Last edited: Jan 20, 2013

    Quad5Ny macrumors 6502a


    Sep 13, 2009
    New York, USA

    SSD's NAND cells die as part of normal operation, but it should be hidden from the user. When a cell can't be read or written reliably the drive controller marks it as bad and replaces it with one from the reserve (it's actually more complicated than that, but you get the idea). The operating system should NEVER see a bad "sector".

    Try doing a Secure Erase and then Install a fresh copy of Mountain Lion. Run the copy of Mountain Lion for a week, do what you usually do but DO NOT restore the Time Machine backup (remember your testing to see if the hardware is OK).

    If your still having data corruption with a clean copy of OS X have Apple replace the SSD, you paid $900 for it and it should work perfectly. Also FYI all the SSD's in my Mac's never show any errors in Disk Utility.
  13. kevink2 macrumors 65816

    Nov 2, 2008
    I was having some of these same issues. It was always a deleted file in dropbox, run by quicken, under crossover. Weird. On my Mac Pro, never saw these issues.

    One difference between the Mac Pro and my MBP is on the MBP I was running under Filevault2 also.

    Or at least I was until mid week, when I couldn't even find my startup partition, even after Repair Disk from Internet Recovery/Disk Utility.

    My data was still all there, and I backed it up using Target Mode on my Mac Pro, though backing up the data there I saw some HFS sibling errors. In a file I didn't care about.

    So I restored from Time Machine, copied the extra 3 days worth of changes I backed up on the Mac Pro. No encryption for now.

    It had been 8 months since my startup volume vanished unexpectedly. I knew more about troubleshooting this time so I didn't do a clean install this time (I also had a time machine backup after the trouble last year).

    When it vanished then, I was running the original HDD. This time, I was running a SSD. So I don't blame the drives in either case.
  14. matthieuv macrumors newbie

    Feb 20, 2017
    Hi, I had similar problems on my retina MacBook Pro (late 2013) : error 8 in disk utility with folders, files and free space mismatch. After a repair from the recovery partition, OS X was definitely corrupt and I had to reformat and reinstall everything.

    After some testing, it appears that this error is caused by Paragon HFS+ : I've installed Windows 10 in UEFI mode to play some games, installed directly on the Mac partition (keeping the Windows partition as small as possible). Disk utility was green until the first file suppression from Windows, then the error 8 was back again.

    I don't know if this error can be ignored or if the partition might be at risk but I'm surprised that not that many people are talking about this issue
  15. bsindia macrumors newbie

    Feb 23, 2017

    Here is what I would do. Boot to single user mode. type in fscy -fy and hit enter. That should fix your disk issues

Share This Page