Recurring problem with iBook G4

Discussion in 'PowerPC Macs' started by Dunstable, Jul 31, 2007.

  1. Dunstable macrumors newbie

    Jul 31, 2007
    Great and noble Mac users,

    My iBook G4 seems determined to drive me crazy. I inherited it from my girlfriend when she upgraded to a MacBook. I think she bought it new in 2005. It seems to have worked fine until recently.

    The problem started innocuously: Firefox would freeze with the little rainbow icon spinning, and nothing happening. I quit the application and tried again; it did the same thing. Then ITunes started freezing, too. Irritating, but not huge. The next day, however, I turned it on, and got only the Apple logo - no 'spinning gears' underneath. I restarted; no improvement. I restarted again; this time, the spinning gears came up, but it didn't progress from there. Upon subsequent attempts (resetting PRAM, PMU, etc.), something seemed to be making a slight grinding sound: audible, but just barely so.

    I threw myself at the mercy of my friend, a long-time Mac user and One Who Knows About These Things. We put all my files on his external hard drive and tried repairing mine; Disk Utility wouldn't do it. It seemed that a new hard drive was in order. Oh well, my old one was small, anyway...

    So, last night, we put in a new hard drive, installed OS X Tiger (which is what I was using beforehand), and put the files back on. Everything seemed fine. However, this morning, as I was trying to reorganise my files, it wouldn't move files into folders. Alright, I thought: quick restart, that'll be fine. Of course, it wasn't: the Apple and the 'spinning gears' came up, and stayed there indefinitely. Then, after I tried to restart in Safe Mode, it came up with the flashing disc icon and a ? I've tried all the usual things again (PRAM, PMU). Nothing helps.

    Any suggestions? I know there are logic board problems with this model, but it booted fine in Tiger from my friend's external drive. He suggested that it might be a problem with the connections to the hard drive - possibly a defunct cable?

    Any advice would be incredibly gratefully received!

  2. A Cute Baby Lam macrumors newbie

    Jul 27, 2007
    If you have already replaced the drive and it boots fine from an external drive (can you run for an extended time with the external drive?) I would say it is either the cable, or the disk controller on the board. I do not know how you would go about fixing either of those other than to take them in to an Apple service center, but maybe the One who Knows might know.

    But if you are looking to replace yours, I have a g4 iBook I am looking to get rid of.... :D
  3. Dunstable thread starter macrumors newbie

    Jul 31, 2007
    Tempting! But, since I've replaced the hard drive, etc., I'd prefer to fix mine!

    So, I replaced the hard drive cable in the hope that that might work. It didn't. Again, it worked for a little while, and then stopped. Now it only shows a grey-ish/blue screen. I managed to boot it in single user mode and run fsck -fy, but it couldn't repair the disk. Should i just give up?
  4. Reflow macrumors 68000


    Mar 30, 2005
    Are you sure that the HDD is not the cause of your problems. Do you have another one you can test with?
  5. Dunstable thread starter macrumors newbie

    Jul 31, 2007
    I had the same problems with both the original hard drive and the one I bought to replace it. Unless I bought a faulty one, I'm guessing it's not a problem with the hard drive itself. Thanks for the suggestion, though.

Share This Page