RED Light coming from headphone jack.

Discussion in 'MacBook Pro' started by vong, Jun 1, 2014.

  1. vong macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #1
    Recently my macbook pro (2010) speaker sound stopped working and I am cannot adjust the volume. When I plug in headphones the sound works and I'm able to adjust the volume etc etc. However, when I unplug the headphones the headphone jack has a red light coming out. I tried googling the issue and the solution was said try resetting the PVRAM or something (CMD+OPTION+P+R when rebooting). I get the "DOOOOOOOM" sound when first booting up a Mac. But after logging in the speakers does not work at all.

    I went to Apple the other day and they said its an issue with the logicboard and would cost $280 to send my macbook to their repair shop to get it fixed. When I got home, there was an update for iTunes. I updated my iTunes and somehow my speakers were working, but after a few hours, just the speakers/volume went out again... So I guess, my question is, is it replacing my logicboard the only option I have to fixing this issue? Thanks!
     
  2. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #2
    The headphone jack is actually a combo port. It has analog audio, which is what headphones use. The red light is when it is using optical, which is what high-end sound systems use. The port is broken and thinks that an optical plug has been inserted.
     
  3. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #3
    You could try somebody who does board repairs. That part is also known as a SPDIF socket. If it is only that which is faulty it may be a much cheaper repair.


    Barney
     
  4. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #4
    I'm sure you've already checked this but...

    What output device is set under the sound preferences? It should be "external speakers". If it is set to "digital output" you will see the red light coming from the headphone port and there will be no sound (unless it is plugged into a digital receiver).

    Hope this helps...
     
  5. Fishrrman, Jun 2, 2014
    Last edited: Jun 2, 2014

    Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #5
    There's a "mini-switch" (mechanical) inside the audio out port that is supposed to be able to detect whether a "regular" (analog) stereo headphone plug has been inserted, or a digital-type plug (that "reads" the beam of light.

    I can't say for sure, but I believe the "normal" position of this switch is for analog audio. The digital plug is shaped differently and may be a little longer, so when one is inserted into the jack, the mechanical switch senses this and switches the output over to digital.

    I'm going to -guess- that somehow your mini-switch got moved into the "digital" position, and it is stuck there, and won't "disengage" back to the analog audio position.

    With this information, you should search the web for reports of what other MacBook users have done to disengage the switch.

    I cannot confirm this, but perhaps inserting and then removing a digital-type plug a few times might do the trick. Or perhaps using a toothpick, etc. But again, I've never had the problem on my own MacBook, so I can't offer this advice with the experience of having done it myself.

    You might try taking it back to an Apple store, and explaining that the switch is stuck in the digital position. See what they have to say.

    I -don't- believe this requires a logic board replacement!

    EDIT:
    While browsing some posts here on MR relating to the "red light" issue, I discovered one that said to go to the Flash pane in System preferences, click "advanced", and delete everything there. I have no idea as to whether this will work or not.

    Some other posts -seem to- suggest a "driver issue", and that a re-installation of the OS -might- solve the problem. Sounds implausible, but you never know. I had a case where my firewire port stopped working on the MacBook Pro. Took it in while still under warranty and they replaced the logic board and it worked again for a while, then quit a second time. Now out-of-warranty, I left it alone. Then installed 10.8 one day, and suddenly, the firewire port "came alive" again. So, software -might- have something to do with it...
     
  6. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #6
    Optical isn't exclusive to high end sound systems.
     
  7. Orr macrumors 6502

    Orr

    Joined:
    Oct 8, 2013
  8. ammusk macrumors regular

    Joined:
    Oct 20, 2009
    #8
    I have the same problem with my MBP 2010 17"

    Whenever I use my Klipsch earphones, the headphone port works fine. Internal speakers also work fine after disconnecting.

    However, although my Sony Headphones work fine when connected to the MBP, the internal speakers of the MBP do not work and the red light appears in the headphone port (after the sony headphones are disconnected).

    This happens most of the time but not always.

    When the headphone port is red, connecting any earphone (including the sony) works fine, however the internal speakers never work when the earphone is disconnected.

    A PRAM reset fixes this problem. Be sure to connect an earphone which does not cause this problem (Apple earphone eg.) before doing the PRAM reset. Otherwise it might not help.

    I force the PRAM reset atleast three times before I allow Mac to boot. Just keep holding the PRAM reset keys until you hear the startup "DOOOM" a few times.

    And yes, when the headphone port is glitched, I'm unable to change the volume on the MBP. It remains grey out.
     
  9. vong thread starter macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #9
    Thank you everyone for your replies!

    I tried what you suggested, I am still not able to adjust my volume. I really did not want to replace my logic-board but it seems like that is the only route available..
     
  10. teefar macrumors newbie

    Joined:
    Jul 6, 2010
    #10
    I know I'm late as hell here, but all they were gonna you was $280 for this? Is that for the logic board?

     
  11. vong thread starter macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #11
    Yeah to get the sound working again.
     
  12. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #12
    Well, in case anyone encounters this issue and is looking for a digital plug, you can consider these:
    Toslink to 3.5mm Mini Optical

    I'm using this to output from my rMBP to amp when watching movies. (old amp, no HDMI connections)
     
  13. Hexo macrumors newbie

    Hexo

    Joined:
    Aug 24, 2015
    #13
    Hi OP
    Same thing happened to me as well, here's how I fixed it:

    I took a thin stick (for the teeth) and messed around in the headphone port for like 10sec, and it worked again.
    has been working like a charm for over a year now. I got that solution from an online forum, so I'm sharing it with you as well!
     

Share This Page