Red light in audio jack, no sound! Help!

Discussion in 'MacBook' started by polar-blair, Oct 2, 2008.

  1. polar-blair macrumors regular

    Apr 20, 2008

    My mums macbook has gone crazy! There is no sound coming from the macbook, and when I went to check if the volume was up the volume box popped up as usual but with a symbol, similar to a no entry sign. Circle with a cross through it. Then I saw a bright red light from within the audio jack itself. When I plugged in ear phones it works fine but the built in speakers are not working.

    Please can someone HELP.
  2. HiFiGuy528 macrumors 68000

    Jul 24, 2008
    the red light may be from the optical output. Have you tried the Mute button?
  3. mgpg89 macrumors 6502a


    Aug 31, 2008
  4. techound1 macrumors 68000


    Mar 3, 2006
    After I threw mine off a bridge I didn't have any more problems with it. Huh.

    Okay, seriously, take a screen shot of that icon and post it. The mute shouldn't have the forbidden symbol as part of it.
  5. iWaldo macrumors member

    Sep 6, 2008
    It sounds like it is jammed in optical audio out mode.

    There's a microswitch that turns the port on and off. Looking into the port, the switch is a small metal thing near the back of the port, on the right side. Take a toothpick or some similar object and poke at the switch until it unsticks and the light goes off.
  6. iWaldo macrumors member

    Sep 6, 2008
    I just successfully diplicated the problem on my MB, by jamming the audio port switch on with a toothpick. The red light came on, and there was indeed a forbidden symbol below the volume bar (I guess it knows there isn't actually anything plugged in, somehow.)
  7. polar-blair thread starter macrumors regular

    Apr 20, 2008
    Hi here are the screen shot of the forbidden volume symbol

    Click for full size - Uploaded with plasq's Skitch

    Volume full:

    Click for full size - Uploaded with plasq's Skitch

    Weird, it just started happening tonight, completely out of the blue. I tried switching it off and on, but no change, I have gone into preferences; sound to try and see if any thing appears there but I cant see anything.
  8. polar-blair thread starter macrumors regular

    Apr 20, 2008
    thanks for the help, took me a long time to get the screen shots working so I didn't see the answers, off to find a tooth pick, thanks guys!
  9. Kebabselector macrumors 68030


    May 25, 2007
    Birmingham, UK
    It does work, I replicated the fault and fixed it for someone!
  10. mgpg89 macrumors 6502a


    Aug 31, 2008
    I'm not kidding, that really worked.
    Just stick a screwdriver/toothpick/whatever in there (whatever fits in real deep) and fiddle around with it until the red LED goes off.
    Then it should work again.
  11. rogers106 macrumors member

    Sep 8, 2008
    This has become somewhat of a major issue for me...

    Everytime I plug in headphones (I have a pair of Bose, and sometimes also just use iPod earbuds), the red light comes back.

    I fiddle around with it, and the red light stops.

    ...and then it comes back again as soon as I plug anything in.

    Is this a bigger issue?

    Should I have the AS take a look at it?

    The reason I ask is that I'm from CT, but I go to school in VT. There are no Apple Stores in VT, but I'll be home for the weekend in a few weeks... is this something they could repair between a Friday drop-off and Sunday pickup?

    I would imagine that if it were JUST the audio jack, it'd be pretty simple whereas a logic board replacement would take longer.

    Anyone go through this?
  12. rat1780 macrumors newbie

    Oct 14, 2008

    Here, try taking a look at this. It may fix the problem by inserting something in the jack but it could cause more damage to the sensor. Also, if you bend those little fragile metal clips inside too much, the audio may not work or cut in and out due to being too loose.

    Sticking metal bobby pins in the jack just can't be good for the electronics.
    and a toothpick will splinter causing more problems from the debris.
    If you do this, use a plastic toothpick or something like it.

    I just wanted to caution users in this practice. Be Careful! Otherwise you could have a bigger repair bill on your hands!
  13. dhc macrumors regular

    Jan 10, 2006

    Suffered precisely this problem. The audio jack is attached to the motherboard, which requires replacing for a permanent fix. Took mine into an Apple store and it was fixed the same day.
  14. rogers106 macrumors member

    Sep 8, 2008
  15. rat1780 macrumors newbie

    Oct 14, 2008
    Ok, so i retract my last post. I've been looking all over for a solution and one user described how he and I fixed it.
    This is what he posted:
    You have the same problem as myself. I've managed to temporarily restart internal speakers by inserting a needle in the socket and short circuit the pins (without pushing on them!!).

    The short version is like this (from my experiments today):

    1. nothing inserted: one of both pins of the socket are grounded and internal speakers are activated
    2. something inserted: if impedance present on pins, means headphones/line-out
    3. something inserted: if no impedance is on pins means optical (afaik toslink is made on plastic, right?)

    Maybe somebody should confirm these ideas.

    Bottom line, you have to replace Left I/O board or try to push and pull a jack in the socket, maybe the bent pin(s) will come to normal position again.

  16. rat1780 macrumors newbie

    Oct 14, 2008
    - Ok this is how I fixed it...

    I don't believe it is a physical switch. I think by "shorting" the two pins together it switches it in the software.
    I used a small jewelers screwdriver and touched it to two of the pins.

    If you set the mac on the edge of the table and look into the illuminated hole, you will see 4 metal clips or pins inside. one at 9:00 <-- one at 12:00 ^ and two at 3:00 --> These two at 3:00 are the two needed to "short out" touch a metal object (needle, small screwdriver, or paperclip) to these two contacts. You will see the optical light blink trying to read if there is an optical connector inserted.
    For me, at this step, I had to try a couple of times before it reset.

    I hope this helps other people, and good luck!
  17. Chase817 macrumors member


    Jul 6, 2008
    i used tons of objects, but the back end of a plastic paintbrush fixed it for me
  18. chrisitude macrumors newbie

    Jun 6, 2007
    this really works!!

    sounds like the strangest thing on this planet to do with the mac but it worked!!! thanks for the post guys and the solution!
  19. kelseyb90 macrumors newbie

    Apr 21, 2010
    As weird as it sounds....

    As weird as it sounds I used a thermometer. its about the same size as headphone plug so i put it in and jiggled it gently and the light went off...wah la! sound. I assume the difference is that it does not make the right amount of contact as the plug so it causes the switches to reset.

    Hope this helps! :D
  20. tooz macrumors 6502

    Jul 21, 2009
    Considering it's been nearly 2 years since the incident, I'm sure the OP has fixed it :rolleyes:
  21. Appletekk macrumors newbie

    Feb 9, 2013
    My fix to red light problem...

    I tried poking around in the audio jack with all kinds of items with no change. Then I used a pressurized can of contact cleaner and "presto" no more light. My internal speakers worked, my headphones worked, and when I removed the headphones the internal speakers worked again. Take note though, the spray back of the contact cleaner is instant...beware getting that stuff in the eyes.
  22. widerstand macrumors newbie

    Feb 6, 2013
    Budapest, Hungary
    how to clean properly

    don't jam things into the port, it just causes more damage! it bends the inner contacts.
    switch computer off, take out the battery.
    blow out the hole with compressed air.
    pick up anything with a 3.5 jack - headphone, extension cable...
    put some contact cleaner on jack head(just make it a bit damp, don't soak it)
    plug in and out several times, then wipe off the leftover liquid from the plug with a paper towel.
    repeat steps above 3-5 times.
    then, with a compressor blow in the hole, make it dry. it also removes the dust that was weakened by the plug.
    it always worked for me.
  23. Brian Y macrumors 68040

    Oct 21, 2012
    To give an idea of why this happens - the microswitch detects the presence of a metallic/non-metalic object.

    If a piece of dust, or plastic, blocks the switch, it will detect a non metallic object, and switch to optical mode. When you put your headphones in, it detects a metal object, and switches back to regular mode.

    Best way to fix it is to give it a wiggle with a small screwdriver (to loosen the crap that's blocking it) and then use a can of compressed air to remove it. If you don't have compressed air, the inside of a biro and some double-sided tape will do it (just make sure you git rid of some of the sticky on the outside first!).
  24. dondavanzo macrumors newbie

    Oct 19, 2014

Share This Page