Red light in headphone jack - No sound!

Discussion in 'MacBook Pro' started by smoking monkey, Jun 18, 2012.

  1. smoking monkey macrumors 65816

    smoking monkey

    Joined:
    Mar 5, 2008
    Location:
    You Only Live Twice
    #1
    I've read through other posts on this topic as I've had this problem before, but I've always been able to fix it by inserting my headphones, wiggling them in the jack and then taking out the headphones.

    The digital sound out has been turned on and doesn't allow the internal speakers to broadcast sound. A total PITA.

    This time I've tried the matchstick, the headphones, repairing permissions, resetting the PMC... Anything I can think of that might help to reset this problem.

    Is there anything else I can try before I send my computer back to Apple. I have a 2009 July Macbook Pro 17". I use the computer every weekday for work so it will be a real problem if I need to send it in for fixing. Although Applecare in Japan is awesome and usually get your computer back to you within 48hours.

    Thanks for any ideas.

    And just to pile up the problems my router decided to kick the bucket this very afternoon. Luckily I got mobile wifi as well (for the work computer)... Hopefully the 3rd problem won't be a biggie.
     
  2. jshephe2 macrumors newbie

    Joined:
    Jun 26, 2011
    #2
    Unfortunately I had the same issue on my MBP13 and was able to fix it a few times with a matchstick but then that didn't work and they had to replace the logic board. They did get it back within 48 hours but two without my MBP!?!?!?! I survived though. Good luck
     
  3. Pagga macrumors 6502

    Pagga

    Joined:
    Feb 21, 2009
    Location:
    Closer to the Artic circle than I like to be
    #3
    This is a "normal" issue.

    My advice is to gently insert and pull out the headphone plug, lightly bobbing it from side to side.

    If done with the right mix of care and persistence, it will solve the issue.

    Unfortunately, once the problem is there, it will occur again ...

    good luck,
    P
     
  4. Leroyzworld macrumors newbie

    Joined:
    Jun 24, 2012
    Location:
    Trenton, Ontario, Canada
    #4
    Try System Preferences>Flash>Advanced tab>Delete All...

    My wife's 2011 mbp had the same problem:
    no sound from speakers,
    sound okay in headphones,
    red light on in jack,
    slow computer.

    She plays MANY different FLASH online games in Firefox. I searched everywhere and found the same advice as you all did ref toothpick in headphone jack, etc. Nothing worked.

    Today, I googled "firefox" "problem" and "sound". I found "Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems". I stopped reading at this point and decided to check out the status of her Flash settings. I opened System Preferences > Flash and explored the different tabs and options on my mbp compared to hers and noticed a LOT more "websites" in her Storage and Camera & Mic tabs. I went to her Advanced tab and selected Delete All... . It took over a minute to clear all her "websites". I did a reboot and was shocked, surprised, relieved that her mbp speakers were spewing sounds again! Problem solved! Her computer is now faster as well.

    Short story:
    System Preferences>Flash>Advanced tab>Delete All...
    Hope it works for you, too.
     

Share This Page