Redirecting to asian google using latest Safari update

Discussion in 'MacBook Pro' started by lornemac, Jul 3, 2011.

  1. lornemac macrumors newbie

    Joined:
    Jul 3, 2011
    #1
    Dear all

    I use Safari on a 1 year old Macbook pro 17". I have recently been getting random asian pages come up whilst still showing a UK web address in the browser. (as per attached screen shot)

    Anyone got an explanation for this and whether I should be worried:confused:?

    Best regards

    Lorne
     

    Attached Files:

  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
  3. lornemac thread starter macrumors newbie

    Joined:
    Jul 3, 2011
    #3
    Dns erm...

    I wouldn't know how to check this.
     
  4. palpatine macrumors 68040

    Joined:
    May 3, 2011
    #5
    The text is in simplified Chinese, so it is run by some kind of mainland China entity, but the site does not seem correct to me for two reasons.

    First, when I use Google in Chinese, it looks just like any other Google homepage, except with Chinese characters. The address usually looks like this:
    http://www.google.com/webhp?hl=zh-CN

    Second, assuming you are in the UK, you should not be getting any Asian pages as a default. I am in Asia at the moment, and when I go to the UK site from here, my Google page is in Japanese, because it is detecting that as my location according to my ISP address (I assume). I just click on the English page button on the bottom to get the regular UK version.

    I wish I had an answer for you. I would start by clearing all of your cookies and so forth (I do this daily). Or, try going there with a different browser (I use chrome). See if that has any effect.
     
  5. DropKick macrumors member

    Joined:
    Feb 19, 2008
    #6
    What does the source code say?

    something like Menu bar -> View -> View Source

    take a screenshot and post it back here. It doesn't look good though.
     
  6. Whorehay macrumors 6502a

    Whorehay

    Joined:
    Feb 17, 2008
    #7
    Check your router settings as well. If you still have the default "admin/password" combo to get into your router settings, a malicious website could easily change the DNS settings to get something similar to what you're seeing.
     

Share This Page