redsn0w 0.9.2

Discussion in 'Jailbreaks and iOS Hacks' started by pasipple, Feb 2, 2010.

  1. pasipple macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #1
    I have a 3gs w/ 3.1.2 (Pwnage Tool) and a 4.26.08 BB....

    I'm interested in changing my boot logo with redsn0w 0.9.2 and I understand that I can do this no matter what "means" I used to JB. Ref: http://wikee.iphwn.org/howto:rs9

    Anyway, when I start redsn0w I'm asked to "select the corresponding IPSW for your current firmware". But when I browse and select my IPSW created during my upgrade to 3.1.2 w/ Pwnage I get the error "unable to recognize specified IPSW".

    Anyone know why this is?

    Thanks....
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    You need to point it to the official, unpwned firmware downloaded from Apple.
     
  3. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
  4. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #4
    No problem. In case you're interested, the reason it needs the original is that is uses it as a source of Apple code to patch before uploading to your phone. It is not illegal for you to patch a copy of the Apple firmware you have legally downloaded, but it would be illegal for the Dev Team to distribute that code already patched.
     
  5. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #5
    So using the 7D11 Apple IPSW...when I booted up redsn0w the program stated that I had a late model 3G and that I couldn't have a custom logo!

    Bummer!

    I don't quite understand this...my serial number shows I have a week 23 iphone?
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    Redsn0w doesn't tell you that you have a late model, it asks you if you have a late model. You must have accidentally clicked the wrong option. Try again, this time reading carefully.
     
  7. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #7
    Thanks for the reply...

    It appears to tell me that my device requires a tethered JB?

    After browsing to the Apple IPSW a warning dialog box comes up telling me that I have a tethered device. "Your device requires tethered reboots after being jailbroken"...."Tethered devices can not yet have custom logos".

    If I hit "OK" to close the warning dialog box...I'm given the option to continue by selecting "next". After redsn0w compiles some info...I only get two options.

    "Install Cydia" or "Just boot tethered right now"? I do not get options for verbose boot or custom boot logo or custom recovery logo?

    Am I still missing something?

    Thanks...
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    Immediately after redsn0w verifies your firmware, you should be presented with the following window:

    [​IMG]

    You should choose NO. You will then be presented with a much larger list of options, including the option to change your boot logo and enable verbose boot mode.
     
  9. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #9
    Nope....I get the warning dialog box that I described.

    I'd like to show you the specific dialog box I get but I don't know how to do a screenshot of dialog box?
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #10
    Application>Utilities>Grab
     
  11. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
  12. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #12
    Or command+shift+3 takes a screenshot (much easier)
     
  13. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
  14. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #14
    The serial number on my 3Gs is 86923xxxxxx....

    ??????
     
  15. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #15
    But then you have to crop it... And since he had no clue, I thought a GUI tool might be better.

    pasipple: I don't know what to tell you. When I run redsn0w 0.9.2 on my Mac using the firmware iPhone2,1_3.1.2_7D11_Restore.ipsw I do not get the message you get at all. I would suggest maybe re-downloading the firmware file and redsn0w, and if that doesn't work getting in touch with MuscleNerd or CPICH on IRC.
     
  16. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #16
    So...any thoughts on why I'm getting this dialog box with a week 23 3GS?

    [​IMG]
     
  17. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #17
    Sorry. I edited my other post just before you posted.

    I don't know what to tell you. When I run redsn0w 0.9.2 on my Mac using the firmware iPhone2,1_3.1.2_7D11_Restore.ipsw I do not get the message you get at all. I would suggest re-downloading the firmware file and redsn0w 0.9.2, and trying again. If that doesn't work getting in touch with MuscleNerd or CPICH on IRC.
     
  18. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #18
    OK...thanks for all the help.

    Just wanted to make sure I wasn't doing something wrong!

    I'll download the Apple IPSW and redsn0W again...and see if that works....
     
  19. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #19
    Restart the computer, make sure and run Redsn0w from the desktop.

    Make sure iTunes and iTunes Helper are closed.
     
  20. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #20
    Alright...I've got to come clean here!

    I had the wrong IPSW. I errantly downloaded....

    ipod3,1_3.1.2_7D11_Restore.ipsw

    instead of...

    iphone2,1_3.1.2_7D11_Restore.ipsw

    Damn this is embarrassing!

    I'm downloading the correct IPSW and I'm guessing this was the problem.

    Thanks for all the help...
     
  21. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #21
    Yes, that was the problem. The iPT3 is not capable of an untethered jailbreak. Glad you figured it out! And if it makes you feel better I once tried to restore with iPhone1,2_3.1.2_7D11_Restore.ipsw instead of iPhone2,1. In my defense, though, mine was much closer than yours. ;-)
     
  22. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #22
    Good news....for me at least....

    Using the correct IPSW did the trick! Duhhhhh...

    Now I need to find some cool boot logos...

    Thanks thelatinist & dhlizard!!!
     
  23. pasipple thread starter macrumors 6502a

    pasipple

    Joined:
    Jun 12, 2009
    #23
    iPod..iPhone? Close enough!!!

    :D
     
  24. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #24
    Well, if you say so :eek:

    Glad you got it done.
     
  25. fsck-y dingo macrumors 65816

    fsck-y dingo

    Joined:
    Jun 14, 2009
    #25
    Both will work great and are helpful. The way I'd do that is to use command+shift+4. That way you can select what you want in the screen shot.
     

Share This Page