Redsn0w cannot recognise ipsw?

Discussion in 'Jailbreaks and iOS Hacks' started by SuperHackerSW, Jul 28, 2010.

  1. SuperHackerSW macrumors newbie

    Joined:
    Jul 28, 2010
    #1
    So yeah, I have 2 versions of IOS 4 but redsn0w 0.95b5-5 can't recognise either of them. Its very annoying, im all ready to go, i have a 3G with IOS 4.01 and Im really looking forward to JB it, but this annoying issue keeps getting in the way. no version of redsn0w or IOS is recognised by any version of each other. what can I do to get redsn0w to recognise the IOS 4 that I have? :confused:
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Maybe download again everything or use another computer.
    Make sure u point redsnow to 4.0 and not
    4.0.1
     
  3. neenja macrumors 6502

    Joined:
    Jul 17, 2008
    #3
    make sure also that you have the correct ipsw.

    4.0.0 (3G): iPhone1,2_4.0_8A293_Restore.ipsw
    4.0.1 (3G): iPhone1,2_4.0.1_8A306_Restore.ipsw

    Those are the correct file names for the iphone 3g 4.0 and 4.01 ipsw files. And yes, if your iphone 3g is currently on 4.01, make sure you point redsnow to the 4.0 file. It will work
     
  4. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #4
    It is definately 100% the correct files, tried downloading everything 3-5 times, and tried my Windows XP laptop instead of this one. Nothings working :(
     
  5. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #5
    As AppleJuiced pointed out, when you are using redsn0w 0.95b5-5, you must point to the 4.0 ipsw (not the 4.0.1 ipsw), even if you have 4.0.1 installed on your phone. This is because redsn0w has not been updated to recognize the 4.0.1 ipsw. This is not a problem because so little has changed between the two firmwares that use of the old firmware will not affect the jailbreak. You can obtain the 4.0 firmware from The iPhone Wiki (which will link you to the official Apple download server).
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Something is not right. Double check everything again.
    It works with everyone else.
     
  7. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #7
    I know for a fact it doesnt work. Everything is correct. I dont know why it doesnt work, I use firmare 4 not 4.01.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    We know for a fact redsnow does work.
    Not sure what's up with your case.
     
  9. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #9
    Please give the complete exact name of the firmware files you are using, as it appears in your filesystem, including file extension.
     
  10. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #10
    I dont know, I've tried it on 4 different computers (1 running windows 7, 1 with vista and 2 with XP) Ive re-downloaded each of the files 6 times, nothing is working, I keep getting the same error.

    File names
    iPhone1,2_4.0_8A293_Restore.ipsw
    redsn0w_win_0.9.5b5-2.zip
    Extracted redsn0w: redsn0w.exe
     
  11. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #11
    Holy crap! its working for what ever reason, its decided to work:D
     
  12. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #12
    1) Are you quite sure you have a 3G, not a 3GS?

    2) You are not perchance unzipping the ipsw after downloading them, are you?

    3) Someone posted earlier that s/he had to take ownership of the ipsw when using redsn0w on Win7. You could try that.
     
  13. sparrky macrumors 6502a

    sparrky

    Joined:
    Oct 23, 2008
    Location:
    California
    #13
    It may not make any difference, but I have the same set up and used redsn0w_win_0.9.5b5-5 ... I uploaded it if you want to give it a shot.

    link
     
  14. j3yq macrumors 6502

    j3yq

    Joined:
    Dec 16, 2007
    Location:
    Iowa
    #14
    So did you point it to 4.0.1 or 4.0, I'm on 4.0.1 and when I point to 4.0.1 it won't reconize it...
     
  15. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #15
    Yeah, point it to IOS 4 and use redsn0w 0.9.5b5-5
     
  16. j3yq macrumors 6502

    j3yq

    Joined:
    Dec 16, 2007
    Location:
    Iowa
    #16
    Awesome thanks
     
  17. neenja macrumors 6502

    Joined:
    Jul 17, 2008
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
    The op is not such a SuperHacker as his name indicates I guess:D
     
  19. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #19
    I would say that it's because for the first time you actually followed our instructions correctly.
     
  20. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #20
    hahaha touche
    one more question, can I restore in itunes and jailbreak it again?
     
  21. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #21
    Yes, you can. Also, you should make sure to get your SHSH on file and backed up locally as soon as possible.
     
  22. SuperHackerSW thread starter macrumors newbie

    Joined:
    Jul 28, 2010
    #22
    woah woah woah not so much techno jargon, still new to this lol:rolleyes:
     

Share This Page