Redsn0w crashes during 4.2.1 jailbreak on my iPhone 4

Discussion in 'Jailbreaks and iOS Hacks' started by PaHtSaN, Nov 24, 2010.

  1. PaHtSaN macrumors regular

    Joined:
    Oct 2, 2010
    #1
    It crashes right after the white screen. Then i end up with my phone in DFU mode with the "Downloading Jailbreak Data" icon and I have to kick it out.

    Is this happening to anyone else? Any solutions?

    Btw, I am using 0.9.6 that I dled from the latest Dev Team blog post.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Try using Redsn0w 0.9.6b4
     
  3. 3goldens macrumors 68000

    3goldens

    Joined:
    Feb 26, 2008
    #3
    try being patient and waiting for the proper untethered jailbreak.
     
  4. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #4
    qft
     
  5. PaHtSaN thread starter macrumors regular

    Joined:
    Oct 2, 2010
    #5
    I am, just got too lazy to type out the b4
     
  6. PaHtSaN thread starter macrumors regular

    Joined:
    Oct 2, 2010
    #6
    lol, thanks for the tip. Im patient, I just like to experiment w all this ish. Besides, tethered isn't that bad since I almost never turn off my phone.
     
  7. christopherli macrumors newbie

    Joined:
    Nov 24, 2010
    #7
    I once faild under Windows2008, Windows2003 and VMWare. After I changed to XP, it succeeded. What type of OS are you using ?
     
  8. CrAkD macrumors 68040

    CrAkD

    Joined:
    Feb 15, 2010
    Location:
    Boston, MA
    #8
    i kept getting unexpected errors on osx. used my xp machine worked perfectly.
     
  9. No ice please macrumors 6502

    Joined:
    Nov 21, 2009
  10. PaHtSaN thread starter macrumors regular

    Joined:
    Oct 2, 2010
    #10
    Vista, I have another comp thats on XP, ill try it out.
     
  11. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #11
    What's the point of doing this if mobile substrate doesn't even work on 4.2.x yet?

    Oh that's right, there is no $@#$% point.

    Big Boss said it took him 20 attempts to get the jailbreak to work. I'll wait. I'm not the crazy impatient gotta have it now type.
     
  12. DN7335 macrumors 6502

    Joined:
    Jun 9, 2008
    #12
    Same issue - fixed

    I was having the same issue, kept crashing during RamDisk Upload. It worked on another computer, so I started playing around and figured out that redsn0w needs to run as an administrator. I'm on Windows 7, and even if you're logged in with an admin account, you still need to specify Run As Administrator for enhanced privileges. Just right click on the .exe file and go to Properties. In the Compatibility tab there is a check box near the bottom to run the program as an administrator.

    Dave
     
  13. PaHtSaN thread starter macrumors regular

    Joined:
    Oct 2, 2010
    #13
    I ran as administrator manually and it still crashes, used run as admin + xp compatibility mode it crashes, used a different computer that has XP, it still crashes, or it just gets stuck on the "waiting to reboot" step before it even has a chance to crash.

    I tried both putting the phone in DFU before starting the process, and following the steps on the screen to go into DFU, same result both times.

    I've never had so much trouble with a jailbreak before, whats going on?
     
  14. tablo13 macrumors 65816

    tablo13

    Joined:
    Jul 29, 2010
    Location:
    Edmonton, Alberta, Canada
    #14
    Have the same problem. Mine crashes in the "uploading ramdisk" stage.
     
  15. PaHtSaN thread starter macrumors regular

    Joined:
    Oct 2, 2010
    #15
    The only thing that worked for me was using my friends mac. If you know someone with a mac, put everything you need (pwnage tool, ipad OS, stock OS) on a flash drive, and just do the jailbreak on their comp.
     
  16. N3RVE macrumors newbie

    Joined:
    Mar 27, 2009
    #16
    I had this same issue while I was trying to jailbreak my iPhone 4 (4.2.1), using redsn0w_0.9.6rc8, it kept on crashing during the "uploading jailbreak data", while searching for a solution I came across this thread.
    I finally got mine to complete by setting it to run in compatability mode for Windows XP, Service Pack 2 and by checking "Run this program as an Adminstrator" under Priviledge level.
     
  17. clarisis macrumors newbie

    Joined:
    Dec 10, 2011
    #17
    TY! :D It finally works.
     

Share This Page